Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Acer UEFI mode will not resume Hibernation

08 Apr 2015   #1
ps1000

Windows 7 Ultimate x64
 
 
Acer UEFI mode will not resume Hibernation

I recently replaced my computers hard drive due to the old one failing. I decided to try and use GPT on the new disk because I want to use more than 4 partitions, unfortunately however, the old BIOS did not support UEFI booting. After much research, I discovered that it is able to boot in UEFI mode with an unlocked BIOS, so I flashed the modified BIOS and was able to set it to boot in UEFI mode. Windows installed without problems and everything is working fine, apart from one thing.

When putting the computer into Hibernation, it will display the error message "No boot device found - Please insert boot media and press any key" when attempting to wake it. Restarting the computer will make it boot and resume successfully, however.

I assume that this is a problem with the BIOS not booting EFI devices first when bringing the computer out of Hibernation.

Is this problem fixable? Should I perhaps stick with MBR in case more problems arise down the line?

PS. Sorry for my bad English, it is a second language.


My System SpecsSystem Spec
.
09 Apr 2015   #2
gregrocker

 

How do you know you installed UEFI, although I doubt it has anything to do with this issue? Did you boot the installer as a UEFI device, then delete all partitions to clear the formatting, watch it create an EFI System partition?

Is Windows Boot Manager set first device to boot in BIOS setup? Make sure now.

Can we see a screenshot of Disk Management - Post a Screen Capture Image ?

Work through the steps given here for most Sleep Mode Problems - Vista Forums .
My System SpecsSystem Spec
09 Apr 2015   #3
ps1000

Windows 7 Ultimate x64
 
 

I do not believe I have installed UEFI, I believe that the current BIOS was able to boot from EFI devices, however the option to do so was not in the BIOS until I flashed the unlocked one.

The two options I changed after the BIOS flash were:

"Boot in UEFI mode: TRUE"
"Boot from EFI devices first: TRUE"

The installer was booted as a UEFI device and Windows created the required partitions fine.

The Hard Drive was new, so it was not partitioned until I created one in the installer.

Attached is a screenshot of Windows Disk Management, and one from Partition wizard. Partition wizard shows a partition that Windows Disk Management does not.


Maybe I am misunderstanding, but I do not think you can set Windows Boot Manager as first device in the BIOS? The Hard Drive is set as first device.

I read through "sleep mode problems - vista forums", but unfortunately nothing helped.

Thank you for your help.


Attached Thumbnails
Acer UEFI mode will not resume Hibernation-disk-management.png   Acer UEFI mode will not resume Hibernation-partition-wizard.png  
My System SpecsSystem Spec
.

09 Apr 2015   #4
gregrocker

 

That partition is hidden in Disk Mgmt.

You have an EFI install, for which Windows Boot Manager is normally set first to boot and not HDD.
My System SpecsSystem Spec
09 Apr 2015   #5
ps1000

Windows 7 Ultimate x64
 
 

Ah, I understand. You were correct, after checking through the BIOS again, there was an option to set "Windows Boot Manager" as first device and once that was set, Hibernation mode worked.

Thank you for your assistance!
My System SpecsSystem Spec
09 Apr 2015   #6
gregrocker

 

Surprised it started. But then every UEFI BIOS is different.

My System SpecsSystem Spec
Reply

 Acer UEFI mode will not resume Hibernation




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup
Reboot after hibernation resume
I recently put together a new machine and it works flawlessly, except for one niggling issue. Whenever I hibernate the system and then resume it, after ten minutes of being "resumed" the system always reboots. There is no bluescreen, no error message of any kind, or any other indication that...
BSOD Help and Support
BSOD after resume from hibernation
Windows 7 Home Premium 64bit Service Pack 1 OEM System is less than one year old I have never reinstalled the OS Thanks,
BSOD Help and Support
HP Laptop Will Not Resume after Hibernation.
I've recently encountered a problem on trying to take my laptop out of Hibernate mode. The machine hibernates normally, but when attempting to resume it will display a black screen with a flashing cursor in the top right-hand corner, then get stuck there. At the moment this is more an irritation...
Performance & Maintenance
BSOD on resume from hibernation
W7 Home Premium x64--retail version HDD originally had WXP installed System was built and installed on 8/11/10 Description: System ran fine for about 5 days with following exceptions: --Two legacy IDE CD drives not recognized by W7 (not in device manager) and only one was visible in BIOS. I...
BSOD Help and Support
BSOD on resume from hibernation?
Ok guys, so I just resumed my computer from hibernation, and I haven't reconnected my camera, which I am 99.9% sure has been causing BSOD issues. That may still be true, but I just got another. "SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION" on a resume. I wish I had the software to open those...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App