Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Setup was unable to create a new system partition...."

3 Weeks Ago   #31
kermit jagger

Windows 7 Ultimate x64
 
 

"https://technet.microsoft.com/en-us/library/hh304353(v=ws.10).aspx"

Is following all these steps necessary?


My System SpecsSystem Spec
.
3 Weeks Ago   #32
kermit jagger

Windows 7 Ultimate x64
 
 

I've now formatted the USB exactly as you told me, this time choosing FAT32. It froze again at the "Starting Windows" logo.

Could it be that there's something UEFI incompatible about my hardware? I mean I doubt it but I simply have no clue what's wrong with it
My System SpecsSystem Spec
3 Weeks Ago   #33
kermit jagger

Windows 7 Ultimate x64
 
 

I've formatted the USB back to MBR and this time it goes past the Starting Windows screen. Why would UEFI mode be a problem for it?
My System SpecsSystem Spec
.

3 Weeks Ago   #34
kermit jagger

Windows 7 Ultimate x64
 
 

"Setup was unable to create a new system partition...."-n31k0st.jpg

I've deleted the partition, and created a new one. This time it's listed as primary but it still gives me the intial error.


My System SpecsSystem Spec
3 Weeks Ago   #35
samuria

win 8 32 bit
 
 

you delete the partition leave it blank let windows create what it needs you have no space to create a parition
My System SpecsSystem Spec
3 Weeks Ago   #36
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Legacy boot has to be enabled.
Post some pictures of the bios options you have
Mostly boot and os type this will need to have an option for other os

You also need to make sure the hdd = hard drive is not formatted gpt and it needs to be mbr if it is gpt you'll have to install with uefi.
My System SpecsSystem Spec
3 Weeks Ago   #37
Megahertz07

Windows 7 HP
 
 

Is your Win 7 ultimate 64 bits?
Is it SP1?
If not, download it from here Microsoft Windows and Office ISO Download Tool
My System SpecsSystem Spec
3 Weeks Ago   #38
kermit jagger

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
Legacy boot has to be enabled.
Post some pictures of the bios options you have
Mostly boot and os type this will need to have an option for other os

You also need to make sure the hdd = hard drive is not formatted gpt and it needs to be mbr if it is gpt you'll have to install with uefi.
Quote:
Legacy boot has to be enabled.
What for? I know it has to be disabled to be able to boot in UEFI mode. I enabled it back on because I've dropped it and decided to do it in regular BIOS.

The only descriptions I can find are "Insyde H20, version f.1b"

Quote:
You also need to make sure the hdd = hard drive is not formatted gpt
It's not formatted as anything. It's not marked as either GPT or MBR when I check it out in cmd.
My System SpecsSystem Spec
3 Weeks Ago   #39
kermit jagger

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Is your Win 7 ultimate 64 bits?
Is it SP1?
If not, download it from here Microsoft Windows and Office ISO Download Tool

It is. I've tried doing it manually once again by using the xcopy command in cmd. Instead of copying everything it only copied like 4 files and created a system partition with 910 gb of space, and an unallocated one with about 20gb left lol.

I honestly have no clue what to do anymore.
My System SpecsSystem Spec
3 Weeks Ago   #40
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Some times hdd manufacture pre-format drives as gpt even though it's only required for drives over 2tbs so windows will see the entire drive space

See the prior tutorial I posted and follow it to format as mbr. it is only 1tb.

Also verify you are not set to use any type of Raid configuration in your bios switch to ahci.
My System SpecsSystem Spec
Reply

 "Setup was unable to create a new system partition...."




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 x64 "Setup unable to create system partition"
Hey everyone, I've searched quite extensively and followed quite a few guides on how to install windows 7 with UEFI. I've got a Dell latitude E6540 laptop with a new WD 500GB blue HD. Every time I try to install Windows 7 Pro x64 I get the: "Setup was unable to create a new system partition or...
Installation & Setup
"setup was unable to create new system partition" no error log
Hi. Just spent the last 48 hours trying to install a fresh Win 7 on my pc. I used Ubuntu before and formated the drive from GParted in Ubuntu. I'm running into the error: "setup was unable to create a new system partition or locate an existing system partition" I have tried: 1. Running...
Installation & Setup
"Setup was unable to create a new system partition" even after format
I had a completely unexpected system failure while I was checking my email one day. Windows shut down unexpectedly. When I restarted, there was no OS detected. Afterwards, I decided to do a fresh install of 7 from a bootable USB. During install, I was unable to install to my SDD when windows...
Installation & Setup
"Setup was unable to create a new system partition..." Help please!
"Setup was unable to create a new system partition or locate an existing partition". I had my PC multi-booting between Win7 & XP, using EasyBCD to create the boot menu at startup. But there has been a problem with the XP installation and today I deleted it and installed a different version (of...
Installation & Setup
Error message of "Setup was unable to create a new system partition"
Let me start off my saying I've installed this exact copy of windows 7 before on this computer with no problems and it worked for years. I'm trying to install Windows 7 ultimate 64 bit version when I run into this message "Setup was unable to create a new system partition or locate an existing...
Installation & Setup
"Setup was unable to create a new system partition or locate existing"
Last night after 8 hours of toil, I finally completed a clean install using a usb drive on my asus ux32vd using the brand new SSD drive I had just bought. The reason it took so long was I kept getting this error -> "Setup was unable to create a new system partition or locate an existing system...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App