Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: no boot option screen

26 Jan 2010   #31


hi gregrocker,
yes, boot.ini is also in C:\
I tried removing Win7 in the Add/Remove tab, then added it again;
still won't boot into Win7 - it gets to the "Starting Windows" screen and then shuts down.
Booting to XP is not a problem.

My System SpecsSystem Spec
26 Jan 2010   #32


I'm not sure why Win7 HD is set first HD to boot in BIOS since XP holds the System Active MBR.

Try entering BIOS setup to set XP HD first HD to boot (after DVD) and report back what happens with dual boot.

See if you get the same drive listings by booting Partition Wizard CD. That Disk0 HD might still hold the MBR and isn't showing it now.

How much trouble would it be for you to plug XP into Disk0 slot and Win7 into Disk1 slot, then set XP as first HD to boot without the data drive plugged in. Next try Win7 as first HD to boot w/o data drive.
My System SpecsSystem Spec
26 Jan 2010   #33


I can set the XP drive to be first boot and see what happens, although I thought the Win7 bootmgr was the one that controlled things once Win7 has been installed? - I don't fully understand the boot process though.

I was thinking another fresh install of Win7 might fix things up, so I tried that, but I'm still in the same spot - Win7 can't/won't boot. I'm wondering if the install itself isn't quite finishing as I'm running into this problem at the very end of the Win7 install process - it may never have quite finished as it couldn't boot back into Win7, although it did at least once during the install.

The remaining data drive (Disk 1 according to PartitionWizard) is connected to a SATA card - not directly to the motherboard. Could this drive also be interfering with the install as I believe the PATA drive was? I could disconnect this one too and try the install once more. I'll have to try that tomorrow though as its getting late...

oh, I forgot mention - after trying to reinstall Win7 again, I noticed my E: drive (Win7 ) is no longer active. Is this to be expected?

thanks for your patience and help.
My System SpecsSystem Spec

26 Jan 2010   #34

Windows 7 x64

I think if I were gregrocker, I would suggest you take out all the drives except the win 7 drive. Get Win 7 running and worry about the rest later.
My System SpecsSystem Spec
27 Jan 2010   #35


I agree with Saltgrass. If you unplug all of the other drives and install Win7 by itself, then you can plug back in the XP drive, set one as default to boot first in BIOS, or choose the other by using the BIOS shortcut key given on first bootup screen for Boot Menu.

This keeps the HD's independent and can come and go as you please.

If you're set on having a Windows-managed Dual Boot, you can try adding XP from Win7 using Easy BCD or try another Win7 install with only the 7/XP HD's plugged in.

If you are pre-formatting the Win7 drive to set it Active, this is not necessary - use the Win7 DVD Custom Drive Tools to format.
My System SpecsSystem Spec
27 Jan 2010   #36

WIN 7 x64

A maximum of four primary partitions can be placed on any hard disk. The limitation of four is one that is imposed on the system by the way that the master boot record is structured. Only one partition may be designated, at any given time, as active. That partition will be used for booting the system.

So only 1 ACTIVE partition !!!!

And bootmgr , boot folder with BCD and ntldr should be on that partition as far as I know.

BCD should be something like this:
Windows Boot Manager
identifier              {bootmgr}
device                  partition=D:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {e183bfc2-0b9a-11df-8e0a-c37636dd1cce}
displayorder            {ntldr}
toolsdisplayorder       {memdiag}
timeout                 5

Windows Legacy OS Loader
identifier              {ntldr}
device                  partition=D:
path                    \ntldr
description             Earlier Version of Windows

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {e183bfc4-0b9a-11df-8e0a-c37636dd1cce}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e183bfc2-0b9a-11df-8e0a-c37636dd1cce}
nx                      OptIn
My System SpecsSystem Spec
27 Jan 2010   #37


I tried installing Win7 once more with only the two physical drives connected.
SATA 2: Win7
Exactly the same thing happened - dual-boot was setup fine, but I can't boot into Win7 - in fact, the install never really finishes...

Quote   Quote: Originally Posted by gregrocker View Post
I'm not sure why Win7 HD is set first HD to boot in BIOS since XP holds the System Active MBR.
I can set either HD to boot first, it doesn't seem to make any difference. What I don't get is why my XP drive holds the System Active MBR... shouldn't this be on the Win7 drive and should I not have only one active drive and maybe that is why Win7 won't boot? Maybe there's something I'm missing about how the MBR works.

If I unplug the XP drive and install Win7 with just the one drive connected, will I run into problems booting into XP once its connected again? You can understand my concern - I really don't want to be stuck without XP as my experience with Win7 so far is pretty in I'm very close to giving up and writing it off as another MS dud.
My System SpecsSystem Spec
27 Jan 2010   #38


What you're experiencing is very unusual. For some reason, Win7 won't install correctly or configure the dual boot with XP.

It is correct for XP to be System Active as the MBR remains there and is updated for dual boot during 7 install. But Win7 partition is supposed to hold the Boot and it is not.

In this case, it is best to disconnect all other drives and install Win7 to its own drive with its own System Active Boot. Then I would set Win7 HD first HD to boot in BIOS, after DVD drive. If you decide to boot XP, use the key given on first bootup screen for Boot Menu to intervene and boot XP instead of 7.

This is actually a better way to dual boot in the eyes of many of us here since it keeps the HD's independent so they can come and go as you please.

However, if you want a Windows-managed Dual Boot, then install EasyBCD in Windows 7 and add XP on the Add/Remove tab.
My System SpecsSystem Spec
28 Jan 2010   #39


Disconnected all drives except the one SATA for Win7. It created the 100MB partition this time - I thought maybe its working... but no - it still quits near the end of the install and won't boot into Win7.

Strange though, as soon as I reconnected the 2nd SATA drive (with XP), the dual-boot option was there.
Is it stored on the XP drive then...?

Anyway, I'm right back to where I was - with an extra 100MB system partition...

I'm thinking its definitely an install problem - checking several other forums, I see many others have had the same problem.
Seems MS really messed up with this one - and its supposed to be better than Vista ???

My System SpecsSystem Spec
28 Jan 2010   #40


If you boot the Win7 DVD Repair console, does it find an installation to repair? If so, run Startup Repair repeatedly to see if it will start.

If not, try clearing the CMOS in your BIOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS

What is the SATA controller setting in BIOS?

Try installing from flash drive: USB Windows 7 Installation Key Drive - Create

Lastly, try running HD Diagnostics and memtest86.
My System SpecsSystem Spec

 no boot option screen

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Dual Boot issues, changing default boot option
I am dual booting Win7 Ultimate x64 from a SSD and WinXP Pro x64 from a HDD. After POST, i get to a boot selection screen showing the XP 2003 Server edition (XP x64) and Win7. I could enter Win7 but the default is the setup so if I don't do anything the screen times out after 30 seconds, loads...
Installation & Setup
Extra Windows 7 Boot option makes pc take more time to boot up.
So yeah, my simple issue is thaht i installed windows 7 on a hard drive, which i later replaced with a Samsung 840 SSD, which also was bootable. So now ive got 2 windows 7 options to boot from, and the only bad thing there is is that it takes 30 extra seconds to boot up, which isnt that much of an...
Installation & Setup
Window 7 Pro and Windows 8 Pro Dual Boot (No option at boot up)
I am not getting the screen asking me to choose which Operating system at boot up. It gives me no options and just Boots straight to the C drive where I have Windows 7 Pro. In preparation I shrunk the Volume of the C drive and created a new partition (E) in which I made it a simple volume NTFS . I...
Installation & Setup
Advanced boot option doesn't show the option "repair your computer"!
Hey, I have a HP Pavilion notebook. A bit older I think. It had built in windows Vista Home Premium. Somehow my hard disk crashed and I bought a new one. I installed windows 7 ultimate 32 bit and updated to service pack 1. I made a system image using windows default recovery console. Everything...
Performance & Maintenance
Can't access Boot Option screen or Safe Mode
Don't know why I can't access Boot Option screen via F12 or Safe Mode which I think is F8. I have tried about 12 times in one way or another.
Installation & Setup
Boot screen Problem: The XP option restarts the PC
Hi. I had W7 7057 & XP running Fine, Dual Boot was working fine On The Same Disk but different partition: c: / W7 7057 d: / XP To install the W7 RC 7100 i've formatted the c: partition and installed on it. No problems at all during installation. W7 RC is running Fine.
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:48.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App