Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Hard drive full capacity not recognized

07 Feb 2010   #1

Ubuntu 9.04, Win XP sp3, Windows 7
 
 
Hard drive full capacity not recognized

Only in Windows 7 at the install screen. Even after a fresh install and adding updates, it won't see it. However, if I plug drive in as slave, xp sp3 will recognize the full capacity. Bios recognizes full capacity and all the partitioning softwares recognize the full 320GB. Ironically, I can only access 137 gb. This makes me wonder about the 48bit LBA. But this can't be the case since everything else sees it, right? Why won't windows 7 see the hard drive's full capacity but other OS, partitioning softwares, and the bios recognize the full 320gb? Trying to install Windows 7 x86 Ultimate.



Attached Thumbnails
Hard drive full capacity not recognized-comp-manage.jpg   Hard drive full capacity not recognized-pict0014.jpg  
My System SpecsSystem Spec
.

08 Feb 2010   #2

Windows 7 Home Premium (64 bit)
 
 

I'm not sure about what might be causing the problem, but it may have been that the disk has an error? Go to computer and right click your C drive and check the volume for errors on one of the tabs. If there isn't an error, you might want to check your hard drive from your bios. If that doesn't work, go to your internal hard drive company and download another driver, one that is updated for windows 7 perhaps.
My System SpecsSystem Spec
09 Feb 2010   #3

Ubuntu 9.04, Win XP sp3, Windows 7
 
 

That's one of the first things I did. The drive in question is a western digital WD3200AAJB. Went to the site just now to check again. There are no drivers expect for a specific controller card, which I am not using. As I said earlier, everything else recognizes the drive and it's full capacity. There are no error either. BTW, I never did mention that I am not using any type of RAID.
My System SpecsSystem Spec
.


09 Feb 2010   #4

Windows 7 Home Premium (64 bit)
 
 

" I never did mention that I am not using any type of RAID" ...wait does that mean you are using raid?
Also, don't forget especially to check your chipset driver. Many chipsets control the hard drive.
Sorry im no help...
My System SpecsSystem Spec
10 Feb 2010   #5

Ubuntu 9.04, Win XP sp3, Windows 7
 
 

Sorry for the confusion. NO RAID.
My System SpecsSystem Spec
10 Feb 2010   #6

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
10 Feb 2010   #7

Ubuntu 9.04, Win XP sp3, Windows 7
 
 

Theog, I looked at that link you posted. I appreciate your posting that link. My motherboard controller supports 48bit LBA. The bios shows the capacity as 320GB. Most of the partitioning softwares out there show the whole capacity. If I was experiencing the 137GB barrier, how can the bios, all partitioning programs that I have tried, and windows xp see the full 320GB?
My System SpecsSystem Spec
10 Feb 2010   #8

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Have you checked the jumpers so it does not limit the size when formatted ?


Attached Thumbnails
Hard drive full capacity not recognized-wd_320caviarblue.jpg   Hard drive full capacity not recognized-wd_320caviarblue_2.jpg  
My System SpecsSystem Spec
17 Feb 2010   #9

Ubuntu 9.04, Win XP sp3, Windows 7
 
 

Currently, I have it pinned as cable select. But I have tried it as master and got the same results. I have even tried disconnecting all devices and booting/installing from a usb. Still got the same result.

Since my last posts on here, I have messed with it much. But the last thing I tried was to install Windows 7, setting the partition to only 100gb. This way it showed two partitions, a 100gb and a 30.27 unallocated space. I let windows create it's little 100mb partition but then I deleted the 100gb partition and resized the 100mb to 100gb and chose to install windows 7 there. So I got the system up and running and used it for a couple of days, checking for updates, yada, yada. Then I decided that I would try dual booting with ubuntu 9.10. Using the ubuntu live cd with gParted, I took the unallocated space (200gb in gparted, but Windows 7 only showed 30gb), and created an extended partition with three logical partitions. One 50gb for ubuntu, one 5gb for swap, and the remainder for files. I installed ubuntu and let it rewrtie the mbr so I could use grub. As you can imagine, when I went to boot Windows 7, I got the bootmgr missing error. Normally, I'd be fine with that. But when I let windows "fix" it's errors, it finds no operating system. I have searched the web and tried all kinds of solutions but nothing works. Yes, even the command line solutions, like bootrec.exe /fixboot. That one tells me "element not found" This one doesn't work either,
bcdedit /export C:\bcd_backup
c:
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /rebuild bcd
This one is supposed work if the system repair finds no operating system, according to microsoft's website. Well it doesn't in my case. I've tried it 4-5 times. When I type the export command, I get the message "export operation failed, requested system device cannot be found". WTF? Anyway, I went anyway and typed the rest of the commands anyway just for kicks. When I type the rebuild bcd command, I get this message, "rebuild - found 0 identified windows installations"

So I have concluded that I have a bad Windows 7 disk or something because I have even wiped the hd clean and went with a clean install of Windows 7, no fancy partitioning, nothing. Simply boot to Windows 7 disk, install to hd and let it be even though that's not what I want. The install went well, as expected. So I resized the partition with gparted and I still have the same exact problems as above when I try to fix the bootmgr after simply just resizing the existing partition. And I only shrunk it from 127gb to 100gb and left the rest to unallocated space. Even doing that, the windows 7 repair can't fix it's own problem. I did the same thing again this time trying partition wizard v4.2.2, getting the same result.

So currently, I am writing zeroes to the hard drive. Completely erasing it. If that doesn't make windows 7 installation disk see the whole hard drive, then I am going to try a different installation disk. I am using Windows 7 ultimate 32bit and I have a 64 bit system.
My System SpecsSystem Spec
Reply

 Hard drive full capacity not recognized





Thread Tools



Similar help and support threads for2: Hard drive full capacity not recognized
Thread Forum
Loss hard drive capacity Hardware & Devices
Solved Home Premium 32bit not recognising full capacity of 3tb drive Hardware & Devices
Solved Hard Drive capacity question. Performance & Maintenance
External Hard Drive reduced max capacity Hardware & Devices
Solved Windows doesn't recognize full capacity of hard drive Hardware & Devices
Hard Drive Capacity Issue Hardware & Devices
Hard drive full capacity not recognized Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33