Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't boot without DVD with SCSI Raid Card and IDE


15 Mar 2010   #1

Windows 7 Ultimate 32
 
 
Can't boot without DVD with SCSI Raid Card and IDE

Did a clean install with OEM Ultimate to a card based SCSI Raid 0. Formatted drive and windows recognizes without drivers. During partitioning windows automatically created two partitions a very small partition and second which is deemed bootable primary. Install went fine and can boot without dvd. Attached a 500 storage drive to the primary (also tried secondary). Bios recognizes it and set last on the boot order. Now system will not boot UNLESS the dvd is in the drive. Installed the OS to that IDE drive and left the OS on the raid - now will boot using the SCSI. Also tried installing the raid cards native drivers (vista based) same result - still creates a phantom partition.

When I looked at the small partition of the RAID it has a bunch of files - bootmgr,etc on the partition. I'm assuming that when the system boots it goes somehow thinks initially the IDE is the start drive. Tried all combinations of start drive in the bios - still does the same thing.

Question: How can I fix this so that I don't have a copy of the OS on both drives. Be more than happy to provide more information if needed.

My System SpecsSystem Spec
.

15 Mar 2010   #2

Windows 7 Professional x64
 
 

Welcome!

Try a startup repair. You may need to run it as many as 3 times.

Be sure to have the drive attached when you run it.
My System SpecsSystem Spec
15 Mar 2010   #3

Windows 7 Ultimate 32
 
 

Did the startup repair a few times - still same result. Seems like a BOOTMGR issue with this particular setup. Knows the drive is there - the hidden boot partition (files complete) and it will BOOT fine as long as the IDE drive is not attached. So to me it seems like when its booting and senses the IDE drive it thinks its the boot drive. If no ide attached only the card based SCSI raid 0 it boots fine.

Don't know how to correct this. I'll post a snap of the bootmgr dump and see if someone can see if there is an error later today.

Also will list the drives in the system and order.
My System SpecsSystem Spec
.


15 Mar 2010   #4

Windows 7 Professional x64
 
 

Try marking the Windows 7 partition as Active and run startup repair again: http://www.sevenforums.com/installat...-problems.html
My System SpecsSystem Spec
15 Mar 2010   #5

Windows 7 Ultimate 32
 
 

Still no go - tried it a few times. Question do you set the "hidden" partition (100mb) as active or the true drive as active. Asking because the hidden system reserved drive actually seems to have the boot information. Tried both still no go.

Heres the bootmgr info if that helps. Seems to hardcode C but I'm not sure will have to run it again - in recovery DISKPART I think it assigned it as D although in disk management after bootup it shows C: as the primary (copy of windows). Any insight would be helpful. Starting to really bug me.




My System SpecsSystem Spec
16 Mar 2010   #6

Windows 7 Professional x64
 
 

Try deleting the system reserved partition. I just wrote this tutorial today: System Reserved Partition - Delete
My System SpecsSystem Spec
16 Mar 2010   #7

Windows 7 Ultimate 32
 
 

Thanks will try it tonight when I get home. Makes sense - the only thing weird about the setup is that when just the SCSI/Card is attached and I pull the IDE drive it works without the DVD being in the drive. Don't know if its just a SCSI/raid issue but I think it still will happen with a SATA card as well. Think somehow either the drive assignments dynamically change or maybe the SCSI drivers are being loaded AFTER the ide is detected - don't know have to look at the bootlog. Remember did have this problem when I loaded a trial version of VISTA but didn't take it any further because I hated VISTA.
Any case will try it can't hurt.
My System SpecsSystem Spec
16 Mar 2010   #8

Windows 7 Ultimate 32
 
 

Deleted the partition and did the repair. When I have only the SCSI attached it will boot fine without the disk - but it did that before. When I attach the IDE drive still get the missing operating system error.

I checked within the console from the DVD and its showing that the SCSI drive is D and the IDE is C. The SCSI is the boot drive. BUT when I fully boot (with DVD in) and it boots up windows - in DISK MANAGEMENT its showing the active part, boot drive, etc. as C (really is the SCSI drive). Seemed like it flipped order - Is this the problem?

Checked the boot order within the bios:

Gives options for devices:

Have CD ROM
Have Hard Disk

In boot order have:

SCIS (with id)
Bootable Add In Card
IDE drive (Seagate)

Tried reversing it so that the IDE is first and I get an error missing BOOTMGR.

Tried reassigning the SCSI which shows in DISK manager after bootup with the DVD in the drive to D and I get PARAMETER INCORRECT. In BCDEDIT bootmap shows C: as the boot drive.
My System SpecsSystem Spec
17 Mar 2010   #9

Windows 7 Professional x64
 
 

This may be a controller issue. Maybe the card isn't fully compatible with your motherboard?

Try this. During the Power On Self Test (POST), press the F11 or F12 key to access the boot popup menu. Then manually select your drive from the list.

Note: by default, the popup menu may be disabled. Look around in the BIOS for the option.
My System SpecsSystem Spec
17 Mar 2010   #10

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Set BIOS to boot Disk1 first boot drive.

OR

1) Make a partition 100mb on IDE boot drive.(40gb)
2) Copy all files from 100mb System Reserved to new partition.
3) Do a Startup Repair 3 to 4 times.

OR

If it was me, I would install Win 7 to the 250gb drive, & use the 40gb for Data Save.
My System SpecsSystem Spec
Reply

 Can't boot without DVD with SCSI Raid Card and IDE




Thread Tools



Similar help and support threads for2: Can't boot without DVD with SCSI Raid Card and IDE
Thread Forum
Raid card will not boot with drive installed Hardware & Devices
Driver scsi raid lsi megaraid 320-2x pci-x u320 Hardware & Devices
Cannot boot from non-RAID image restored to RAID SSD Backup and Restore
what scsi card works H-RS880-uATX motherboard Hardware & Devices
How to load win7 on scsi raid systems? Installation & Setup
Scsi/Raid Host Controller - HELP Hardware & Devices
SCSI/RAID Host Controller Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:57 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33