Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Devices and Printers freezes

18 Apr 2009   #1
zynex

Windows 7
 
 
Devices and Printers freezes

Hi.

I've installed Windows 7 Beta 7077 several times now, and every time when I installed the drivers for the system (just UPEK Fingerprint reader new drivers, rest is Windows own drivers) it causes "Devices and Printers" to freeze up, not showing anything. Also I have noticed that the Bluetooth unit can't find any devices after that. As I can understand I can't install my printer now either?

Any solution to this problem?!

Attachment 8356


My System SpecsSystem Spec
.

18 Apr 2009   #2
nate42nd

Windows 7 Professional x64
 
 

You might try right clicking "computer" click the "hardware" tab and choose to adjust hardware installation settings. There is an option there to let Windows install drivers or ask you before or let you do it. I wonder if this is the solution to the problem you are having. Hope it helps.
My System SpecsSystem Spec
18 Apr 2009   #3
zynex

Windows 7
 
 

Quote   Quote: Originally Posted by nate42nd View Post
You might try right clicking "computer" click the "hardware" tab and choose to adjust hardware installation settings. There is an option there to let Windows install drivers or ask you before or let you do it. I wonder if this is the solution to the problem you are having. Hope it helps.
Unfortunately not. The hardware is installed, and uninstalling the hardware dosn't seem to work either. Looks like the system can't detect any hardware at all in "Devices and Printers" any longer, and other hardware (like Bluetooth devices) as well.
My System SpecsSystem Spec
.


18 Apr 2009   #4
zynex

Windows 7
 
 

I can abort the search (with X in the window), but the result just looks like this.

-scrshot.jpg


My System SpecsSystem Spec
18 Apr 2009   #5
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Do a system restore and don't install the fingerprint drivers
My System SpecsSystem Spec
18 Apr 2009   #6
zynex

Windows 7
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Do a system restore and don't install the fingerprint drivers
I have tryed that to, without success. I'm not sure it's the UPEK Fingerprint driver that's the problem either. I't works a couple of reboots, but after 3-4 reboots it stops working, so it's hard to know whats going wrong
My System SpecsSystem Spec
18 Apr 2009   #7
nate42nd

Windows 7 Professional x64
 
 

That is strange. I was thinking it may be installing a driver before you get a chance to install your own for the fingerprint reader and messing things up. Guess not. If the restore does not work....I would not have an "easy" solution. (repair maybe)
My System SpecsSystem Spec
18 Apr 2009   #8
zynex

Windows 7
 
 

Quote   Quote: Originally Posted by nate42nd View Post
That is strange. I was thinking it may be installing a driver before you get a chance to install your own for the fingerprint reader and messing things up. Guess not. If the restore does not work....I would not have an "easy" solution. (repair maybe)
I have reinstalled the system 5-6 times the last 24h to figure out what's going wrong, from that CCleaner removes something to drivers or programes that mess things up. I tryed to add a new user also, but the problem is still there in the new users account. Frustrating
My System SpecsSystem Spec
18 Apr 2009   #9
johngalt

 

If you're using CCleaner every time - stop.
My System SpecsSystem Spec
18 Apr 2009   #10
zynex

Windows 7
 
 

Quote   Quote: Originally Posted by johngalt View Post
If you're using CCleaner every time - stop.
Hehe, after 10-12 reinstallations i figured that CCleaner messed things up badly. Works like a charm now I'll keep away from cleaners for now. Hope there will be a update soon tho. Think CCleaner messed up the registry somehow.
My System SpecsSystem Spec
Reply

 Devices and Printers freezes




Thread Tools





Similar help and support threads
Thread Forum
No printers visible in Control Panel > Devices and Printers
I finally came up with a solution to this problem. No printers were showing up under Control Panel > Devices and Printers. All printers were visible using print command in any software. I just couldnt set a default printer, remove obsolete printers, etc. I then found the "Print Management"...
Hardware & Devices
Printers not showing up in Devices and Printers
This is the second time I have had this problem and I cannot remember what I did to fix it the last time. I have been searching for the last couple of hours and nothing is working. When I try to print I get the message that no printers are installed. What I have tried: Found print...
Hardware & Devices
Devices and Printers
I added a wireless printer to my PC and whenever I go into Start\Devices and Printer\ I get nothing...An window. I do know the printer was added because when I go to print I get the option to choose the printer. Can I repair this somehow.....? Maybe with the Windows 7 disk? Thanks
Hardware & Devices
Installed printers not displayed in Devices & Printers
Hi I have installed the following printers: Epson LX-300+II, HP Laserjet 1010, HP Colour Lasterjet 1515, Canon IP5200. The printers work and are all displayed from Word, IE, etc, but only one printer shows up in Windows 7 Devices & Printers - usually whichever is selected as default...
Hardware & Devices
Let's see your Devices & Printers
I just glanced at my Devices & Printers a few minutes ago and noticed that there is a lot of items in there. So, lets see what everyone's looks like. Here is mine on my Desktop machine,
Chillout Room
No devices or printers showing in Device and printers
I've got an HP 8440p which has a Window 7 32 bit build. It's not showing anything in Devices and printers. I'm unable to get any answer other than rebuild from my fellows techs. I'm hoping someone out there has a better fix. Thanks...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App