Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dual boot using VHD not working


13 May 2010   #1

Windows 7 x64
 
 
Dual boot using VHD not working

Hi all , firstly i'd like to say this forum is the BEST it has helped me out on more than a few occasions! Secondly a little background , i am a junior IT tech so can build pcs etc but a lot of the command prompt stuff goes over my head!
Here's what i wanted to do - have windows 7 ultimate installed in a protected environment for testing software etc without having another pc or risking my current data and install.
My HDD is 1 TB , made up of 4 partitons C: 200gb with 127 free , D: 365gb with 166 free , E: 365gb with 223 free and Z: system reserved 100 mb.

So i considered VM ware and virtual pc to test things but ideally I want to use all my system resources as i do a lot with video editing etc so came across this tutorial.

All went fine until the create vdisk command , i went for 40960 mb as per your tut and got this message - diskpart has encountered an eror. There is not enough space on the disk. See the system event log for more information. I tried with 1024 mb to test and got the same error. I then tried with the same command but with E: instead of C: and it carried on to create the VHD and completed the windows installation which then updated etc. All good i thought.

Restarted the PC to go to my default OS no problem went to advanced system properties and changed the default OS to original as it was set to the VHD and changed the time down to 10 seconds instead of 30.

Restarted again but now it will only boot to my original OS whichever boot selection i make! even more strange is that the VHD image is on a folder in D: drive! As above this was installed to E:! in the VHD folder I can see all the windows os files but cant get it to boot.

Sorry for the long winded post and any help is much appreciated.

My System SpecsSystem Spec
.

13 May 2010   #2

Windows 7 x64
 
 

So a quick update , I started the process again. Got the same error when trying to create a VHD with a 25 gb size on C: even after moving some data giving about 150 gb free space. Installed to D: no problem as before. The problem seems to be when i use easybcd to rename as they are both called windows 7 , both boot options then point to my old os not the vhd file. I'm sure there's an easy fix to this just dont know what , HELP!
My System SpecsSystem Spec
14 May 2010   #3

Windows 7 x64
 
 
HELP!

OS is 7 Ultimate by the way - is anybody there!
My System SpecsSystem Spec
.


Reply

 Dual boot using VHD not working




Thread Tools



Similar help and support threads for2: Dual boot using VHD not working
Thread Forum
Dual Boot not working Installation & Setup
7 is not working after dual boot with ubuntu Installation & Setup
Dual Boot mouse not working Hardware & Devices
Internet not working with dual boot Network & Sharing
Dual boot-Stopped working! Installation & Setup
Dual boot not working Installation & Setup
Need Help getting dual boot working! Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:31 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33