Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: hey need help with sata HD :(

10 Jun 2010   #1
champ

 
 
hey need help with sata HD :(

hi guyzz i installed windows 7 on my new sata HD n it works fine but when i try to isnatll xp it gives error when i try to install it, i tryed everything plz help me i have motherboard of gigbyte i relly want xp with 7 plzzz help me out here


My System SpecsSystem Spec
10 Jun 2010   #2
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Hi Champ, I suspect your problem is with ACHI drivers, XP doesn't come with them by default.

You have 3 options here:
1. Go into your BIOS and find your hard drive settings, change ACHI or SATA to IDE mode.
2. If you have a floppy disk drive you can load your SATA drivers into XP SATA Drivers - Load in Windows XP Setup on Dual Boot
3. Slip stream the drivers into the XP disk SATA Drivers - Slipstream into Windows XP CD
My System SpecsSystem Spec
10 Jun 2010   #3
champ

 
 

My System SpecsSystem Spec
10 Jun 2010   #4
severedsolo

Windows 7 Ultimate X64 SP1
 
 

yup as i thought, ACHI, change Onchip SATA type to IDE and that should fix it
My System SpecsSystem Spec
10 Jun 2010   #5
champ

 
 

so which one do i change n am i in the right section in my bios if im can u tell me which option i go in n change it
My System SpecsSystem Spec
10 Jun 2010   #6
severedsolo

Windows 7 Ultimate X64 SP1
 
 

In your screenshot of your BIOS you have Onchip SATA type ACHI selected, that is the option you need to change, every BIOS is different, but it SHOULD have an option that says IDE mode or just IDE
My System SpecsSystem Spec
10 Jun 2010   #7
champ

 
 

i changhed it to nativ ide mode n the setup loads after i install can i change it back to ahci?
My System SpecsSystem Spec
10 Jun 2010   #8
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Quote   Quote: Originally Posted by champ View Post
i changhed it to nativ ide mode n the setup loads after i install can i change it back to ahci?

That SHOULD be ok, but you will need to install the drivers for your SATA controller before doing so, or XP won't load can you please fill out your system specs in User CP so I can find the right drivers for you? If you don't know your specs then Speccy is a great little utility Speccy - System Information - Free Download
My System SpecsSystem Spec
10 Jun 2010   #9
champ

 
 

wohoo its formatting :yahoo: i gave tht partition 20gb can i extend it later on?
My System SpecsSystem Spec
10 Jun 2010   #10
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Quote   Quote: Originally Posted by champ View Post
wohoo its formatting :yahoo: i gave tht partition 20gb can i extend it later on?
yes that shouldn't be an issue, if you post a screenshot of your Disk Management screen we can advise you on the best way to do that. (From Windows 7 click start, right click computer, click manage then click Disk management)
My System SpecsSystem Spec
Reply

 hey need help with sata HD :(




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:19 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App