Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Is clean install still working?

29 Jun 2010   #1
illway1

Windows 7 Home Premium 64 bit
 
 
Is clean install still working?

I have seen a lot on clean installs but all guides are from like 2009. Is clean install still a way to install windows 7 with upgrade disc on a new hdd?

Also if this is possible... since i have a hdd with vista on it and i have the licence how do i install 7 with the licence and a black hdd?


My System SpecsSystem Spec
.

29 Jun 2010   #2
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Hello Illway, and welcome to Seven Forums.

Yes, they still work. That is just the date that the tutorial was first created on, but all of our tutorials are constantly updated for any changes.

Clean Install with a Upgrade Windows 7 Version
My System SpecsSystem Spec
29 Jun 2010   #3
illway1

Windows 7 Home Premium 64 bit
 
 

so how do i install with the blank hdd/ with upgrade/ with licence?

Also are there any cons besides all my stuff getting deleted with clean install?
My System SpecsSystem Spec
.


29 Jun 2010   #4
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

The tutorial link above can help show you step by step on how to do a clean install with a retail upgrade Windows 7 disc.

That would be the only con to a clean install.
My System SpecsSystem Spec
29 Jun 2010   #5
illway1

Windows 7 Home Premium 64 bit
 
 

once 7 is set up dont i need to update drivers?

which drivers do i need to update and where can i find them?
My System SpecsSystem Spec
29 Jun 2010   #6
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

All i can say at this time update all drivers, we need your full spec.

Can you post your specs.
Filling out System Specs
My System SpecsSystem Spec
29 Jun 2010   #7
illway1

Windows 7 Home Premium 64 bit
 
 

msi 870a-g54 mobo
amd phemon II x4 3.2ghz black edition
g skill 2gb ram ddr3 1600 (2) so 4 g in totall
sapphire radeon hd 4670 1gb 128 bit
corsair 650w
My System SpecsSystem Spec
29 Jun 2010   #8
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
29 Jun 2010   #9
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Yes, you will need to reinstall all of your programs and drivers after doing a clean (format) install. You can usually get the drivers for your version (32/64 bit) of Windows 7 at the device manufacturer's website on their support/download page.

Here are the drivers for what you have listed above.


MSI 870A-G54 drivers:
MSI Global Computer, Laptop, Notebook, Desktop, Mainboard, Graphics and more

sapphire radeon hd 4670 (32-bit Windows 7):
Drivers & Support | GAME.AMD.COM

sapphire radeon hd 4670 (64-bit Windows 7):
Drivers & Support | GAME.AMD.COM
My System SpecsSystem Spec
29 Jun 2010   #10
illway1

Windows 7 Home Premium 64 bit
 
 

for the mobo will i need to download bios as well after windows 7 update?

btw all the parts are new im getting them the day after tommorow
My System SpecsSystem Spec
Reply

 Is clean install still working?




Thread Tools





Similar help and support threads
Thread Forum
"Application has stopped working" with clean Windows 7 install
Hi there, Recently switched a laptop for a family member back from Windows 8 to Windows 7, thought all would be fine, but am running into some issues. The laptop is an HP Envy Sleekbook 6 1126sa: HP ENVY Sleekbook 6-1126sa Product Specifications | HP Support - and their site only lists...
Drivers
clean install 7ult not working the way it should
I just built an i7-3820 on a P9X79 with a OCZ ssd and its not running as well as I thought it would. Its quick, but Im getting a lot of applications freezing up and haveing to be forced closed. It took me a few full installs to get the set up right so I had to install 7ult a few times, but I...
General Discussion
Sound not working at all after clean install of Windows 7
I got a new computer custom built a few months ago, but it came with Windows 7 32 bit, so I decided to wipe it clean and install 64 bit, for gaming purposes. It installed fine, games ran a lot smoother etc, sound was working at this point. The sound still worked up until a few days ago, when...
Sound & Audio
Boot config not working, tried clean install, can't install windows 7
My spouses pc all of a sudden wouldn't boot, not into safe mode or anything (vista), and so we were going to upgrade anyways to windows 7, so i bought the upgrade windows 7 and attempted to do a clean install and reformatted the c: drive which has 250gb, and each time i start the install it bogs...
Installation & Setup
Clean install from Upgrade disc not working
I'm a moron and figured it out, please delete the thread.
Installation & Setup
Clean install still not working correctly
Just tried to reinstall office 10 and once again, I cannot get it to work correctly. Office starts up and seems to be running fine, but the moment that I click anything I get an error. Problem signature: Problem Event Name: AppHangXProcB1 Application Name: WINWORD.EXE Application...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App