Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 and XP install --> only XP boots

31 May 2009   #21
Jayk1188

XP
 
 

Quote:
Can you explain exactly how did you install. You should not need the DISK in drive to boot at all.
EasyBCD is easy enough to use, I prefer --> orb --> type msconfig -->
move to boot... should see this: or very similar:
I burned the ISO to a DVD, then rebooted my PC and set it to boot to disk then used custom install to select the empty partition (100gb) install went without a hitch and the computer restarted. when it came to the 'press any button to boot for CD/DVD' i pressed nothing and windows 7 booted, i downloaded drivers etc which required a restart, this time i took the installation disk out of the drive, so the 'press and key to boot from CD/DVD......' part did not come up then the computer just booted straight into XP with no option to do other wise.
So i restarted again and put the disk back in the drive. the 'press and key to boot from CD/DVD......' message came up, i pressed nothing and it booted straight to windows 7.
so i did a little digging and found the /bcdedit tutorial and set up the XP part as per its instructions.
Restarted, took the disk out, straight to XP, restarted again, left the disk in, press any key message, let it time out, got a boot menu.
from this windows 7 booted fine, so i restarted to see if i could boot to xp from this menu, but it just restarted my computer when i selected it.
So i downloaded easy BCD to see if that would help, but no difference.
also tried repair install with no luck.
I have since formatted the partition, disconnected my second unused HDD and tried to reinstall, but now i get 80070017 errors, so i tried to burn a new disk and i think my DVD drive may be broken as i cannot even boot to this disk without getting I/O device errors


My System SpecsSystem Spec
.

31 May 2009   #22
Snufffed

 

Quote   Quote: Originally Posted by Jayk1188 View Post
I burned the ISO to a DVD,
(Recommend very low speed 2x to 4x no faster) then rebooted my PC and set it to boot to disk then used custom install to select the empty partition (100gb) install went without a hitch and the computer restarted. when it came to the 'press any button to boot for CD/DVD' i pressed nothing and windows 7 booted,(Did you have an option ) i downloaded drivers(this means you installed new drivers) etc which required a restart, this time i took the installation disk out of the drive, so the 'press and key to boot from CD/DVD......' part did not come up then the computer just booted straight into XP with no option to do other wise.
So i restarted again and put the disk back in the drive. the 'press and key to boot from CD/DVD......' message came up, i pressed nothing and it booted straight to windows 7.(who did you DL your ISO from)
so i did a little digging and found the /bcdedit tutorial and set up the XP part as per its instructions.(what does your msconfig look like, reason
XP should be on C:\ and Win7 should be on a different X:\)
Restarted, took the disk out, straight to XP, restarted again, left the disk in, press any key message, let it time out, got a boot menu.
from this windows 7 booted fine, so i restarted to see if i could boot to xp from this menu, but it just restarted my computer when i selected it.
So i downloaded easy BCD to see if that would help, but no difference.
also tried repair install with no luck.
I have since formatted the partition, disconnected my second unused HDD and tried to reinstall, but now i get 80070017 errors, so i tried to burn a new disk and i think my DVD drive may be broken as i cannot even boot to this disk without getting I/O device errors
That could be a good reason, if the DVD drive was crapping out, then you install was borked.
You can install from the extra HDD> that is what I do...
c:\ Vista SP2
x1:\Drive has uncompressed Win7
x2:\blank drive for Win7 install.
while booted into Vista. go to x1 --> 2x click win7 setup. and when ask install in x2:\ then you should get a msconfig like this.


Attached Thumbnails
-msconfig-win7.gif  
My System SpecsSystem Spec
31 May 2009   #23
Jayk1188

XP
 
 

Thanks for the help snuffy.
I managed to get the DVD to burn properly, not sure why it decided not to play for a while but its all good now. i downloaded from the microsoft website.
My XP pertition decided to assign itself the letter E: and i dont really wanna have to reinstall it.
I managed to get 7 to install to C: and i now get a boot screen when the install disk is not in the drive, although i have 3 options now;
Earlier verion of windows
Windows 7
Windows 7 ultimate (recovered)

Both the top options are working fine now
Im not sure what the bottom is all about but its not that big a problem.
I reconnected the unused HDD and all works fine now. I dont understand why the boot didnt work with the HDD connected through the install, but its not that big a deal now it works.
My System SpecsSystem Spec
.


31 May 2009   #24
Snufffed

 

Quote   Quote: Originally Posted by Jayk1188
I reconnected the unused HDD and all works fine now. I dont understand why the boot didnt work with the HDD connected through the install, but its not that big a deal now it works
can you give specifics on unused HDD. I have one I have to load specific drivers for it (on clean installs).
My System SpecsSystem Spec
01 Jun 2009   #25
Jayk1188

XP
 
 

Quote:
can you give specifics on unused HDD. I have one I have to load specific drivers for it (on clean installs).
It's a Samsung 120GB IDE. I didn't have to install any drivers.
My System SpecsSystem Spec
01 Jun 2009   #26
Snufffed

 

I just wanted to know, what type you had that for some reason seemd earlier to cause a problem... but a Standard IDE, unless your using a IDE Card Adapter on a SATA mobo, should make NO DIFFERENCE.
I connect my OLD IDE HDD's thru a IDE Adapter Card, which takes Special Drivers in Windows 7.
My System SpecsSystem Spec
01 Jun 2009   #27
Jayk1188

XP
 
 

Nope just plugs directly into the MB. Not sure why it wouldn't work but it wasn't too big a problem to pull the power cable out of the HDD while it installed and set-up.
My System SpecsSystem Spec
01 Jun 2009   #28
Snufffed

 

Huuuummmm you had me going there for a bit ... Win7 is touchy on how you have the code set.... do not use CABLE Select. either set it as Master or Slave. Most HDD's come from factory as cable select.
My System SpecsSystem Spec
02 Jun 2009   #29
Jayk1188

XP
 
 

It was set as master, with my DVD drive as slave origionally. I meant disconnect the 4-pin power cable so HDD receives no power and set the DVD drive as master.
My System SpecsSystem Spec
Reply

 Windows 7 and XP install --> only XP boots




Thread Tools





Similar help and support threads
Thread Forum
Win 7 wants to install program when it boots up
I installed a program WYSIWYG web building program. I built another computer with Windows 7 ultimate 64bit 8gig ram Now when windows boots up to the desktop the install screen comes on for me to install the program. Is there some place that this program is hiding a file associated with the web...
General Discussion
windows 7 boots into safe mode after clean install no matter what i do
I have clean installed windows 7 ultimate 64 several times on my HP Pavilion DV6, and no matter what it always boots into safe mode w/o networking. I have brought up the boot options, selected start windows normally, and it still boots into safe mode. does anyone have any idea how to get it to boot...
Installation & Setup
Trying to install but XP boots
Hi. Ready to start to install W7 Home Premium on my XP Home PC having passed the W7 upgrade advisor OK. Full install not upgrade. Have set BIOS to boot from CD as 1st, 2nd and also 3rd device for good measure and although I can hear disk spinning, XP boots up rather that W7 setup...
Installation & Setup
window 7 install, boots to blk screen w/ mouse
SO i jsut got a limited edition windows 7 ultimate 64bit cd and i previously has windows 7 64bit rc installed and when i install the disc i just got it installs fine and everything but when it restarts it goes to the finishing installation and then it starts to boot up but gets stuck at blk screen...
Installation & Setup
Win 7 install stops /nothing boots
I have two drives, !st with XP PRO SP3 installed. I'm going to do a clean install on it. A second drive with a partition for Win 7-7048. I've attempted two installs [dual boot, once with XP and one with Vista. Each install has stopped at the same spot. When Win 7 is finished copying files and...
Installation & Setup
How do I "install Windows on the drive from which it boots"?
I want to encrypt my hard drive with TrueCrypt, but it comes up with an error saying that "Windows is not installed on the drive from which it boots". I just reinstalled Windows 7, so it wouldn't be a huge loss to install it again in the same day, but when I install it, how do I make Windows...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App