Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Not displaying whole library

20 Sep 2010   #1

Win 7
Not displaying whole library

All right, I know that I probably have something set wrong but in Media Player (Win 7) my library now only displays the last CD I ripped as well as the last few albums I played.

It is not displaying the 200+ other albums I have (which it used to show) in my music library.

any help is appreciated.

My System SpecsSystem Spec
26 Sep 2010   #2

Windows 7

In WMP, try the following three commands

Organize - Manage Libraries - Music
Make sure your music folder is listed, change default save location if needed
(I suspect the 200 albums may be in a location not listed)

Organize - Options - "Rip Music" Tab - "Rip Music to this Location"
change default save location

Tools [Alt-t]- Advanced - Restore Media Library
If the folders above are correct and the information is incomplete, or if you move files (albums) into the folders using Windows Explorer ("Restore Deleted Items" may work also)
--I have 2300 albums and it takes a while!
My System SpecsSystem Spec
26 Sep 2010   #3

Windows 7
Rebuilding Music Media Library database

The following three steps should get you rolling:

1. Confirm the folder with your albums in the library locations, also default save location
Organize - Manage Libraries - Music

2. Check Rip Music Location
Organize - Options - "Rip Music" tab

3. Rebuild Library database, if not done when completing above (If you copied any files or folders to the folder using any means other than WMP)
Tools {Alt t} - Advanced - Restore Media Library
My System SpecsSystem Spec


 Not displaying whole library

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Unable to create the file "New
Try to create new library. Get "Unable to create the file "New" Access is denied. Found: "Unable to create the file 'New Library.library-ms' File System error (16389) The error 16389 (0x4005) is a trucation of a E_FAIL error (0x80004005)." New library commands raise...
General Discussion
WMP12 Library - Automatized Library Organization
Is there a way of making WMP organize all the library automatically looking for the albums on internet? I have several .flac files that are in the unknown section of the WMP library, more than 100 albuns and I did once organized all of them, covers and etc, but seems that when I reinstalled the...
Music, Pictures & Video
Add AudioBook library(mp3) in Media Player other than Music library
I added a new folder under the "Libraries" and linked it with source audio file(mp3) folder. But Media Player does not recognize new folder, and could not find any hint in the Media Player Help. Teach me how to re-organize, to add new library addition to default Music library, Media Player.
Music, Pictures & Video
Library Conundrum: 'Arrange By Folders' is Missing in Custom Library!
A year ago, I created a custom Library and have been using it successfully until the beginning of this week (11/7/2011). The library's folder location is similar to the following: C:\Users\USERNAME\FOLDERX Now, when I open the Library, it shows a listing of all of the files found within all...
General Discussion
Remove New Library Button in from Library Toolbar
Hello We have a GPO setting "Prevent users from adding files to the root of their Users Files folder" as we do not want users to be able to add files to their Roaming User Profile. This GPO causes an error when a New Library is attempted to be created. Because of the error we would like...
Library icon displaying slowly
I am having this problem. Iln6JH3bzJA the locations you see are either on the c: drive (downloads) or a different drive letter d: (video) Once the icons come up I have no issues accessing library (aka the pointers are working fine) and no issues accessing any files within those...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:40.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App