Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12

05 Jun 2009   #1

Windows 7 build 7100
 
 
HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12

I would be grateful if anyone could describe how they have successfully tweaked their codec set up so that MCE/WMP12 plays back .m2ts files that were encoded in VC-1 (my .264 .m2ts files playback fine) - preferably with hardware acceleration if possible. Currently, when I playback a .m2ts file encoded using VC-1 in MCE/WMP12, I get audio but no video. I know that by converting the files to .MKV, they will play back using FFDSHOW, but I have so many .m2ts files that converting them all would be a tremendous hassle. I've been spending weeks trying to figure this out. Your help would be much appreciated!

Battles

My System SpecsSystem Spec
.

05 Jun 2009   #2

W& x64 RC1
 
 

Quote   Quote: Originally Posted by Battles View Post
I would be grateful if anyone could describe how they have successfully tweaked their codec set up so that MCE/WMP12 plays back .m2ts files that were encoded in VC-1 (my .264 .m2ts files playback fine) - preferably with hardware acceleration if possible. Currently, when I playback a .m2ts file encoded using VC-1 in MCE/WMP12, I get audio but no video. I know that by converting the files to .MKV, they will play back using FFDSHOW, but I have so many .m2ts files that converting them all would be a tremendous hassle. I've been spending weeks trying to figure this out. Your help would be much appreciated!

Battles
Haha, I have been dealing with the same thing. I was actually going back and forth with Mike Healy over at Hack7MC regarding, and it appears you need to use the MPC Video Decoder filter and not FFDShow. I plan on giving it a shot tonight. See post, scroll down to the bottom of the comments section to see my dialogue with Michael.

Windows 7 Codecs - Shark007 Pack makes codec installation easy on Hack7mc.com
My System SpecsSystem Spec
05 Jun 2009   #3

Windows 7 build 7100
 
 

dbone, I tried sending you a message directly, but I'm not sure it went through. Anyhow, I left a post in the HackWin7 in the same thread that you posted above with regard to MPC. Please let me know if you have gotten it to work. I can get MPC to work outside of WMP12/MCE, but not within the WMP12/MCE environment.
My System SpecsSystem Spec
.


10 Jun 2009   #4

W& x64 RC1
 
 

Hey Battles,

Did you ever get this to work? I tried following Shark's suggestion checking off Gabest under the MPEG tag but that didn't work, and actually made things worse as the audio played back choppy (still no video). I decided to just move my ts/m2ts VC1 movies into the mkv container and now they play fine in Windows 7.

I may try putting Windows 7 on my second HTPC this weekend, and will see if I can get the ts/m2ts VC1s to work (probably just install Haali/FFDShow instead of using Shark)
My System SpecsSystem Spec
10 Jun 2009   #5

Win Xp/7
 
 

There is solution.
First ur gonna install MPCVideoDec.ax from here. Unpack files and copy decoder to system32 folder. Then Start>>cmd and run it as administrator. In command line paste bolded text ...\system32\regsvr32 MPCVideoDec.ax then press enter.
Now download this tool and choose that filter as VC-1 decoder. And ur done!
Additionaly u may check properties of decoder as it decodes many formats as default. If u want only VC-1 u have to uncheck the rest of formats.
My System SpecsSystem Spec
10 Jun 2009   #6

W& x64 RC1
 
 

Quote   Quote: Originally Posted by sirdan View Post
There is solution.
First ur gonna install MPCVideoDec.ax from here. Unpack files and copy decoder to system32 folder. Then Start>>cmd and run it as administrator. In command line paste bolded text ...\system32\regsvr32 MPCVideoDec.ax then press enter.
Now download this tool and choose that filter as VC-1 decoder. And ur done!
Additionaly u may check properties of decoder as it decodes many formats as default. If u want only VC-1 u have to uncheck the rest of formats.
I actually tried those exact steps and it didn't work. Even though I registered MPCVideoDec I am not sure my PC was registering it properly. Using Filter Manager under Direct Show Filters MPC - Video Decoder does not show up (running Vista it would show up after registering).
My System SpecsSystem Spec
10 Jun 2009   #7

Win Xp/7
 
 

Did u use 64x filter??? Just looked on ur signature.
What message u get after installing filter?
My System SpecsSystem Spec
10 Jun 2009   #8

W& x64 RC1
 
 

Quote   Quote: Originally Posted by sirdan View Post
Did u use 64x filter??? Just looked on ur signature.
What message u get after installing filter?
Yeah, I used the MPCVideoDec x64 filter. After I register the filter a popup shows saying something like "DLL service has registered successfully...". It is very weird because I am doing nothing different then in the past on my Vista machines. All those machines will show MPC Video Dec in the Filter Manager. It does not show up in the filter manager for Windows 7, so I assume this has to mean it is not getting registered properly. I will see if I can tinker around with it tonight
My System SpecsSystem Spec
10 Jun 2009   #9

W& x64 RC1
 
 

I have attached screenshots showing that I was able to successfully register the x64 MPCVideoDec.ax file, yet it shows up nowhere in the filter manager or in the W&FIlterTweaker


Attached Thumbnails
HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12-mpcregister2.jpg   HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12-mpcregister3.jpg  
Attached Images
  
My System SpecsSystem Spec
11 Jun 2009   #10

Win Xp/7
 
 

Yes its really strange. You registered filter and programs cant see it. I have never had 64bit win so that would be my guesses. First copy decoder file (*.ax) to folder where are stored other direct show filters (on 32 bit os its system32), and register it there. Secondly im not sure if radlight can detect 64 bit filters since it is 32bit application. Or maybe there is 64b one actually?
Another thought would be that You have to download the very last version of tool (that Windows 7 filter manager i pointed u) because MPCdecoder was added just very recently. I hope ur problem can be solved.
My System SpecsSystem Spec
Reply

 HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12




Thread Tools



Similar help and support threads for2: HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12
Thread Forum
Solved Blu-ray M2TS Files - Software Help Needed Music, Pictures & Video
VLC 1.1.0 stable release actually works with PGS subs in .m2ts files!! Software
MTS M2TS Video Editing? Software
Poor video quality on all players except WMP12 Music, Pictures & Video
WMP12 Wont play video files! Music, Pictures & Video
RE: WMP12 Streaming Video Music, Pictures & Video
WMP12 box at video play huge! Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33