Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP Needs to be Open to index library ALWAYS


01 Mar 2011   #1

Windows 7 Home Premium x64
 
 
WMP Needs to be Open to index library ALWAYS

Hi--

I have an external hard drive that I store all my media (audio, video) on and stream it to various devices such as my XBOX360(s). In Vista this was a snap. The files would index, update when I added new stuff automatically and only occasionally needing a bit of tweaking such as a Windows media player network sharing services restart or something (rarely).

Now in Windows 7, none of my content from the external drive is available on the XBOX360s unless I have WMP open?! Every time I open it, it re-indexes all of my content on the external drive. I've read the indexing help and it states that the content should be available to search as long as the drive is connected (NOT as long as WMP is OPEN!). I NEVER disconnect this drive. It is always plugged in and powered on.

What gives? I am a bit OCD where my desktop is concerned-- I don't want to run apps I don't need to... why do I have to have WMP open constantly? Can I fix this?

Thanks.


My System SpecsSystem Spec
.

02 Mar 2011   #2

Windows 7 Ultimate x64 SP1
 
 

Unfortunately, as far as I understand it, Microsoft removed the ability to silently index your library as a background service with Windows 7 and now you must have WMP 12 open for this to happen. Believe me, you're not the only one who misses this functionality from WMP 11. Even after SP1 and getting somewhat used to it, there is still a LOT wrong with WMP 12.
My System SpecsSystem Spec
02 Mar 2011   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

That's interesting. I just have to place a video in a library location and it is available to my Iomega TV link without WMP12 running.
My System SpecsSystem Spec
.


02 Mar 2011   #4

Windows 7 Home Premium x64
 
 

Maybe it's a functionality of how the Iomega TV Link works. Maybe it keeps its own index of files. The XBOX360 uses the windows index which apparently disappears on external drives when WMP is closed.
My System SpecsSystem Spec
02 Mar 2011   #5

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by shenacat View Post
Maybe it's a functionality of how the Iomega TV Link works. Maybe it keeps its own index of files. The XBOX360 uses the windows index which apparently disappears on external drives when WMP is closed.
I don't think so. Every time it starts it seems to take a few moments to reconnect with the media devices but once connected if you move a new video into a library folder it picks it up fairly quickly. Maybe connecting with the media devices starts the indexing routines.
My System SpecsSystem Spec
02 Mar 2011   #6

Windows 7 Home Premium x64
 
 

If that's the case, then the XBOX is confused, because it just reports zero content. Sometimes it does the "loading" type of thing, where it makes me wait to see stuff while it indexes, but this behavior is different. It just reports no content, not even an available drive. It will do it until I go over to the computer and open WMP. Bleah! Maybe if enough of us complain they will fix it in a future version :P
My System SpecsSystem Spec
02 Mar 2011   #7

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by shenacat View Post
If that's the case, then the XBOX is confused, because it just reports zero content. Sometimes it does the "loading" type of thing, where it makes me wait to see stuff while it indexes, but this behavior is different. It just reports no content, not even an available drive. It will do it until I go over to the computer and open WMP. Bleah! Maybe if enough of us complain they will fix it in a future version :P
Presumably, under steam in WMP, Automatically allow my devices to play my media is checked.
My System SpecsSystem Spec
02 Mar 2011   #8

Windows 7 Home Premium x64
 
 

Yes Kado897, it is checked. That was frequently a problem for me in Vista, so I quickly went through and found the way to enable my devices in Windows 7 first thing. I also noticed that the WMP Network Sharing service is set to Automatic (Delayed Start) instead of just Automatic. I'm changing that now to Automatic to see if that makes a difference.
My System SpecsSystem Spec
02 Mar 2011   #9

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by shenacat View Post
Yes Kado897, it is checked. That was frequently a problem for me in Vista, so I quickly went through and found the way to enable my devices in Windows 7 first thing. I also noticed that the WMP Network Sharing service is set to Automatic (Delayed Start) instead of just Automatic. I'm changing that now to Automatic to see if that makes a difference.
Mine is Automatic(Delayed Start) as well.
My System SpecsSystem Spec
02 Mar 2011   #10

Windows 7 Home Premium x64
 
 

Well, something is different. I've turned off WMP and can still browse stuff on the Xbox360... frankly it's acting more like it's old self. Maybe that was the ticket?! something about my particular setup made that change necessary?! Let's hope it continues like this and doesn't revert to old habits.
My System SpecsSystem Spec
Reply

 WMP Needs to be Open to index library ALWAYS




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:54 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33