Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can not Play some xvid (avi) files

07 Jul 2009   #1
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
Can not Play some xvid (avi) files

I am having a problem playing a number of xvid encoded .avi files.

about 16 to 20 minutes into the video I get a message saying "Cannot Play video -windows media center can not open the file"

This happens on 7229x64 and 7264x64. It also fails at the same point in WMP (both the x86 and x64 bit versions).

It plays fine on the 7100x86 version.

I have one version of the files and they are shared by network shares. (It fails on the host machine and works on a network machine so I do not think it is a network problem).

I would upload one of the files but it is 699 MB.

Anyone else having problems?

Thanks

Mark


My System SpecsSystem Spec
.

07 Jul 2009   #2
MUff1N

Windows® 7 Ultimate x64 SP1
 
 

Hmm, has to be a change in the Xvid codec rate or something that changes in the vid that Windows doesn't like or know how to deal with...

But, I also have some Xvid files on my machine & they play just fine on WMP, DivX & WinDVD 9 Plus.
So I'm not sure what exactly the problem is for you as they play fine on my system on build 7264.
My System SpecsSystem Spec
07 Jul 2009   #3
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 

Quote   Quote: Originally Posted by MUff1N View Post
...as they play fine on my system on build 7264.
Are you running x64 or x86? Also, I only have problems with some, not all.

would you be willing to download a 699MB test file and try it out?

Mark
My System SpecsSystem Spec
.


07 Jul 2009   #4
sirsiddius

Windows 7 build 7264
 
 

Is it the latest season of Top Gear?
My System SpecsSystem Spec
07 Jul 2009   #5
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
Yes

Quote   Quote: Originally Posted by sirsiddius View Post
Is it the latest season of Top Gear?
Yes


How did you know?

I can play S13e01 on all computers, but S13e02 and s13e03 do not work on 7229x64 or 7264x64, just 7100x86.
My System SpecsSystem Spec
07 Jul 2009   #6
sirsiddius

Windows 7 build 7264
 
 

Cause I've been trying to play s13ep3 on in win 7 and I get an error at the 16min mark, and that file just happens to be 699mb. Coincidence huh?

In the end I went back to XP and the whole thing played without a hitch.
My System SpecsSystem Spec
07 Jul 2009   #7
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 

what version of w7 were (are) you running (x86 or x64)?
My System SpecsSystem Spec
07 Jul 2009   #8
sirsiddius

Windows 7 build 7264
 
 

It tried it on 7100 and 7264 both 32 bit and neither of them could play the file. It was only one of many annoyances I had with wmp12. I even made a rant post about it: WMP 12 is really stupid and annoying.

I'm downloading VLC player now, and I'm going to see what happens.
My System SpecsSystem Spec
07 Jul 2009   #9
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 

This is interesting as it runs fine on my 7100 32 bit. I am 99% certain it will work on VLC.

Mark
My System SpecsSystem Spec
08 Jul 2009   #10
MUff1N

Windows® 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by mtp View Post
Are you running x64 or x86? Also, I only have problems with some, not all.

would you be willing to download a 699MB test file and try it out?

Mark
Yea I'll download it as I got 6mbs down.
Care to give me a link to the download Mark so I can test this & find the fix for it if there is any?
Thanks...
My System SpecsSystem Spec
Reply

 Can not Play some xvid (avi) files




Thread Tools





Similar help and support threads
Thread Forum
Output files are too big after hardsubbing using XVID
I used to hardsub videos using xvid codes using VirtualDubMod. When i hardsubbed a 700mb avi, the file produced is normally 400 - 500mb and i used xvid codec. But now when i hardsub a 700mb avi, the file produced would be 800mb++ And i remember when i click xvid under compression, it will start the...
Music, Pictures & Video
Xvid to Quicktime
I am tying to convert a couple of xvid files to quick time, and would like to know if anyone knows a free converter program. Thanks jack
Media Center
WMP freezes playing Xvid avi
I am on win7 x64 7600 RTM playing Xvid /avi movies WMP freezes for few mins then after 5-7 mins again start playing normally, assuming it could be codec problem I installed Klite along with media player classic, but even that does not work . What is the source of the problem? I tried KMplayer...
Music, Pictures & Video
Convert to XviD
Right, here goes, I bought a surround sound system with DVD upscaler and the unit/upscaler has a USB slot and the instructions say flash drive. I want to use my Hard drive in it but I don't know if it works. Here's the two drives I have: Freecom, 2.5" SATA, 160GB, NTFS, USB powered...
Software
Choppy XViD playback and 100% CPU usage
I'm finding whenever I play any avi files my cpu usage jumps to 100% in WMP 12. I've tried shark007's codecs with no success. However, I don't have these problems in VLC player. I also know it's an xvid thing, as I have no problems playing DVD's, or music. The CPU just jumps to 100% with avi's it...
Music, Pictures & Video
will win7 Media Center play xvid and divx files?
Hi, will win7 media center play divx and xvid files natively without the need to install codecs or codec packs? I've heard win7 media player will do this but i'm wondering about win7 "media center"? Thanks
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App