Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MKV and subtitles in WMC - Not working

01 Sep 2011   #1
HDRoadKing

Windows 7 Ultimate x64
 
 
MKV and subtitles in WMC - Not working

Hi all,

Hoping someone can shed some light on my problem and how to fix it. The issue I'm having is that I am unable to get subtitles working in WMC. Basically I only want them for non-english speaking parts in a movie. Here's my setup:

Win7 Enterprise SP1 (32-bit)
WMC
Media Browser plug-in
CoreAVC video codec
FFShow

I have the MKV file and .sub files in the same folder and they are named the same as well, but I can't get them to display.

Any suggestions?

Thanks in advance,
Mike


My System SpecsSystem Spec
.
01 Sep 2011   #2
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

i have the same issue ,for this type of file i use vlc to play the movie you can add the subtitle folder to vlc via the vlc menu.
doesnt really answer your question but its my workaround.
VideoLAN - Official download of VLC media player for Windows
My System SpecsSystem Spec
01 Sep 2011   #3
Shark007

Windows 7 Ultimate 64bit
 
 

I have no idea why people would suggest using alternate players such as VLC when the question posed is specific to playback in Media Center within the Media Center forum section.

For MKV's with subs to playback in Media Center, uninstall FFDshow (because it is included in the following suggestion), and Install the Win7codecs. If you have a 64bit operating system, you will also need to x64Components addon.

To get the MKV's with subs working in Media Center, disable the Microsoft Video decoder on the SWAP TAB of the Settings Application.
My System SpecsSystem Spec
.

01 Sep 2011   #4
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Thanks for the info shark007, the reason I suggested vlc was as i already stated i have this issue and found a workaround,i did say it doesn't answer the question. now i have the solution and can inform people correctly in future,thanks.
i also use sharks007 codecs
My System SpecsSystem Spec
01 Sep 2011   #5
HDRoadKing

Windows 7 Ultimate x64
 
 

Thanks Shark! One question though, will installing this codec have any impact on CoreAVC? The only reason I ask, is that my HTPC is running on an Atom board and without CoreAVC offloading the processing to the GPU using CUDA, MKV's stutter horribly.
My System SpecsSystem Spec
01 Sep 2011   #6
Shark007

Windows 7 Ultimate 64bit
 
 

Uninstall CoreAVC and Haali (before installing my codecs)
On the H264 TAB, select LAVCUVID, this also uses CUDA.
IMO, CoreAVC is a waste of money these days. (poorest support on the planet)

If the subs do not work woth LAVCUVID, give ffdshow dxva a try on the H264 tab.
My System SpecsSystem Spec
01 Sep 2011   #7
HDRoadKing

Windows 7 Ultimate x64
 
 

I'll give that a try and let you know how it goes.

Many thanks for your help so far!
My System SpecsSystem Spec
01 Sep 2011   #8
HDRoadKing

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Shark007 View Post
Uninstall CoreAVC and Haali (before installing my codecs)
On the H264 TAB, select LAVCUVID, this also uses CUDA.
IMO, CoreAVC is a waste of money these days. (poorest support on the planet)

If the subs do not work woth LAVCUVID, give ffdshow dxva a try on the H264 tab.

No joy

I tried with both LAVCUVID and ffdshow dxva and still no subtitles either in WMC or just in WMP. I did as you suggested and removed both CoreAVC, ffdshow and Haali prior to installing your codec pack.

There is literally nothing else on this HTPC, just the OS, drivers, MediaBrowser add-on and your codec pack.

Any other thoughts?
My System SpecsSystem Spec
01 Sep 2011   #9
Shark007

Windows 7 Ultimate 64bit
 
 

for some people, disabling UAC (User Account Control) can cause these problems.
If you had disabled UAC I suggest you...

1. uninstall the codecs
2. set UAC to the 'Default' setting, re-boot the computer
3. re-install the codecs (edit, use the button on the Help TAB to associate MKV's with the Windows players) and apply the settings previously suggested
My System SpecsSystem Spec
02 Sep 2011   #10
HDRoadKing

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Shark007 View Post
for some people, disabling UAC (User Account Control) can cause these problems.
If you had disabled UAC I suggest you...

1. uninstall the codecs
2. set UAC to the 'Default' setting, re-boot the computer
3. re-install the codecs (edit, use the button on the Help TAB to associate MKV's with the Windows players) and apply the settings previously suggested

Sorry, still no luck. Here are screenshots of the settings just in case I've missed something.


Attached Images
MKV and subtitles in WMC - Not working-capture1.png MKV and subtitles in WMC - Not working-capture2.png 
My System SpecsSystem Spec
Reply

 MKV and subtitles in WMC - Not working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
SRT subtitles
hi i have a trouble in displaying .srt subtitles back in windows xp i was using k-lite mega codec and everything works fine on win7 x64 im using the same k-lite bundle and its not working even in WMC any solutions ?!
Media Center
Forign Subtitles Not Displaying Properly (Russian Subtitles)
Hey, this problem has been giving me a headache for days and a million Google searches later: I downloaded subtitles that are Russian (.srt), however when I open up the video file in Windows Media Player or VLC the subtitles are displaying as gibirish, like this: " ...
Music, Pictures & Video
WMP 12 - PS3 - Subtitles
Hi, after following some of the tutorials or topics posted here I managed to get MKV and subtitles working in WMP12. Mostly through installing Shark. I also managed to link my PS3 and Media Streaming goes very well. The only thing that is nog working are subtitles. I get subtitles when...
Media Center
Subtitles on Windows 7 Media Center - working
1- Took ownership(via R click) and renamed these three files in C>windows>system32 MP4SDECD.DLL MP43DECD.DLL MPG4DECD.DLL 2- Install ffdshow and ffdshow64 if u are running 64-bit version. 3- Then when you try to open an avi movies with a srt file you may notice that doesnt have...
Media Center
Need help with subtitles
I have a problem with subtitles on my videos in both Windows Media Player and Divx, which used to work just fine on Windows Vista. Two different movies I have tried, one being an .avi file, the other being a .mp4 file and both subtitles being .srt files. I read up on some other forum, and found...
Music, Pictures & Video
No subtitles in mp4 with aac
HI EVERYONE I recently configured WIN 7 Media Center with ffdshow codecs. All movies play good excpet MP4 movies which I have sound but no subtitles I usue spdif pasthrough for the audio I have done thousands of mixtures in the codecs but the problem stil remains The Direct Vob Sub does not...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App