Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMC plays TV audio, but no video display (black screen)

09 Mar 2012   #11
tocorolla

Windows 7 Home Premium 64bit
 
 

It's WinTV-HVR-1250.

I'm in correspondance with Hauppauge. THey seem to think it's NVIDIA drivers which i've tried a few different ones already.


My System SpecsSystem Spec
09 Mar 2012   #12
barnabas1969

Windows 7 Ultimate x64
 
 

I have a 1250 and a 2250 in my Media Center PC. Both work fine. Have you told Hauppauge that you are able to play DVD's in Media Center? They are probably thinking that the driver bug in the nVidia drivers is the culprit. That's what I thought when I first replied to your post too... until you told me that you can play DVD's.
My System SpecsSystem Spec
09 Mar 2012   #13
barnabas1969

Windows 7 Ultimate x64
 
 

Oh... and after you re-installed the Media Center drivers from Hauppauge, I hope you also went through the "Live TV Setup" in media center again... to scan for channels and such.
My System SpecsSystem Spec
10 Mar 2012   #14
tocorolla

Windows 7 Home Premium 64bit
 
 

Yes, I rescanned the TV signal again each time I change something. Rebooted the PC too.
My System SpecsSystem Spec
11 Mar 2012   #15
kegobeer

Windows 7 Ultimate x64 SP1
 
 

Do you have a single display or a multiple display setup?
My System SpecsSystem Spec
11 Mar 2012   #16
tocorolla

Windows 7 Home Premium 64bit
 
 

It's a single display. VGA cable to monitor. DVI adapter at PC side if it matters?
My System SpecsSystem Spec
11 Mar 2012   #17
kegobeer

Windows 7 Ultimate x64 SP1
 
 

Have you tweaked any filters/codecs?
My System SpecsSystem Spec
11 Mar 2012   #18
tocorolla

Windows 7 Home Premium 64bit
 
 

For codecs, I've uninstalled and reinstalled klite. I mean, it works with WinTV, just not with WMC, which makes it a strange one...
My System SpecsSystem Spec
11 Mar 2012   #19
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

I'm inclined to believe it's probably NVIDIA's driver that's the problem.

I recently updated my computer to their latest driver and WMC produced a black screen.

I reverted to the 275.33 driver and all is good again so you might want to consider rolling back to an earlier graphics driver.
My System SpecsSystem Spec
12 Mar 2012   #20
barnabas1969

Windows 7 Ultimate x64
 
 

Seavixen32, the OP has already reverted to an older nVidia driver. If the display driver was the issue, he wouldn't be able to watch a DVD in Media Center. He can watch a DVD... just not TV.
My System SpecsSystem Spec
Reply

 WMC plays TV audio, but no video display (black screen)




Thread Tools



Similar help and support threads for2: WMC plays TV audio, but no video display (black screen)
Thread Forum
Black screen while video playback on any player, but VLC (audio works) Drivers
No video playback only audio (black screen) Graphic Cards
No video playback only audio (only black screen) Music, Pictures & Video
Audio Plays Fine, No Video Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:29 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App