Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMC plays TV audio, but no video display (black screen)


07 Mar 2012   #1

Windows 7 Home Premium 64bit
 
 
WMC plays TV audio, but no video display (black screen)

Hello, I hope this is not a repeat question as I have checked and searched the forum thoroughly.

I have a problem playing live TV using Windows Media Player. I can select different TV channels without a problem. I can hear the audio clearly. However, i can not watch anything as it displays a black screen.

I originally used WinTV (version 7, with the newest updated driver and software) and works fine. For video card, I have a GTX260 with the latest version (295.73) installed. I've tried different versions of driver (259.xx to 285.xx) to no avail.

When I tried setting up the TV tuner it detects the tuner as Analog Cable (tuner 1) which I assume is the WinTV tuner.

Wondering if you have any tips or suggestions to try next?
thanks

My System SpecsSystem Spec
.

07 Mar 2012   #2

Windows 7 Ultimate x64
 
 

The latest stable driver is 290.53. The newer ones (including the latest WHQL release) either have the black screen problem with Media Center or the 29/59 flicker bug. Several of the older versions have these problems as well.

Go to nVidia's site, download the 290.53 beta driver, and when you install it... make sure to choose a "custom" install, then check the box that says "clean install". If you don't do a clean install, you will still have pieces of your old driver installed, and that could cause you the problems you're seeing.
My System SpecsSystem Spec
07 Mar 2012   #3

Windows 7 Home Premium 64bit
 
 

Thanks barnabas1969. I tried what you suggested with 290.53 beta driver, and custom clean install, rebooted. It is still not showing tv display. Audio is good, no distortion whatsover. I can still change channels, but just no video display. Most of the drivers I tried were custom install so not sure if maybe some settings were not checked off somewhere?
thanks...
My System SpecsSystem Spec
.


07 Mar 2012   #4

Windows 7 Ultimate x64
 
 

Hmmm... that's strange. Is the "no video" problem only when you run Media Center, or even on the Windows desktop?

If it's only doing it in Media Center, then this version of the drivers should have fixed your problem. If it's doing it on the desktop, then you have a different problem.
My System SpecsSystem Spec
07 Mar 2012   #5

Windows 7 Home Premium 64bit
 
 

I can use Windows Media Center to play DVD videos, mpeg/avi movies without a problem.
My tuner TV software that I installed (WinTV 7) is used to watch live TV with audio and video display. If I use WMC to watch live TV, I am only getting the audio to go through.
My System SpecsSystem Spec
08 Mar 2012   #6

Windows 7 Ultimate x64
 
 

I'm guessing that you have a Hauppauge tuner, correct? Hauppauge has different drivers, depending on whether you plan to use Media Center or WinTV. You need to install the Hauppauge drivers for Media Center if you want to use it to view TV with that tuner. Look on the Hauppauge website, click the "Support" tab, find your tuner card, and look at the top of the support page for that card for "Media Center Installation" or something similar.
My System SpecsSystem Spec
08 Mar 2012   #7

Windows 7 Home Premium 64bit
 
 

Yes it is a Hauppauge tuner. I downloaded the WinTV version 7 which is the latest one. THe webpage said it included the WMC driver when you install it. However I tried what you suggested, still no luck :S
My System SpecsSystem Spec
09 Mar 2012   #8

Windows 7 Ultimate x64
 
 

Maybe you could try un-installing WinTV and the WMC driver, then re-install ONLY the WMC driver? I never installed WinTV as there is no need for it when you have WMC. Maybe WinTV causes a conflict? I'm just guessing here.
My System SpecsSystem Spec
09 Mar 2012   #9

Windows 7 Home Premium 64bit
 
 

Still no luck.
I uninstalled WinTV and WMC. Reinstalled WMC only. Tried different NVIDIA drivers.

I'm about to try different cables or re sit the TV tuner and/or video card....but doesn't make any sense if I can view it without a problem when I use WinTV.
My System SpecsSystem Spec
09 Mar 2012   #10

Windows 7 Ultimate x64
 
 

I don't think it has anything to do with cables. What model is the tuner? Have you contacted Hauppauge?
My System SpecsSystem Spec
Reply

 WMC plays TV audio, but no video display (black screen)




Thread Tools



Similar help and support threads for2: WMC plays TV audio, but no video display (black screen)
Thread Forum
Black screen while video playback on any player, but VLC (audio works) Drivers
No video playback only audio (black screen) Graphic Cards
No video playback only audio (only black screen) Music, Pictures & Video
Wierd Display Error: Black screen until logon screen; no Logo etc. General Discussion
Black screen display for less than a sec BSOD Help and Support
Audio Plays Fine, No Video when watching Live TV Media Center
Audio Plays Fine, No Video Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:42 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33