Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Two problems: x264 videos and subtitles

18 Jan 2009   #1
jota

Windows 7 Build 7000 x86
 
 
Two problems: x264 videos and subtitles

I have two problems with windows media center
1st - I can't see videos with .srt subtitles
2nd - I can't see videos x264 (download from Up! Download de Filmes e SÚries na internet!)
And I have the 1st problem in Media Player too...

So what can I do?

OBS: I can see x264 in other players without a problem, I just have trouble playing this videos in Media Center.


My System SpecsSystem Spec
.
19 Jan 2009   #2
dalhectar

Windows 7 Beta Build 7100 x86
 
 

What container are these movies in? mkv, mp4, avi?
My System SpecsSystem Spec
19 Jan 2009   #3
jota

Windows 7 Build 7000 x86
 
 

They're in avi
My System SpecsSystem Spec
.

19 Jan 2009   #4
Bellerophon

Windows Se7en Ultimate x64
 
 
Resolved in Win7 Beta x64

OK, I have just found the solution to this you need three files. The three files you need are: -

(1) Microsoft Visual C++ 2008 Redistributable Package SP1 (link on Media Control site);
(2) Codec installation files - here;
(3) Media Control : version 5.4.5 - here (you can also get the codec files here).

All downloads are available on the Media Control site. Make sure you get the right version of Microsoft Visual C++ 2008 Redistributable Package SP1 i.e. x64/x86 the link on the Media Control site is for x86. Installation instructions are also on the site.

Please don't forget to post after installing for x86 to confirm it is working or not.
My System SpecsSystem Spec
19 Jan 2009   #5
jota

Windows 7 Build 7000 x86
 
 

I'm gonna try.
I'll post the results here when I'm done.
My System SpecsSystem Spec
19 Jan 2009   #6
Bellerophon

Windows Se7en Ultimate x64
 
 
It Works

Quote   Quote: Originally Posted by jota View Post
I'm using x64, will this links work?
I am using it now on my htpc.


Attached Thumbnails
-mce-mkv-subs.png  
My System SpecsSystem Spec
19 Jan 2009   #7
jota

Windows 7 Build 7000 x86
 
 

Ok, it didn't worked for me. Or maybe i'm doin' it wrong, can you say step by step what I have to do?
My System SpecsSystem Spec
20 Jan 2009   #8
Bellerophon

Windows Se7en Ultimate x64
 
 
Here's what I did

Quote   Quote: Originally Posted by Bellerophon View Post
OK, I have just found the solution to this you need three files. The three files you need are: -

(1) Microsoft Visual C++ 2008 Redistributable Package SP1 (link on Media Control site);
(2) Codec installation files - here;
(3) Media Control : version 5.4.5 - here (you can also get the codec files here).

All downloads are available on the Media Control site. Make sure you get the right version of Microsoft Visual C++ 2008 Redistributable Package SP1 i.e. x64/x86 the link on the Media Control site is for x86. Installation instructions are also on the site.

Please don't forget to post after installing for x86 to confirm it is working or not.
Quote   Quote: Originally Posted by jota View Post
Ok, it didn't worked for me. Or maybe i'm doin' it wrong, can you say step by step what I have to do?
From my post above downloaded and installed (2) and then (1) then (3) and that's it, no tweaks, no nothing.
My System SpecsSystem Spec
20 Jan 2009   #9
jota

Windows 7 Build 7000 x86
 
 

Yeah, it didn't worked. I can see that menu but it does nothing. I still can see subtitles and now, when I open a x264 video I just hear the audio and MCE freezes.


Attached Thumbnails
-ahh.jpg  
My System SpecsSystem Spec
20 Jan 2009   #10
Bellerophon

Windows Se7en Ultimate x64
 
 
Problems here now

I installed the new shark Windows 7 codec and I am now back to square 1 myself. Can't play mkv files anymore, it is helpfully telling me it can't find them now.
My System SpecsSystem Spec
Reply

 Two problems: x264 videos and subtitles




Thread Tools




Similar help and support threads
Thread Forum
BSOD using WMC and trying some encodes with x264
Hey everyone! Trying to solve some problems with my PC, not so good at BSOD analysis... Had a Motherboard switch from Asus (same model, previous board failed so RMA'd it), never had a problem so far, till some blue screens started to pop up. After a while of watching some videos in wmc, in...
BSOD Help and Support
Synchronizing subtitles with videos
I fixed this! if anyone need help pm me
Music, Pictures & Video
Video Encoding x264 (MeGUI)
--How to Setup & Encode Content with MeGUI x264 Encoder-- This tutorial will show you how to use MeGUI to create a MP4 or MKV file for your Media Center collection, from your legally owned DVD collection. I will not cover how to decrypt.
Tutorials
Forign Subtitles Not Displaying Properly (Russian Subtitles)
Hey, this problem has been giving me a headache for days and a million Google searches later: I downloaded subtitles that are Russian (.srt), however when I open up the video file in Windows Media Player or VLC the subtitles are displaying as gibirish, like this: "╩ţ­ţŰŘ ├ňţ­Ń ¤ ˛űÚ ´­ÓÔŔ˛ ßţŰňň...
Music, Pictures & Video
ATI problems when encoding/watching videos
Hi, I've just had problems recently with my graphic card when I'm encoding a 1080p video to 720p video. During that process, the display suddenly went corrupted. It has many tiny pink/red rectangles going diagonally throughout my whole screen...
Graphic Cards
Problems with playing any videos
Firstly, as I said in another thread, my sound does not work, I hear only loud crackling. Also, when playing any video, whether directly in WMP or on the web (YouTube, Viddler), it plays very slowly and jerkily, and often has pixellation, strange colors, etc. I am using Windows 7 Ultimate 64-bit,...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

ę Designer Media Ltd

All times are GMT -5. The time now is 10:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App