Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Trying to remove WMP Picture Library

05 Jan 2013   #1

Windows 7 Ultimate 32bit
 
 
Trying to remove WMP Picture Library

Hi,

I've been searching everywhere in this forum and all others but haven't been able to find my particular problem. My video and music libraries work great with no problems.

My picture library shows pretty much every image from every corner of my hard drive bogging down the player pretty badly.

I have never used WMP for viewing pictures so, deciding to remove them, I went to organize > manage libraries > pictures and removed the only two that were there: "My Pictures" and "Public pictures".

They appeared to go away but the pictures remained in the library.

As an experiment, when I added "my pictures" back in as a library folder, it worked fine and I now had duplicates of that folder. I was able to right click individual pictures and delete them (only the second set that I just re-added). When I removed the "my pictures" folder again, I now still have duplicates of those pictures and when I right click and chose delete it does nothing.

The problem seems to be that when you remove a folder from the library, the files remain literally "stuck" in the library. Is this normal? How can these files be removed?

Thanks

Darren

My System SpecsSystem Spec
.

05 Jan 2013   #2

win7 ultimate 32bit
 
 

Quote   Quote: Originally Posted by jjavaman View Post
Hi,

I have never used WMP for viewing pictures so, deciding to remove them, I went to organize > manage libraries > pictures and removed the only two that were there: "My Pictures" and "Public pictures".

They appeared to go away but the pictures remained in the library.

Darren

see the attached screenshots--read the 'learn more about' section


Attached Thumbnails
Trying to remove WMP Picture Library-capture2.jpg  
Attached Images
  
My System SpecsSystem Spec
05 Jan 2013   #3

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Tip   Tip
select options in wmp and select the library tab, uncheck the box for "delete files from the computer when deleted from the library"




you need to remove them from the library in wmp, to do so from in wmp you click organize/ manage libraries/pictures
then click remove for each location in the window that shows. this will stop wmp monitoring your pictures library in explorer
then you need to clear the pictures that are already showing in the wmp library.
on the left navigation pane in wmp select pictures, this will then show a path at the top of wmp, it will show library
click library at the top and then in the wmp primary views window that shows several icons select the pictures icon then again it will show more icons, all pictures ,tags etc, select "folder"
when all your images finish loading you can select them all and right click and delete.


warning   Warning
a prompt window will ask you if you wish to delete from the library only or from the library and computer,
BE SURE TO SELECT "DELETE FROM LIBRARY ONLY"
My System SpecsSystem Spec
.


05 Jan 2013   #4

Windows 7 Ultimate 32bit
 
 

Thanks for the replies, guys.

Tman, unfortunately, that's one of the questions and responses I've been finding everywhere I've been looking and my reason for posting here. I'm not trying to delete the files entirely from my hard drive. I just want to remove them from my WMP library which I also know "how" to do it just that it's not working the way the program is supposed to.

I guess really my question more clearly would be. has anyone else encountered this glitch with the software and if you got it fixed, how did you do it?

Boohbah, you've pretty much nailed it with what I'm trying to do. I have removed the folders through the manage libraries tab (effectively, stopped WMP from monitoring those folders). That function works.

My problem arises when I get to the second part of right clicking and deleting them from the library, clicking delete does nothing. Normally the picture icon should dissapear I don't get an error message or anything, the icons just won't delete.

I've tried stopping WMP in Task Manager/Services then going to Appdata/Local/Microsoft/Media Player/ and deleted the Currentdatabase_372 file, restarted WMP, let the database rebuild itself but that didn't work. I'm trying to avoid having to uninstall WMP. Any other suggestions?

Thanks again for the quick replies.

Darren
My System SpecsSystem Spec
05 Jan 2013   #5

Windows 7 Ultimate 32bit
 
 

When trying to delete, I've also tried "open file location", changed the name of the folder it's drawing from. Going back to libraries, There's a generic icon and error when I try to open the file (because the path is gone due to renaming the folder) but it still won't delete.

The thing that stumps me is that none of these files are showing up in libraries in the explorer window, just in WMP.

...That, coupled with the fact that Libraries was never told to monitor all these other folders to begin with.
My System SpecsSystem Spec
05 Jan 2013   #6

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

wmp uses the explorer libraries by default.

try this and see if it helps.
Windows Media Player - Rebuild Corrupted Libraries

once you have cleared the wmp library cache theoretically it wont rebuild the pictures library as you have already stopped it monitoring your pictures library.
My System SpecsSystem Spec
05 Jan 2013   #7

Windows 7 Ultimate 32bit
 
 

That did it. I was close before. I just didn't delete ALL of the files in the WMP appdata folder before only the Current database_372 file. I re-added the My pictures and public pictures folders to the pictures library and it loaded pictures out of only those folders. Yay!

I still cant figure out why WMP would have loaded everything else in there to begin with but if it happens again I know how to fix it.

Many thanks, Boohbah!

Darren
My System SpecsSystem Spec
06 Jan 2013   #8

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

your welcome.
you may find wmp loads quicker now and is more responsive,
My System SpecsSystem Spec
Reply

 Trying to remove WMP Picture Library





Thread Tools



Similar help and support threads for2: Trying to remove WMP Picture Library
Thread Forum
Solved Deleted files from Picture Library. Can they be recovered? Backup and Restore
Picture library printing to Fax Music, Pictures & Video
Solved Picture Library Problem Music, Pictures & Video
Solved Picture Library Not Showing Pictures General Discussion
Remove New Library Button in from Library Toolbar Customization
Picture Library option not working on Desktop background Customization
Why do I not get a preview of my picture library? Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33