Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Trying to remove WMP Picture Library

05 Jan 2013   #1
jjavaman

Windows 7 Ultimate 32bit
 
 
Trying to remove WMP Picture Library

Hi,

I've been searching everywhere in this forum and all others but haven't been able to find my particular problem. My video and music libraries work great with no problems.

My picture library shows pretty much every image from every corner of my hard drive bogging down the player pretty badly.

I have never used WMP for viewing pictures so, deciding to remove them, I went to organize > manage libraries > pictures and removed the only two that were there: "My Pictures" and "Public pictures".

They appeared to go away but the pictures remained in the library.

As an experiment, when I added "my pictures" back in as a library folder, it worked fine and I now had duplicates of that folder. I was able to right click individual pictures and delete them (only the second set that I just re-added). When I removed the "my pictures" folder again, I now still have duplicates of those pictures and when I right click and chose delete it does nothing.

The problem seems to be that when you remove a folder from the library, the files remain literally "stuck" in the library. Is this normal? How can these files be removed?

Thanks

Darren


My System SpecsSystem Spec
.

05 Jan 2013   #2
tman69

win7 ultimate 32bit
 
 

Quote   Quote: Originally Posted by jjavaman View Post
Hi,

I have never used WMP for viewing pictures so, deciding to remove them, I went to organize > manage libraries > pictures and removed the only two that were there: "My Pictures" and "Public pictures".

They appeared to go away but the pictures remained in the library.

Darren

see the attached screenshots--read the 'learn more about' section


Attached Thumbnails
-capture2.jpg  
Attached Images
  
My System SpecsSystem Spec
05 Jan 2013   #3
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Tip   Tip
select options in wmp and select the library tab, uncheck the box for "delete files from the computer when deleted from the library"




you need to remove them from the library in wmp, to do so from in wmp you click organize/ manage libraries/pictures
then click remove for each location in the window that shows. this will stop wmp monitoring your pictures library in explorer
then you need to clear the pictures that are already showing in the wmp library.
on the left navigation pane in wmp select pictures, this will then show a path at the top of wmp, it will show library
click library at the top and then in the wmp primary views window that shows several icons select the pictures icon then again it will show more icons, all pictures ,tags etc, select "folder"
when all your images finish loading you can select them all and right click and delete.


warning   Warning
a prompt window will ask you if you wish to delete from the library only or from the library and computer,
BE SURE TO SELECT "DELETE FROM LIBRARY ONLY"
My System SpecsSystem Spec
.


05 Jan 2013   #4
jjavaman

Windows 7 Ultimate 32bit
 
 

Thanks for the replies, guys.

Tman, unfortunately, that's one of the questions and responses I've been finding everywhere I've been looking and my reason for posting here. I'm not trying to delete the files entirely from my hard drive. I just want to remove them from my WMP library which I also know "how" to do it just that it's not working the way the program is supposed to.

I guess really my question more clearly would be. has anyone else encountered this glitch with the software and if you got it fixed, how did you do it?

Boohbah, you've pretty much nailed it with what I'm trying to do. I have removed the folders through the manage libraries tab (effectively, stopped WMP from monitoring those folders). That function works.

My problem arises when I get to the second part of right clicking and deleting them from the library, clicking delete does nothing. Normally the picture icon should dissapear I don't get an error message or anything, the icons just won't delete.

I've tried stopping WMP in Task Manager/Services then going to Appdata/Local/Microsoft/Media Player/ and deleted the Currentdatabase_372 file, restarted WMP, let the database rebuild itself but that didn't work. I'm trying to avoid having to uninstall WMP. Any other suggestions?

Thanks again for the quick replies.

Darren
My System SpecsSystem Spec
05 Jan 2013   #5
jjavaman

Windows 7 Ultimate 32bit
 
 

When trying to delete, I've also tried "open file location", changed the name of the folder it's drawing from. Going back to libraries, There's a generic icon and error when I try to open the file (because the path is gone due to renaming the folder) but it still won't delete.

The thing that stumps me is that none of these files are showing up in libraries in the explorer window, just in WMP.

...That, coupled with the fact that Libraries was never told to monitor all these other folders to begin with.
My System SpecsSystem Spec
05 Jan 2013   #6
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

wmp uses the explorer libraries by default.

try this and see if it helps.
Windows Media Player - Rebuild Corrupted Libraries

once you have cleared the wmp library cache theoretically it wont rebuild the pictures library as you have already stopped it monitoring your pictures library.
My System SpecsSystem Spec
05 Jan 2013   #7
jjavaman

Windows 7 Ultimate 32bit
 
 

That did it. I was close before. I just didn't delete ALL of the files in the WMP appdata folder before only the Current database_372 file. I re-added the My pictures and public pictures folders to the pictures library and it loaded pictures out of only those folders. Yay!

I still cant figure out why WMP would have loaded everything else in there to begin with but if it happens again I know how to fix it.

Many thanks, Boohbah!

Darren
My System SpecsSystem Spec
06 Jan 2013   #8
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

your welcome.
you may find wmp loads quicker now and is more responsive,
My System SpecsSystem Spec
Reply

 Trying to remove WMP Picture Library




Thread Tools





Similar help and support threads
Thread Forum
Picture Library Not Showing Pictures
Not sure how to explain this but when I used to open my picture library I would be able to see my pictures. Even in the folders I would be able to see what was in them. Now I just have the same generic image. I have attached pics so maybe I can get some help here :) I am not sure if it is...
General Discussion
Corrupt picture library
My picture library has became corrupt. I recently set up WMC and imported my photos and installed Adobe Photoshop and Premiere Elements 11. I did a system restore to prior to the Elements 11 install without a fix. Any help would be appreciated. Screen shots from picture library and WMP.
Music, Pictures & Video
Picture library printing to Fax
Whenever I go to my picture library and print from there, rather than trying to print to my default printer, it tries to send as a fax. It never gives me a choice of where to print. I can work arounbd it by selecting preview rather than print and it goes to the picture viewer which allows mne to...
Music, Pictures & Video
Picture Library Problem
I somehow managed to put a wrong date on two folders in my picture lidrary. I would like to remove the photos in the two folders into a folder of the right date and delete the empty folder, or can someone tell me how to change the wrong date on the two folders. I have included an attachment of the...
Music, Pictures & Video
Remove New Library Button in from Library Toolbar
Hello We have a GPO setting "Prevent users from adding files to the root of their Users Files folder" as we do not want users to be able to add files to their Roaming User Profile. This GPO causes an error when a New Library is attempted to be created. Because of the error we would like...
Customization
Why do I not get a preview of my picture library?
When I go to my picture library, and set the option to show icons instead of details, I get the following display: http://i83.photobucket.com/albums/j314/WoodenFrog/picturelibrary.jpg How do I change it so that the icons will be thumbnails of my actual pictures? Thanks Ferd
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App