Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Movie Library now ONLY displays .AVI file types in WMC7

05 Sep 2013   #1
BuddyWeiser

Windows 7 Ultimate 32bit
 
 
Movie Library now ONLY displays .AVI file types in WMC7

For some reason, WMC7 has stopped showing any video file EXCEPT for .AVI files. This is irritating as about half of my Movie Library consists of MP4 files. The movies play fine in WMP and also play fine in WMC7(if I right click on the video file and click on Play with WMC7), but the files don't show up in the library. I'm assuming this is some type of registry issue? I found a fix in another forum, and this is what it instructed me to do:

Type "regedit" in the search space right above the "Start" icon.
You need to know the extension of the file e.g.: ".mpg.", "jpg, for jepg", ".mp4"... etc.
Double click "HKEY_CLASSES_ROOT"
Look for the known extension.
Let's say, you want to see picture files on WMC, so scroll down to ".jpg" Right click it and select "New" then "string Value". Name it "Content Type", then right click the new value and select "Modify". Type: "Image/jpeg"
Right click ".jpg" again and select: " New" then "String Value". Rename it: "PerceivedType" (has to be two words together, as I typed it). Right click the new value and select: Modify. Type "Image".

I did this for MP4 video files, and they seemed to solve the problem, and my full movie library was showing in WMC7, however the next time I opened WMC7, it was back to the drawing board. I have 290 video files and only 133 of them show up in the movie library.


My System SpecsSystem Spec
.
10 Sep 2013   #2
BuddyWeiser

Windows 7 Ultimate 32bit
 
 

No help on this topic? For an additional note, all of my movies are stored on a western digital My Book external hard drive, and all other computers on my Homegroup recognizes and sees the full movie library(in windows media center). I need some help here.
My System SpecsSystem Spec
Reply

 Movie Library now ONLY displays .AVI file types in WMC7




Thread Tools




Similar help and support threads
Thread Forum
Media Center- Setup Movie Library
How to Setup a Media Center Movie Library in Windows 7 This tutorial will show how to manage your movie library in Media Center, including poster images & full synopsis information.Windows Media Center is not available in Windows 7 Starter and Windows 7 Home Basic editions. . The N and KN...
Tutorials
Unable to create the file "New Library.library.ms
Try to create new library. Get "Unable to create the file "New Library.library.ms" Access is denied. Found: "Unable to create the file 'New Library.library-ms' File System error (16389) The error 16389 (0x4005) is a trucation of a E_FAIL error (0x80004005)." New library commands raise...
General Discussion
AVI files on SAN not getting added to WMC Movie Library
I've just setup an HTPC (W7 Professional 32bit) and am using WMC on Windows 7. I've run into a problem that lots and lots of people have had (can see lots of posts on the web) but not fixes seem to work and I've trolled for two days now finding no fixes for the problem. Perhaps someone can...
Media Center
How do I delete movies from my movie library?
Hello, new to Windows 7 Media Center and these forums. I have begun backing up my movies onto an external hard drive, and have encountered a slight annoyance: I have a few "movies" showing up in my movie library that don't have any files associated with them, and I'm not even sure how they got...
Media Center
Movie Library sort by date added?
Hi all, I've been a long time reader of these fourms but first time poster but am looking for any advice on the following. I use the movie library function to view & play movies that are "ripped" and recorded from TV. I have now 300+ movies and add movies every week. The sort by date added...
General Discussion
WMC DVD Movie Library x2???
OK... a strange issue here. I just setup a Movie Library and added only that folder C:\Users\My Videos\DVDs to my Movie settings in WMC. All my DVD Rips play fine but I show 2 copies of every movie and I only have 1 of each in that folder. I'm new to this Movie sharing stuff... Any...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App