Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Media Center playback requires progress bar click


19 Jan 2014   #1

Windows Vista Ultimate 64-bit
 
 
Windows Media Center playback requires progress bar click

I have this strange problem after I changed the video card. Now this isn't the first time I've changed it. But this time, on the first launch of WMC, playback has a black screen and sound for like 3 seconds until it stops. Clicking somewhere on the progress bar to change the time position corrects this and playback is normal. This only happens when you first launch the WMC apparently, not subsequent playbacks.

I tried reinstalling the drivers and such, but that didn't solve it. Is this some sort of HDCP hiccup with my video card?

XFX HD-687A-ZHFC Radeon HD 6870 1GB 256-Bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card
XFX HD-687A-ZHFC Radeon HD 6870 1GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card - Newegg.com

My System SpecsSystem Spec
.

26 Jan 2014   #2

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Interesting that you should observe this. I have EXACTLY the same problem... but I've associated it only when playing a 1080i recording as the first thing played. It does NOT happen when opening a 720p program first.

I didn't actually connect the possible relationship to the video card (I have an HD5870) and in particular the installation of the latest Catalyst 13.12 driver back in December until reading your post. I can't recall this problem before the last month or two.

I've been using WMC for over four years now and I never had this problem until relatively recently. Even more interesting, my three WMC extenders also seem to start strangely now. I have to wait for about 15 seconds after getting them going, until I see the "spinning wheel" (which I don't know why it's happening). Once the spinning wheel stops I can now push the buttons on the remote and the extender will respond. If I try pushing remote buttons before the spinning wheel appears and then finishes, the extender is essentially dead/stuck and will not come back to life. I don't know what this odd extender behavior could have to do with Catalyst video drivers, but whatever the cause it happens on ALL THREE of my extenders.


I even took the opportunity of having almost nothing un-watched remaining in my \Recorded TV folder to reinstall Windows 7 in anticipation of the upcoming Olympics. I didn't want any malfunctions during those two weeks and thought it must be some "corruption" in my now 13-month old Windows 7 install on the HTPC which was responsible. I assumed that a fresh reinstall of Windows would resolve both of the above symptoms.

But you can imagine my surprise when NEITHER symptom disappeared with the new install of Windows 7. They both persisted, even in this brand newly installed Windows. How could that be I pondered??

Of course, it might also be something with a Windows Update dealing with playing 1080i WTV files and not 720p, but that's obviously a real stretch. Nevertheless it is another thing that would appear in my fresh Windows 7 reinstall as well as in my prior system.


So, that suggests the problem is not from "corruption" but rather is in something that I reinstalled in the new Windows 7 and which was also in the previous Windows 7, and the 13.12 Catalyst driver is exactly one of those things. I always un-check the "transcoders" during my custom install of Catalyst, so I wouldn't think that's the culprit. But definitely something else in the 13.12 Catalyst may well be what has caused this strange behavior... which apparently you see as well as me.

My workaround is simply to push the "12-second skip back" button on the remote, and that fixes it... at least for as long as I leave WMC open. If I close WMC and then re-open it, again the very first 10890i program I start to play will trigger that "black screen and stop, after a few seconds of sound-only and no video". Again, 720p programs don't cause the issue.


Now that your similar experience has confirmed my own, I may uninstall 13.12 (with Driver Fusion) and go back to 13.9, and see if I still have the problem. There's no particular reason I went to 13.12, other than the desire to "keep current" and pick up some possible performance improvements... although generally these are only for much newer cards than my HD5870.

If going back to 13.9 resolves the problem and its two symptoms, which is very annoying both on the HTPC as well as on my extenders, I will simply stick with 13.9. If not, well then I might as well upgrade to 13.12 again.

Interesting experiment. I will report back.
My System SpecsSystem Spec
27 Jan 2014   #3

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Well, I reverted back to 13.9. I also uninstalled (a) AMD Accelerated Video Transcoding and (b) AMD Media Foundation Transcoders, which I'd apparently installed when I did my latest fresh Windows 7 reinstall.

And, sadly, I report that it makes NO DIFFERENCE AT ALL from behavior under 13.12. Opening a 1080i WTV program as the first program played still produces the black screen with sound only for a few seconds, and then it stops, and I have to push SKIP-BACK-12-SECONDS or SKIP-FORWARD-30-SECONDS or just touch the progress bar to kick-start it back to normal life. Opening a 720p WTV program as the first program not only does no harm but also triggers completely normal WMC behavior from that point on, including opening a 1080i program next which this time and forever more (during this WMC session) now plays normally and perfectly.

Closing WMC and re-opening, and then playing that 1080i program... well, we're back to the problem symptom of initial black screen until the "kick start".

Also, the same problem opening extenders also exists.

In other words it does not appear to be tied to the Catalyst 13.9 or 13.12 drivers. So either it is somehow tied to some previous Catalyst version (which is now seeming to be increasingly unlikely) or something more recent in a Windows Update.

==> I'm going back to 13.12, since it appears it's unrelated to this problem.
My System SpecsSystem Spec
.


27 Jan 2014   #4

Windows Vista Ultimate 64-bit
 
 

It does the black screen pause for SD recordings as well. But they last around 9 seconds (vs. 3).
Just to point out, this is the case for live TV as well.

How do you tell what's 720i?


I'm not sure if this is related but I had another problem recently when trying to use 5.1 sound over HDMI going into an HTS.
It says this:
Video Error - Files needed to display video are not installed or not working correctly. Please restart Windows Media Center or restart the computer.

This however, seems to be an old problem and I haven't found a solution from searching yet. Maybe no one solved it reliably. But if you have a surround sound target, maybe you can plug the HDMI into it and see what happens. I'm thinking that maybe it's some HDCP quirk that craps out some drivers?


I'm using this btw: HDHomeRun Prime | Welcome to SiliconDust
My System SpecsSystem Spec
27 Jan 2014   #5

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Quote   Quote: Originally Posted by rasmasyean View Post
It does the black screen pause for SD recordings as well. But they last around 9 seconds (vs. 3).
I don't watch SD channels so I didn't know that. I only watch HD (720p and 1080i).


Quote:
Just to point out, this is the case for live TV as well.
And, I never watch "live" TV either. I only watch what I've set up for recording, which are the shows and series I want to watch eventually... but never sitting through commercials.

So even "live" for me is "nearly live", i.e. if I want to watch something that's on rigyht now I will begin watching my recording at least 15 minutes or more after it's started, so that I can still skip past commercials.


Quote:
How do you tell what's 720i?
Not 720i... 720p.

Essentially EVERYTHING is 1080i, except for the following which are 720p:

ABC broadcast and related family of cable networks (including ESPN)
Fox broadcast and related family of cable networks (including FX)
National Geographic


Quote:
I'm not sure if this is related but I had another problem recently when trying to use 5.1 sound over HDMI going into an HTS.
It says this:
Video Error - Files needed to display video are not installed or not working correctly. Please restart Windows Media Center or restart the computer.

This however, seems to be an old problem and I haven't found a solution from searching yet. Maybe no one solved it reliably. But if you have a surround sound target, maybe you can plug the HDMI into it and see what happens. I'm thinking that maybe it's some HDCP quirk that craps out some drivers?
I've seen this also, but in my experience it's because of faulty recordings... say to a hard drive that is too slow to really keep up with continuous data rates required for HD, but to which you're trying to record multiple programs simultaneously.

My actual solution was to upgrade my hard drive and computer, so that recordings go to a modern large high-speed 64MB cache SATA-III (6Gb/s) 7200rpm drive. No "green" drives that spin at 5900rpm or worse, 5400rpm. If you want to record 4 HD programs simultaneously you'd better have hardware that's up to snuff. And that means high speed drives and motherboard to match. CPU isn't as critical, but the drive used for recording is.

Or, if your network-based tuner (i.e. the HD HomeRun Prime) can't feed data fast enough to your HTPC over your network (e.g. you're trying to record multiple HD channels and your LAN router is only 10/100 instead of gigabit, or the specific wired LAN connection leg from the HomeRun to your HTPC is only 10/100 instead of gigabit, or if you're using CAT5 cables instead of CAT5e or CAT6, well you're going to have problems when you are dealing with multiple HD channels simultaneously being sent around your LAN either to the HTPC from the HomeRun or from the HTPC to extenders or ALL OF THE ABOVE SIMULTANEOUSLY!

Again, if your LAN or connection legs are too slow to support the needs of your home TV network setup, you can also see flawed data recordings which when played back can produce this distracting "files missing - restart" messages. At least that's been my experience.

I had a number of these when I offloaded some recordings to an external USB hard drive, and tried to play them back directly from the external USB hard drive. That external drive was not fast enough or reliable enough to deliver the data in a timely fashion to WMC, and these "files missing" errors occurred constantly. The solution was simply to re-copy the WTV files back from external USB drive to an internal SATA-III hard drive and play them from there. Sure enough, no errors now!

Sometimes I could overcome these errors by pressing STOP and re-starting the playback of that recorded program from the beginning. But instead of just letting it play again I'd use the FF function to speed back up to just past the point in the program I was at when the "files missing" error occurred. The inability to "keep up" during normal speed playback (when video and sound is delivered) didn't seem to be a problem when FF is in effect and there is no audio involved. Once past the "defective recording" point (or what I guessed was a "bad spot") sure enough normal playback now resumed when I pressed PLAY. Of course I might have to do the same thing again a bit later, but at least I was able to eventually fight my way through the program by FF'ing past problem areas. Note that these might not be "hard" and reproducible failures. I might try playing the same program that just gave me trouble, and the second time there's no problem! Very annoying, but again in my opinion due to "bit starvation" because of inadequate hard drive capability and/or insufficient LAN bandwidth from your external tuner(s) to the HTPC.

I have an internal Ceton 4-tuner cablecard-enabled card in my HTPC, not a network based external cable TV tuner like an HDHomeRun Prime. So I don't have an issue with LAN bandwidth, although I do have a CAT6-based gigabit home network and router and switches.
My System SpecsSystem Spec
27 Jan 2014   #6

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

I am now very suspicious of something dealing with de-interlacing (either hardware or software) directly involved with this problem.

That would explain why it only happens with 1080i for HD, or as you say 480i for SD. Both of these must be de-interlaced for display on a flat panel monitor whose native resolution is 1080p. Either software or hardware (controlled by software) is doing this, and I think this is a "giant clue".

In contrast, native 720p programs don't require de-interlacing, but rather only require scaling to 1080p. So they are avoiding the "rogue code" which is responsible for this symptom.

That's my theory.

Also, the secondary related symptom that occurs when starting my extenders... again, my extenders are set to 1080i output resolution almost always (except on those occasions when I change to 720p to watch 720p programs). I'm going to experiment by setting an extender to 720p instead of 1080i and then starting it up to see if the symptom I previously described can once again be avoided by having the extender set at 720p (similar to having WMC play a 720p program as its very first playback an not seeing the "black screen" symptom).

Now I don't yet know what the connection is between the HTPC/monitor/de-interlacing story and the startup of an extender in 1080i/720p (assuming my extender-in-720p experiment is successful in avoiding the extender symptom I previously described). But both of these problems sure does seem very much tied to interlaced content.

Also, it's not obvious why this only happens "first time" or when the extender is powered up and first connected to WMC, and then will never again return as long as WMC remains open or the extender remains powered on it is current session. But I'm not really interested in that explanation, but only want to get to the bottom of what in my system causes the problem in the first place.
My System SpecsSystem Spec
27 Jan 2014   #7

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Mystery solved!!! It's a problem that started with AMD Catalyst 13.9.

I checked my backups, and prior to 13.12 I was using 13.9. Earlier tonight I tried going back to 13.9 and it still "failed" with this symptom. And I had originally installed 13.9 back on September 21. I thought this symptom had started just a month or two ago, but maybe "time really flies by when you're having fun" so maybe I've actually had it longer than just a month or two... like maybe for three or four months.

Anyway, it was still there with 13.9.


So looking further back, while I do have a 13.4 version that I installed at the end of April, I actually went with 13.6 beta 2 when it came out in early July and was highly praised. I don't think AMD ever actually released an official 13.6 WHQL that I can find, but I must have used 13.6 beta 2 from early July until September 21 when they release 13.9 WHQL and I installed it.

So I just now tried going back to 13.6 beta 2. And SURE ENOUGH... THE PROBLEM HAS GONE AWAY!!!

With 13.6 beta 2 the behavior of playing that first 1080i program is now characterized by presenting an image in the window (rather than having a black window as it is with 13.9 and later), with audio playing in both cases. There actually is a very brief "stall" in the video (i.e. it freezes) a few seconds later, but then it quickly resumes normally. And with the video playing and audio now playing normally, that spinning "busy" circle now also appears (which I take to correspond perhaps to some type of initial unique buffering-up whenever playback of a program starts), and which apparently has some first-time bug in the code for 1080i programs starting with 13.9 and not present in 13.6 beta 2. And a few seconds later the spinning "busy" circle disappears, and now the normal video and normal audio is still proceeding normally. So 13.6 beta 2 seems to behave 99.9% perfectly.

The difference is that with 13.9 the opening 1080i image in the window NEVER appears, although audio is present, and that first-time 1080i window is just black. Furthermore, even when the spinning "busy" circle starts spinning over the still black window, there still is no image presented. And even when the spinning "busy " circle stops spinning and disappears, there still is no image presented... and WMC is now clearly "stuck", and even the audio goes away as well. Whatever this first-time buffering was supposed to accomplish for 1080i, apparently it's not working properly and the feeding of image to the window never occurs, locking up WMC. Only doing something like re-positioning or changing channels or anything seems to "kick start" WMC back to life, and now normal behavior resumes, and the lockup never occurs again!!

There is now no question that this entire issue was caused by the AMD driver release 13.9 and whatever they "broke" that impacts WMC behavior on that first 1080i program playback, it still exists in 13.12. It is simply not present in 13.6 beta 2 (although there is that very brief "freeze" a few seconds in, but it's non-fatal and quickly un-freezes with playback now normal even during the spinning "busy" circle for its own few seconds of life).

NOTE: as before, there is ZERO problem when the first program is 720p. It only appears whenever the first 1080i program is played, even if it is many 720p program playbacks later. There's something fatally wrong with handling of the very first 1080i program in a WMC session, beginning with 13.9.


Next, I was curious to know if this would somehow also be related to my second symptom, i.e. the lockup of my DMA2100 extenders if I pushed any button on the remote too quickly after the initial connection to WMC was established. With 13.9 and 13.12 installed I had to hold back and push no button, until the spinning "busy" circle on the HDTV screen connected to the extender appeared after a few seconds, and completed its spinning after a few seconds, and finally disappeared. Only now could I safely push buttons on the remote and have them and the extender work properly.

Well, imagine my surprise when I discovered that this problem, too, disappeared with the 13.6 beta 2 drivers installed! Same as I observed with WMC on the HTPC itself, a few seconds after the WMC connection is completed by the extender, the spinning "busy"circle appears and continues for a few seconds before disappearing. But unlike with 13.9 and 13.12 installed, prior to the appearance of the spinning "busy" circle I can actually push any buttons on the remote and the extender actually honors them. So it's operating normally virtually immediately after connecting to WMC, including a few seconds later when the spinning "busy" circle makes its appearance for another few seconds before disappearing. Everything happens simultaneously and independently, with no "period of vulnerability" for the extender as there is with 13.9/13.12 where I cannot safely push a remote button until the spinning "busy" circle finally disappears.

So again, whatever AMD did in 13.9 (and which is still there in 13.12), it also affects extender behavior.

No such issue in 13.6 beta 2.


Bottom line: now the cause of the problem is known, and it started with 13.9.

Obviously I am now well aware of it, and what the "workaround" needs to be both for the WMC window on the HTPC as well as on an extender, to prevent the extender anomaly from occurring or to "kick start" WMC after the first 1080i program is selected.

So, do I want to remain with 13.6 beta 2 where these issues do not exist? Or do I want to go with the latest 13.12 which has the problems but for which relatively simple workarounds are also known. The problems are really just first-time or one-time, and once the extender is operating normally it will operate normally forever (until powered off). And once WMC is "kick started" back to life, it too will operate normally forever (also until powered off).

I'll have to decide which way I want to go. But at least now the culprit is known, and it is AMD Catalyst 13.9 or newer. Installing the previous 13.6 beta 2 can eliminate the problem.

EDIT: I've decided to go forward with 13.12, and "live with the problems". At least I understand them, what they're being caused by, and how to work around them so they're non-fatal and only mildly annoying immediately after starting WMC or powering up an extender. These seem like very small nuisances, as I typically then watch many hours of TV which will be problem-free even with 13.12.
My System SpecsSystem Spec
27 Jan 2014   #8

Windows Vista Ultimate 64-bit
 
 


Hey, you might be onto something, there! Yeah, I tried ABC, Fox, and ESPNÖand they donít have the first-play black screen pause problem!

Iíve recorded 3 HD movies successfully before so I donít think itís bandwidth in this case. Plus the 5.1 seems to be in the file as I used an SPDIF sound card and the speakers output different things. I have Gb routers, but my cables are mixed Cat 6/5 whatever I got for free stuff. lol

My experience with ďslow systemĒ is trying play something shared via nettop. But I didnít get any messages. It just jitters. Iíll have to try that STOP trick and see what happens. I didnít know it streamed like Youtube. I thought it didnít really have a buffer and just read the file from the remote hard drive.

And come to think of it, ďLive TVĒ is actually a recordingÖon the spot! :P


My System SpecsSystem Spec
27 Jan 2014   #9

Windows Vista Ultimate 64-bit
 
 

I downloaded 12.1 cuz the AMD site didn't make those othe versions available. They were missing from the page.

But, yeah, that solved it! AMD should give you a free video card for finding the bug! I'm sure this analysis you did might save them a lot of debuggin time! There's a place to report it and I suppose you can refer them to this post so maybe they'll come out with a 13.13 soon with the fix.
My System SpecsSystem Spec
Reply

 Windows Media Center playback requires progress bar click




Thread Tools



Similar help and support threads for2: Windows Media Center playback requires progress bar click
Thread Forum
Windows 7 media Center Choppy or stuttering playback Media Center
Playback issue with media center + 360 Network & Sharing
Media Center - MSN tv playback error Media Center
Windows Media Center - Disc Playback - Create Shortcut Tutorials
DVD playback stops in Media Center and Media Player Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:23 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33