Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Playing H.264 video in MC7 - No Audio

08 May 2014   #1
PoBear

Windows 7
 
 
Playing H.264 video in MC7 - No Audio

Hi

I've recently acquired a Freeview HD tuner card and have been experimenting with capturing HD programmes.

The video plays fine in WMP12 and MC7 but I get no audio. VLC plays it OK

I'm running Windows 7 Home Premium X64 fully patched as of last 6 May 2013.

The files are H.264 video and AAC audio in a .ts container full specs below

Video
-----
Codec: H264 - MPEG-4 AVC (part 10) )h.264
Resolution: 1920 x 1080
Frame Rate: 25
Decoded format: Planar 4:2:0 YUV

Audio
------
Stream 1
Codec: MPEG AAC Audio (mp4a)
Language: English
Channels: Stereo
Sample Rate: 48000 Hz

I thought 7 had support for H.264 out of the box!

Any ideas?


My System SpecsSystem Spec
.
09 May 2014   #2
3D Jed

Windows 7 pro x64 SP1
 
 

UK Freeview programs often have more than 1 audio stream eg audio description for visually impaired. Sometimes this stream is present but silent (or mainly silent). Maybe you're trying to listen to the ad track.
My System SpecsSystem Spec
09 May 2014   #3
PoBear

Windows 7
 
 

Thanks

This can be a problem in WMP12, I've had it some SD recordings, but MC7 always seems to sort it out, so whilst it could still be the problem having tried nearly a dozen different recordings I would have expected at least on of them to have worked if it was a stream problem
My System SpecsSystem Spec
.

10 May 2014   #4
jimbo45

Linux CENTOS 7 / various Windows OS'es and servers
 
 

Hi there
Not perhaps the answer you are looking for -- but if it plays in VLC why not just stick to that -- IMO it's far better than WMC anyway.

Cheers
jimbo
My System SpecsSystem Spec
10 May 2014   #5
3D Jed

Windows 7 pro x64 SP1
 
 

Quote   Quote: Originally Posted by PoBear View Post
Hi

I've recently acquired a Freeview HD tuner card and have been experimenting with capturing HD programmes.

The files are H.264 video and AAC audio in a .ts container full specs below
What are you using to capture the HD ? Have you tried watching and recording using WMC ?

WMC doesn't record in a ts container - it saves in wtv format. SD wtv is mpeg2 and HD is h.264. Whilst wtv is non standard, it can be edited in VideoReDo or converted with Handbrake and edited using freeware. If you convert with Handbrake there is often a choice of audio streams.
My System SpecsSystem Spec
10 May 2014   #6
PoBear

Windows 7
 
 

It is definitely not because there are multiple audio streams as I have been able to produce a file with just the video and main audio stream and it is still not working in WMP12 and MC7.

I am actually using Media Portal to do the capture but this should be irrelevant as both MP and MC simply capture the broadcast transport stream into a container, neither actually does any modification to it.

The audio is AAC_LATM which is supposed to be supported.
My System SpecsSystem Spec
Reply

 Playing H.264 video in MC7 - No Audio




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 freezing when playing audio/video
ixF9OqCtD0s I've included a video so you guys at least know what I'm talking about. -- I've done some very basic things, such as update my drivers that needed to be updated, I've also scanned for possible RAT's and malware. Malwarebytes and DarkComet Remover did pop up malware, and they were...
Music, Pictures & Video
Dell l702x BSOD when playing audio or video
I bought a Dell l702x in January and a couple months later installed a SSD and did a clean install of Windows. Since then I have been getting frequent BSODs when playing audio or video. Most of the crashes seem to be with either the Nvidia gt 555m driver or the Intel Graphics 3000 driver. I...
BSOD Help and Support
Audio Crackling when playing Video files via WMC and WMP
Hi, I hope this is the correct forum to post this. Let me know where I should post if not. I Bought a desktop computer last weekend and am testing to make sure it will meet my needs primarily as an HTPC. When using the WMC I have noticed crackling sounds when playing m2ts video files...
Media Center
AVI file playing video and not audio
Hello, I have a windows 7 home premium 64 bit computer. I am trying to play an avi file. It only plays the video and not the audio. Any solutions?
Sound & Audio
BSOD while playing video/audio
I don't know if it's exactly video/audio related, but I had these 3 bsod lately. the last 2 were "bad pool header" bsod. I have the minidumps attached.No new hardware in my machine for a long time. Memory:2.5 gb ram ddr2 667, gpu: msi gforce 7100(nvidia drivers,updated-has it to do with bsods?),...
BSOD Help and Support
Internet Explorer not playing audio or video files
How to Fix "Internet Explorer not playing audio or video files" The reason for the error is because your defaults have changed to a third party program for playing your audio and video files. 1. Click Start, select Default Programs 2. Click Set program access and computer defaults ...
Tutorials


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App