Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Tuner not available after hibernate

02 Aug 2013   #11

Windows 7 Home Premium 32-bit
Tuners also not available after sleep (not just hibernate)

Thought I'd post this here as many years later, this problem still exists and it appears to be a Windows / Media Centre problem and not a hardware / driver issue.

I built my Windows 7 based Home Theater computer over two years ago and have had the 'no tuners available' after resuming from sleep problem ever since I added the 2nd tuner (can't remember which order I added them but I had both a DVB-S & a DVB-T). They always come back after a reboot/cold boot. I got round it by scheduling a task to reset the tuners when the machine resumes from sleep. Works every time as long as the reset runs before I hit the Media Centre button which is always every time now since I put an SSD in for the OS and as long as I remember to quit WMC before sleeping the machine (as the tuners can't be reset if WMC is already running).

The key points I want to make however are these:

Search the internet for 'no tuners after sleep Windows Media Centre' and you will get thousands of results from people using many different make/models of motherboard, TV card, graphics card and they all have the same problem. There's simply no way all these diverse makes/models of motherboards, BIOS', TV Cards would all have the same bug in exactly the same place.

1. I don't think it's anything to do with PCI-E link power state management as two of my tuners are PCI and not PCI-E. And it was like this before I added the USB one as well. And changing the power setting hasn't fixed it for many people.

2. It doesn't appear to be anything to do with power management setting for any of the devices as I (and many others) have tried every combination under the sun to no avail.

3. It's nothing to do with the 'backgroundscan' WMC performs either as plenty of people have disabled this (myself included) and still have the problem


The reason I think 4. is the key bit is this: I have seen loads of reports across the internet from different people with the same problem and they are all using different motherboards, different tuners, different BIOS versions and different drivers/versions of drivers. The problem occurs no matter which manufacturer's hardware you use. I'm using two Hauppauge tuners (DVB-T and DVB-S) and a PCTV USB 290e Nano and I get the problem. I've seen reports from people using Black Gold (e.g. BGT-3620's) with the same problem. I've seen reports from people with TBS TV cards with the same problem. I've seen people with AnySee TV cards having the same problem? I've seen people using AMD chipset motherboards with the same problem. Ditto Intel (Core 2 Duo era, Core-i5 era), nVidia chipset boards and all manner of other peripherals, all with the same problem. What are the chances of independently developed hardware and drivers by all these different manufacturers having exactly the same bug in exactly the same place? Once is chance, twice is a co-incidence, but three is a pattern. The only common denominator is Windows & Media Centre.

The problem has to be in Windows and/or Media Centre. There can be no other explanation. And the sooner MS realise and fix this, the better for everyone.

To me, it is a big hurdle in the wider adoption of Windows Media Centre as a home entertainment hub. I know I could have recommended and sold many more Home Theatre computers if I had the confidence that my customers wouldn't face this problem. As it stands, I hesitate to recommend it as a viable product/solution for this and this reason alone.

Come on MS, this is not a hard to replicate issue. Replicate it in your labs, debug and fix the issue now and make many hundreds of thousands of existing customers (and potentially many millions more) very happy. You owe it to us for standing by you and loyally buying your otherwise good products.

My System SpecsSystem Spec

 Tuner not available after hibernate

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Help with 2nd TV -Tuner
I setup my HTPC and went with the KWorld Hybrid TV Stick UB445-U2 USB 2.0 Interface can be looked up at KWorld UB445-U2 Video Device - That worked fine of course I could only get locals and a few other channels. Decided that it just wasn't enough and purchased the HD Homerun Prime 3...
Media Center
Win 7 Tv Tuner
Im looking to buy a tv tuner for windows 7 and would like to know if this one is working : WinTV-HVR-1250 In fact i only need a simple NTSC analog cable tv tuner nothing fancy... but need to have good image quality... and should be compatible with win 7 :D hope someone cant enlight me on that...
Hardware & Devices
Hibernate or NOT TO Hibernate that is the question
After checking how slow my computer was running, shutting down and taking a nap I decided to shutdown Hibernate and save the time and HD space for other things. Hibernate file is a large file that is build on startup in your root directory of C: It seems to store information so if your...
General Discussion
TV Tuner, help please!
Hey guys, me again with a new battery of inquries. So, I got hooked up with a TV Tuner but am having a hell of a time getting it to pick up any channels from my Verizon FiOS Set-Top box. I have it connected via an S-Video cable, the RCA audio splitter and I’ve even tried directly wiring the...
Media Center
Dual TV Tuner cards or 2 STB boxes and 1 tuner card
Hello, I have MCE7 and windows 7. I have a Pinnacle 800i TV tuner card which receives QAM. Everything works great, but I wanted to get the option to watch a channel while recording another. I was hoping to downgrade my DVR to just a standard box if I can record my shows on my PC. Do I need to...
Media Center
Hibernate startup fails after second hibernate
Hi My computer can only hibernate once, after that, if it has already hibernated once before during the session, it goes into a strange state where the power is never turned off, but I can't return to windows. I have this issue. I have the hibernate button and the computer does never go...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App