Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WMP12 Album Art driving me insane

11 Feb 2009   #1

W7 Build 7000
WMP12 Album Art driving me insane

Sup boys! This is my first thread over here. I am no noob to computers, or forums. My computer is running better than ever coming from XP, with one exception. I take pride in my music collection. It is small, but everything is just the way I want it. All tags are tagged in WMP and my PPC plays them flawlessly. However in Windows 7 when I try to download album info (or it does it automaticlly) it gets all the tags, but fails to get the album art. All of my old ones from XP have their album art, but the new ones just have that crappy note there. I am really struggling with this. TIA!

My System SpecsSystem Spec
11 Feb 2009   #2

Linux (Debian, Android)

I agree.

Vista would update the album art instantly after me moving my music into the folder it recognizes.

With 7 it doesn't. You pretty much have to manually get album art for everything... frustrating.
My System SpecsSystem Spec
12 Feb 2009   #3

W7 Build 7000

OMG! That couldnt suck anymore!
My System SpecsSystem Spec

03 Apr 2009   #4

Windows 7 Home Premium 64 bit

I'm using a program called Mp3tag. It will import album art for you but stinks cause you still have to do 1 album at a time.
My System SpecsSystem Spec
01 Dec 2009   #5

Windows 7

Sorry to bring this back from the dead...

I have a very large collection, which I have meticulously tagged, including album art.

WMP12 is degrading some of the album art, pixellating it, destroying it completely and ignoring it. Not everything, but enough to be maddening.

Are there some kind of size restrictions, or some kind of other requirements for album art in WMP12?

My System SpecsSystem Spec

 WMP12 Album Art driving me insane

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Sound crackling is driving me insane.
Based on my research, I appear to be another victim of windows 7 sound glitches. My specific problem seems to only happen when playing music. Or, at least, I have yet to truly notice it while playing a game or watching video. I've been trying to find a solution for a couple of weeks, including...
Sound & Audio
Browser issue driving me insane
I could just be dumb but when I type in the address bar to go to a site i have to click the green arrow to be able to go to the sire rather than be able to hit the enter/return key. Is there any way to fix this so that every time I want to change pages I dont have to keep clicking the green arrow...
Browsers & Mail
Help, I am going INSANE! WMP12 Album Art.
Hello all, I am going absolutely nuts over the album art in WMP12 - W7x64. The album art is correctly embedded in the file, but WMP12 will show a different picture. I can see the correct picture in Explorer, in the file itself, in my MP3 tag editor, even WMP12 shows a small correct version of...
Media Center
BSOD's driving me insane!
Hi! I'm new one here and I have huge problem. In july BSOD's started to show up. I didn't bothered about it. Then I figured out that when I'm looking videos on youtube. So I didn't watch movies on youtube anymore. But then problem appeared again in December! I played Counter-Strike but suddenly...
BSOD Help and Support
Help Required... Driving me insane!!!
Hello everybody! Firstly i'm new here (so hi, hope you're all well and all that!) and also new to Windows 7. I have a second hand ASUS Eee PC netbook, running W7 Starter. I recently installed Skype and can't seem to get the built in webcam to work. I keep getting the "This device can perform...
Hardware & Devices
Windows explorer lag driving me insane
I have looked and found a few references to problems similar to mine on these forums but no solutions. Apologies if i have missed any. I have a clean install of the retail version of W7 HP 32bit on a W7 formatted HD (300gb velociraptor). I have a pretty fast system with 4gb ram, E8500 CPU and...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:00.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App