Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FFDSHOW Lag

06 Jan 2010   #1

windows 7 32 bit
 
 
FFDSHOW Lag

So I recently discovered ffdshow and its ability to upscale. I adjusted the ffdshow settings through sharks codecs and the quality of mkv files played through media player classic is stunning. However when I try to play them through MCE and mediabrowser I get very slow laggy video. Im not sure what to do to attempt to fix it. Any ideas would be great. As of right now I have ffdshow handling mkv (disable media splitter default).


My System SpecsSystem Spec
.

06 Jan 2010   #2

Windows 7 Home Premium 64bit
 
 

Assuming you have x264 inside the MKV:
H264 TAB: Use FFD Show codec & under H264 in Direct Show player: Use FFD Show
MKV tab : Use Halli Splitter


is this how you have it set?

Will need to set this same way for 32 AND 64bit (if you have 64 OS)

If the audio is AAC 5.1 you may want to set Use Monogram decoder in the SWAP tab


Also, in FFD Show video:
In resize you may want to try different Resizers. This could be the issue:
in resize & Aspect / Settings:
try Bicubic or Lanczos
My System SpecsSystem Spec
06 Jan 2010   #3

windows 7 32 bit
 
 

That is indeed how I have it set in both settings windows. Played around with the different resizers and still the same result. In my sharks codecs I do not have the monogram decoder listed anywhere.
My System SpecsSystem Spec
.


07 Jan 2010   #4

Windows 7 Home Premium 64bit
 
 

It would be under the SWAP tab (or should be)
And in the section for Decode AAC Audio with:
The latest FFDshow show had a issue with 5.1 AAC for some reson. If you dont have 5.1AAC then FFDshow will be fine for 2.0 and others
monogram is only needed for 5.1 AAC until the next FFDshow update


You may also want to double check the codecs, to be sure they are set properly.
Config TAB/ FFDSHOW Video Config
at top CODECS
H264 = ffmpeg-mt
MPEG2 & Other MPEG2=libmpeg2

Also CONFIG/FFDSHOW AUDIO CONFIG:
AAC=libfaad2 ((DISABLED if you set MONOGRAM))
AC3=liba52
DTS=libdts
I doubt these settings are a issue. They should be set correctly already, but worth double checking to be sure.


Curious, what are you resizing to? 1080P?

Also, just for a test to see if its the re-sizer or other issue,
turn off the resizer all together.
How does the Video playback with normal settings?
My System SpecsSystem Spec
07 Jan 2010   #5

windows 7 32 bit
 
 

Playing with the settings, if I turn off the "blur" setting and leave on the "resize" the video plays fine in media center through ffdshow. So it appears that the blur is to blame. Any idea on how I can get the blur setting to work as well because it does make a difference in quality. Thanks for all your help. Oh yeah, Im resizing to 720P.
My System SpecsSystem Spec
Reply

 FFDSHOW Lag




Thread Tools



Similar help and support threads for2: FFDSHOW Lag
Thread Forum
Solved ffdshow conflict with Windows Media Player 12 Sound & Audio
Videos Format & MPC-HC x64 Settings + FFDShow Music, Pictures & Video
Shark007 ffdshow options Media Center
Is it safe to install ffdshow x64 in Windows 7? Software
Problem with codec (ffdshow doesn't work) Music, Pictures & Video
Winamp, Windows 7 and ffdshow problem Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33