Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Find Driver For AMD/ATI TV Theater 650 Pro

08 May 2009   #21

7 Ultimate x64

Iv been having the same problems as you out of the ATI HD-650 & Win 7 (7000).
I never know when Media Center is going to let me watch live TV! Sometimes its there and others...well you know.
Its really getting on my nerves.
I have my copy of 7RC but haven't installed it yet so if you do find a fix Please Post It.

My System SpecsSystem Spec
08 May 2009   #22

Win 7 Ult SP1/Win 10 Pro (all x64)

I will. It worked fine for me in 7000 by the way.
My System SpecsSystem Spec

 Can't Find Driver For AMD/ATI TV Theater 650 Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Find Driver ?!
Hi, Please help me find driver to the webcam of this laptop: Samsung NP305U1A-A02SE It seem more difficult then i thought !! But i think the webcam name is: webcam scb-1100N I hope someone can help me.
how do i get wmc to my home theater
hello, i have a home theater and i want to send my wmc to my pioner receiver in one room and to my samsung bluray player in another room. both r wifi ready and set up. problem is i can get windows media player sent to my devices but i cant get the nice windows media center sent to my external...
Media Center
Theater 550 Pro TV tuner
My Theater 550 Pro TV Tuner worked fine in Vista, I just reinstalled the hardware. 7 Found it, installed it's drivers, and said it was working fine. But the Media Center does not see the card at all, either do other Media programs (Sage, BeyondTV, Media Portal, etc...). Now, when I boot, I get a...
network controller driver accidently removed can't find driver
So the story goes like this I like updating drivers and i thought i found a new chipset. I was wrong I was uninstalling devices i didn't have. i restarted my computer and i couldn't get on the web network controller missing and unknown device which is under adapters. i have a m2n-e sli mobo with...
help no find driver or ??
no find card or driver help men :/

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:52.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App