Windows 7 Forums

maddox47 maddox47 is offline

New Member


Australia au south australia

About Me

  • About maddox47
    Name
    Jeremy
    Location
    Australia
    Country Flag
    Australia
    State/Region Flag
    au south australia

Statistics

Total Posts
General Information
  • Last Activity: 04 Nov 2009
  • Join Date: 02 Nov 2009

System Spec

    OS
    Windows 7 Professional x64 Build 7600
    CPU
    Intel Q9550 @ 3.2 Ghz
    Motherboard
    Gigabyte GA-EP45-DS4P
    Memory
    8 GB G.Skill Pi DDR2 1066
    Graphics Card(s)
    ATI 4870X2
    Sound Card
    Onboard Realtek HD Audio
    Monitor(s) Displays
    2 x Samsung 2443BW LCDs, 1x Hitachi P50X01AU
    Screen Resolution
    1920 x 1200
    Hard Drives
    2 x Seagate 720GB ST3750330AS (Raid)
    2 x Western Digital 1TB WD15EADS
    PSU
    Corsair 750TX (750W)
    Case
    Antec Twelve Hundred (1200)
    Cooling
    TRUE Black Heatsink + 2x Scythe Ultra Kaze 120mm CPU Fans
    Keyboard
    Logitech G15 (first model)
    Mouse
    Razer Lachesis
    Internet Speed
    TPG - 9.5 Mb/s (D), 0.85 Mb/s (U)
    Other Info
    Billion 7800N ADSL2+ Router
    Belkin Nostromo N52TE SpeedPad
    Logitech Z-5500 5.1 Ch Speakers
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App