Windows 7 Forums

Evan

t41 t41 is offline

The Rover


USA us florida

About Me

  • About t41
    Name
    Evan
    Biography
    biker, builder, musician
    Location
    south side of the sky
    Interests
    same as above
    Occupation
    builder
    Country Flag
    USA
    State/Region Flag
    us florida
  • Signature

    No man is smart, except by comparison to those who know less

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 20 Sep 2014
  • Join Date: 01 Apr 2009

System Spec

    Computer Manufacturer/Model Number
    dell optiplex - 2003
    OS
    windows7 7600 x86
    CPU
    itel pentium 4
    Memory
    3.00 GB
    Graphics Card(s)
    diamond radion x1050
    Sound Card
    SoundMax
    Monitor(s) Displays
    dell 2408wfp dell e172fp
    Screen Resolution
    1920 x 1200 1280 x 1024
    Hard Drives
    2 - 80 GB internals WD
    1 - 01 TB ext
    2 - 750 GB ext
    1- 500 GB ext
    all running on system no problems
    Keyboard
    old logitech cordless
    Mouse
    logitech wireless
    Internet Speed
    16 / 4
    Other Info
    networked into my sbs2003 server running sp1 still
    it's a wonder I could even get windows 7 to connect to it

Latest Threads

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:12 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App