Windows 7 Forums

toolman59 toolman59 is offline

Junior Member


UK

About Me

  • About toolman59
    Location
    North Somerset
    Country Flag
    UK

Statistics

Total Posts
General Information
  • Last Activity: 30 Nov 2014
  • Join Date: 28 Feb 2011

System Spec

    Computer type
    PC/Desktop
    Computer Manufacturer/Model Number
    Self build
    OS
    Windows 7 Ultimate 64 bit SP1
    CPU
    AMD FX-8350 Eight Core
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    Corsair Vengeance 16GB DDR3
    Graphics Card(s)
    XFX HD6870 1GB DDR5
    Sound Card
    None Onboard sound
    Monitor(s) Displays
    LG Flatron Wide 20"
    Screen Resolution
    1680x1050
    Hard Drives
    WD1002FAEX Caviar Black SATA3 1TB
    Hitachi 500GB PATA
    Hitachi 320GB PATA
    M4-CT256M4SSD2 ATA Device SSD Sata 3 250GB
    2 off Seagate 2TB ST2000DM 001-1ER164 SATA Disks
    PSU
    OCZ Modxstream Pro 600W Silent
    Case
    Fractal R3
    Cooling
    Artic Cooling Freezer 7 Pro Rev 2
    Keyboard
    Logitech K800
    Mouse
    Logitech Trackman Wheel
    Internet Speed
    12.5Mbits
    Antivirus
    AVG 2015 Free Edition
    Browser
    Google Chrome, Opera, Firefox
    Other Info
    Sky Hub router

Latest Threads

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:13.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App