Windows 7 Forums

Tsunamijhoe Tsunamijhoe is offline

Junior Member

Statistics

Total Posts
General Information
  • Last Activity: 22 May 2014
  • Join Date: 30 Apr 2010

System Spec

    Computer type
    PC/Desktop
    Computer Manufacturer/Model Number
    custom
    OS
    Windows 7 Ultimate SP1 64bit
    CPU
    Core I3 2100T/Core I5 750/Core I3 2120
    Motherboard
    ASRock Z77 Extreme4/Gigabyte GA-H55-UD3H/Asrock H61DEL
    Memory
    2x4GB 1600mhz/2x4GB 1600hmhz/2x4GB 1333mhz
    Graphics Card(s)
    onboard/onboard/ASUS HD7850-DC2-2GD5-V2
    Sound Card
    not active/onboard/onboard
    Monitor(s) Displays
    Philips 42"
    Screen Resolution
    1920x1080
    Hard Drives
    WD Red WD30EFRX
    WD20EARX
    WD20EARS
    WD20EACS
    PSU
    Corsair GS700/Antec 500w Earth watts/Corsair TX650 V2
    Case
    Antec Twelve Hundred V3/2xAntec Sonata Elite
    Cooling
    generic
    Keyboard
    2xMS natural Ergonomic
    Mouse
    MS Wireless/logitech laser/steelseries Xai
    Internet Speed
    20/2mbit
    Other Info
    2x IBM serveraid 1015M IT Flashed 8xPort SATA
    4x X-case 5in1 drive cages (norco rebranded)

Latest Threads

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:27 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App