Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Outlook 2007, rules and alerts not working

26 Aug 2011   #1

Windows 7 professional x64
 
 
Outlook 2007, rules and alerts not working

Hi Everyone,

I use imap e-mail account (not a gmail) and outlook 2007 client.
I have several rules to dump mails to different folders, they should work automatically, however it is not the case, e-mails arrive and no action is taken.
When I run the rules manually, it works as expected.

And yes rules have small box checked next to them, meaning that they are active, but it doesn't make any difference if it is checked or unchecked behavior is the same, no action is being taken unless i run the rules manually.

Summary: no action is being taken by outlook itself even-though rules are enabled.

My System SpecsSystem Spec
.

26 Aug 2011   #2

Windows 7 Ultimate 64bit
 
 

How many rules do you have ?
Try changing the order of the rules (or disable the rules one at a time), I've seen in the past that sometimes 1 rule will cause the others not to run or work properly. I've also heard that an MS update caused problems with rules in the past
My System SpecsSystem Spec
26 Aug 2011   #3

Windows 7 professional x64
 
 

currently I am testing only with one rule!
My System SpecsSystem Spec
.


26 Aug 2011   #4

Windows 7 Home Premium 64bit
 
 

Some interesting suggestions on this problem here:
Rules do not work automatically | MSOutlook.info
My System SpecsSystem Spec
26 Aug 2011   #5

Windows 7 professional x64
 
 

Additional info:

The filter that I am using is as follows:

Apply this rule after the message arrives
sent to e-mail_address
and with MY_WORD in the body
and on this machine only
disply NOTIFICIATION
and move to Folder
=========================
Only works if I run the rule manually!

However if remove the word from message body, than it works automatically. thing is I have to filter e-mails based upon that specific word in the body.

Any ideas why the filter doesn't work automatically but works when it ran manualy??
My System SpecsSystem Spec
26 Aug 2011   #6

Windows 7 professional x64
 
 

Quote   Quote: Originally Posted by Irene View Post
Some interesting suggestions on this problem here:
Rules do not work automatically | MSOutlook.info
Tried this one, didn't solve the problem.
However identified new problem.

Outlook will filter messages without problem based upon sender or receiving email, rule works than.
As soon as I add word to the message header or body, or combination of those two, it stops. Same rule works if i run it manually.
This is still only rule that I am testing behavior with outlook. Still don't get the point why does it work when run manually.
In Addition: in send and receive I configured to download entire message content, headers body, attachments.
My System SpecsSystem Spec
26 Aug 2011   #7

Windows 7 Home Premium 64bit
 
 

Some more ideas from people with same/similar problems:
Q&A: Outlook 2007 - rules do not run automatically | TechRepublic

Please let us know if any of them work for you.
My System SpecsSystem Spec
26 Aug 2011   #8

Windows 7 professional x64
 
 

Quote   Quote: Originally Posted by Irene View Post
Some more ideas from people with same/similar problems:
Q&A: Outlook 2007 - rules do not run automatically | TechRepublic

Please let us know if any of them work for you.
This one was the first one that i googled.. didn't work so i started thread here
My System SpecsSystem Spec
26 Aug 2011   #9

Windows 7 Home Premium 64bit
 
 

zrefa, I have just replicated your rule on my laptop which has Outlook 2007 and a specific email address.

I then send two test emails from my desktop using my main email address, including the phrase 'my_word' in the body of one and the subject of the other - it worked perfectly - I had an alert box with NOTIFICATION on it containing two emails, both of which had been transferred to the specified file!!

Don't know what to suggest now.
Illustration below - naturally I removed my email address.
.
.


Attached Images
 
My System SpecsSystem Spec
26 Aug 2011   #10

Windows 7 professional x64
 
 

Quote   Quote: Originally Posted by Irene View Post
zrefa, I have just replicated your rule on my laptop which has Outlook 2007 and a specific email address.

I then send two test emails from my desktop using my main email address, including the phrase 'my_word' in the body of one and the subject of the other - it worked perfectly - I had an alert box with NOTIFICATION on it containing two emails, both of which had been transferred to the specified file!!

Don't know what to suggest now.
Illustration below - naturally I removed my email address.
.
.
Thanks for testing this for me.
Are you using imap or exchange for your account ?
My System SpecsSystem Spec
Reply

 Outlook 2007, rules and alerts not working




Thread Tools



Similar help and support threads for2: Outlook 2007, rules and alerts not working
Thread Forum
Outlook 2007 account not working Microsoft Office
Outlook 2010 - Alerts for new emails in 2nd Account not working Browsers & Mail
Outlook 2010 Desktop Alerts not working after recreating user profile Microsoft Office
Solved Outlook 2007 quit working Microsoft Office
Outlook Alerts not Working... Microsoft Office
Outlook 2007 desktop Alerts Don't Work Microsoft Office
Outlook 2007 - URL links not working Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33