Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Office 2k7 Install Error

18 Jan 2010   #1

Windows 7 Professional 64 bit
 
 
Office 2k7 Install Error

Hello everyone! I'm new to the forums.

I've had Office 2007 Enterprise since it came out. Worked fine on Windows XP Home 32bit and worked fine on Windows 7 Ultimate 64bit RC.

Well a few weeks ago I got around to doing all the upgrades to my computer, including installing Windows 7 Professional 64bit. I installed Office that day but didn't go to use it until a couple days ago.

When I go to launch any program I get the configuring windows followed by the "Microsoft office has not been installed for the current user" error. However, there's a twist. I go to my admin account and it loads up right away, no problem. I tried repairing it. No luck. I tried uninstalling it an then running the program as admin in my account, no luck. Uninstalled it again and tried using the admin account, no luck. Same problem, only now Word will open in my account but gives me errors when I try to open a downloaded doc file without saving it to the desktop first. I can't get into any of the other programs on my account, but as I said it works in admin fine. I tried making a new account to see if anything would change but nope.

Thoughts or suggestions would be much appreciated.

My System SpecsSystem Spec
.

18 Jan 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

Welcome Kimura, Here's some info I found from Micrsoft answers that might help you out.
Cannot Uninstall Office 2007.

This program will help you clean up the uninstall issue and then you can work on getting it reinstalled.
Revo Uninstaller - Free software downloads and software reviews - CNET Download.com

If you continue to have problems just post back and someone will help you out.
My System SpecsSystem Spec
18 Jan 2010   #3

Windows 7 Professional 64 bit
 
 

Thanks for the links! What a nifty uninstaller program. I used it to uninstall office, remove the registry key/entries and misc. files. Robooted the computer, and installed Office again. Unfortunately I still get the same problem
My System SpecsSystem Spec
.


18 Jan 2010   #4

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

You're welcome. You might want to try this tutorial and see if that helps.
SFC /SCANNOW Command - System File Checker
See if that finds anything and fixes it. then try your install again.
My System SpecsSystem Spec
18 Jan 2010   #5

Windows 7 Professional 64 bit
 
 

Verification 100% complete.

Windows Resource Protection did not find any integrity violations.
My System SpecsSystem Spec
18 Jan 2010   #6

Windows 7 Professional 64 bit
 
 

I don't get it. It's installed on two other computers with Windows 7 Home Premium 64 bit and they have no problems.
My System SpecsSystem Spec
19 Jan 2010   #7

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

I didn't have any problem installing enterprise on my home premium either, Here's something I found. Also have you tried installing in compatibility mode?
How to troubleshoot problems that may occur when you try to install a 2007 Office system program from the 2007 Office system program CD or DVD
Let us know what happens, Good Luck.


P.S. Here's some other info.
http://social.answers.microsoft.com/...b-392584bb0ba8

Office 2007 will not install :(
My System SpecsSystem Spec
20 Jan 2010   #8

Windows 7 Professional 64 bit
 
 

Well I know its not the disk or the CD drive. Just installed it on my Virtual XP with no problems or errors.

I followed the instructions via the 3rd link to resent the security settings...

Quote:
Sample command to reset security settings

The steps below do not apply to Windows XP Home Edition, or Windows Vista Home Basic and Home Premium editions. To restore security setting for Home editions, either use the Microsoft Fix, System Restore or a backup.Note After security settings are applied, you cannot undo the changes without restoring from a backup. If you are uncertain about how to restore your security settings to the default settings, you must make a complete backup that includes the System State (the registry files). Items that are reset include NTFS file system files and folders, the registry, policies, services, permissions , and group membership.

To restore your operating system to the original installation default security settings, follow these steps:
  1. Open a new Command Prompt:

  2. In Windows XP
    • Click Start, click Run, type cmd, and then press ENTER.
    In Windows Vista
    • Click Start and then type cmd in the Start Search box.
    • In the results area, right-click cmd.exe, and then click Run as administrator. You will be prompted to type the password for an administrator account. Click Continue if you are the administrator or type the administrator password. Then, click Continue.
  3. In Windows XP, type the following command, and then press ENTER:secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    In Windows Vista, type the following command, and then press ENTER:secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose
    You receive a "Task is completed" message and a warning message that something could not be done. You can safely ignore this message. For more information about this message, see the %windir%\Security\Logs\Scesrv.log file.
I got:

Quote:

The system cannot find the file specified.

The task is completed with an error.
See log %windir%\security\logs\scesrv.log for detail info.
I haven't gone further than that. I'm gonna get some sleep! Try some more tomorrow.
My System SpecsSystem Spec
20 Jan 2010   #9

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

Did you try installing in compatibility mode?
My System SpecsSystem Spec
20 Jan 2010   #10

Windows 7 Professional 64 bit
 
 

Well I went into the admin account and checked the security settings for the programs. Turns out full control wasn't being granted to user accounts or my account. So I checked off the boxes to allow full control. Everything seems to run now, but I still get "preparing to install" for a few seconds followed by a UAC popup asking me if I want to allow Word etc. to to make changes to the computer before it will start up.

I don't get this issue at all in admin mode, and none of the other Windows 7 computers running it have this problem either.

Also when I download doc files from my yahoo email account I can't just open the file from the download manager. I get "There was an error sending the command to the program". I have to start word first in order to open up a file.

So it seems I can sort of use it now but I wouldn't call it resolved.
My System SpecsSystem Spec
Reply

 Office 2k7 Install Error





Thread Tools



Similar help and support threads for2: Office 2k7 Install Error
Thread Forum
Error while trying to install and uninstall Office 2010 Microsoft Office
Error 1935 - impossible to install Office 2010 Microsoft Office
Office 2010 Gets Install Error Microsoft Office
Office 2010 Install stops with no error Microsoft Office
Office 2010 Beta install error! Microsoft Office
Office 2007 Basic sp1 or sp2 install error Microsoft Office
Error With Office 2010 Beta Install Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33