Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't get Office 07 Enterprise to Work

01 Feb 2010   #1
0Gravity

Windows 7 Pro 64
 
 
Can't get Office 07 Enterprise to Work

Hi All,
Let me start by saying.....Why is it EVERYTHING in Windows 7 seems to be a hassle...I can't even install one of Microsoft's own programs without having issues!
This all started when I decided to upgrade from Office 03 because I could not get Windows mobile device center(Another Microsoft Application) to sync my PDA to Outlook, So I figured maybe it was due to an outdated office suite! Now I installed Office 07 Ent. Ed. using the "Run as admin" option on the setup (Even though I am installing from an admin account....Why did MS make things this difficult in Win7?)
So now when I click on ANY of the office apps I get...

"Microsoft Office XXXX has not been installed for the current user. Please run setup to install the application."

I don't understand this....The current user is THE ONLY USER and it is the admin account....I have tried taking "Ownership...another lovely hoop Win 7 seems to like to make you jump through!" I have made sure that the current USER has any and all "Permissions" granted.....The only way I can seem to get any of them to work is by going into compatibility mode and checking the "Run as Administrator" option, and then some of the apps wont run in compatibility mode, and I should not have too use this mode anyway, from what I understand!

I apologize for the rant, but I REALLY am about ready to give up on Win 7 and go back to XP, and I really like 7, when it works! These are NOT the first programs I have had issues with and I am really tired of having to use "Workarounds" to get programs to run!
Please Help me figure out what I am doing wrong? Do I need to have more then one account set up, an Administrator ONLY account and then My everyday use account? The way I have it setup now is when I fire up my PC it boots and goes strait into my "Mikes" account without any password....Is this my problem? Does the admin account HAVE to be passworded? IDK...
Thanks in advance for any help,
Mike



My System SpecsSystem Spec
01 Feb 2010   #2
ickymay

win7 ultimate / virtual box
 
 

Quote   Quote: Originally Posted by 0Gravity View Post
The way I have it setup now is when I fire up my PC it boots and goes strait into my "Mikes" account without any password....Is this my problem? Does the admin account HAVE to be passworded? IDK...
Thanks in advance for any help,
Mike
no that shouldn't be a problem, in fact I have my win7 install set this way and I have never had the issue your experiencing

there is something wrong with your install and or office, I don't think I installed my versions using right click as admin and i think it was allow these settings for all users (can't remember).

I would try a full unninstall reeboot then full install, this sounds like a user problem on your PC, have you changed any user folder settings ?
My System SpecsSystem Spec
01 Feb 2010   #3
0Gravity

Windows 7 Pro 64
 
 

[QUOTE=ickymay;542521]
Quote   Quote: Originally Posted by 0Gravity View Post
I would try a full unninstall reeboot then full install, this sounds like a user problem on your PC, have you changed any user folder settings ?
I completely uninstalled and reinstalled last night and finished patching to SP2 and I still have the same problem....As far as I know I have not changed any settings for my user folder. The only thing I am wondering if it has effected my Win7 install is that I did a clean install of Windows 7 but I used the "Files and Settings Wizard" to get settings from my XP install to Win7, and both systems Use the same User account name, so I have noticed, (as seen in the attached picture), in my C:/users folder in both my "mikes" account and the "All Users" account I have, what appear to be folders or possibly "Shortcuts to folders" from my XP install, that I cannot gain access too....Does anyone know if this is normal?

In this pic notice the "application data" and Duplicate "My Documents" and other folders with the little arrow on their Icon's, these are the folders I am refering to...when I try to open them I get a message saying the folder is not accesable Access Denied....are these remnents of my old XP install? If so can they be safely deleted?
Also could I start from scratch and create a new "User" and delete this current "Mike" user profile and somehow transfer or activate programs I already installed to the "Mike" profile? I'm thinking the XP files and settings somehow corrupted my user profile of the same name on Win7, but I dont neccesarily want to do a whole "Fresh Install" again!
Thanks again,
Mike


Attached Images
 
My System SpecsSystem Spec
01 Feb 2010   #4
0Gravity

Windows 7 Pro 64
 
 

Ok I finaly got All the Office Apps to stop giving me the "Not installed for the current user" Message!
What I ended up doing is Shut Off the UAC for my user account and everything works fine now! For those that might not know, this is found in Control Panel/User Accounts/Change user account control settings and it looks like the picture below....I took it off the Default setting and set it to NEVER NOTIFY! I have no idea why the default setting would not let me use Microsoft Office but I stopped trying to figure out Microsofts thinking! So now I guess my system is less secure because the policys set for these settings are too strict!
But if it stops all the problems I have been having getting programs to work....I am a happy camper!

Thanks Again for the suggestions,
Mike


Attached Images
 
My System SpecsSystem Spec
02 Feb 2010   #5
ickymay

win7 ultimate / virtual box
 
 

Quote   Quote: Originally Posted by 0Gravity View Post
Ok I finaly got All the Office Apps to stop giving me the "Not installed for the current user" Message!
What I ended up doing is Shut Off the UAC for my user account and everything works fine now! For those that might not know, this is found in Control Panel/User Accounts/Change user account control settings and it looks like the picture below....I took it off the Default setting and set it to NEVER NOTIFY! I have no idea why the default setting would not let me use Microsoft Office but I stopped trying to figure out Microsofts thinking! So now I guess my system is less secure because the policys set for these settings are too strict!
But if it stops all the problems I have been having getting programs to work....I am a happy camper!

Thanks Again for the suggestions,
Mike
that would suggest it's about permissions, if you have a look at the folders you imported with the transfer wizard by right clicking properties, then the security tab, you will likely find you need to edit the permissions for your user name ?
My System SpecsSystem Spec
02 Feb 2010   #6
0Gravity

Windows 7 Pro 64
 
 

Quote   Quote: Originally Posted by ickymay View Post
that would suggest it's about permissions, if you have a look at the folders you imported with the transfer wizard by right clicking properties, then the security tab, you will likely find you need to edit the permissions for your user name ?
You would think that, but I tried it a while ago and I have the permissions for the folders and for my Username set to "Full Control" Everything kind of points to this whole problem being about an Admin/Permission thing.....but I have only one User set up on this system and it is set as Administrator....so I dont know!

Thanks,
Mike
My System SpecsSystem Spec
Reply

 Can't get Office 07 Enterprise to Work




Thread Tools





Similar help and support threads
Thread Forum
MS Office Enterprise Word 2007 problem.
I'm having this problem since yesterday and I'm helpless. Whenever I press enter to go to the next line, it always leaves one line in between even if I don't want it to. See the screen shot where I write "Hello!" and press enter only once. Any help?...
Microsoft Office
How could I fax in office Enterprise 2007 &Win 7 Ultimate x64?
I do not own a fax mechine in my home. I have written a document and filled in a PDF form and saved in my computer. I have written my document in the Office Enterprise 2007-Word on my desktop that has Win 7 Ultimate x64 OS. Is ther a free software that I could use to fax my document...
Microsoft Office
MS Office Enterprise 2007 - missing Help
I am not sure when this happened, but there is no data in the 'Help' links to any of the modules. When I press the "?" help links, either nothing happens at all or a box opens and when I touch 'list the index' it appears on the left, but nothing displays on the answer box on the right. I have...
Microsoft Office
Office 2010 Enterprise ??? does it exist
Hi there I was looking for the replacement to Office 2007 Enterprise (multiple activations allowed) but could only find Office Professional Plus 2010 on Technet. However uou can get the Terminal Services Key from technet and use THIS key instead of the Office 2010 key for your office installs...
Microsoft Office
trail of Office enterprise
I have a office enterprise key, how ever i lost my CD for it, so i wondering where can i get the trial version for office enterprise 2007, so that i can add my key to activate it fully
Microsoft Office
Windows 7 RC & Office 2007 Enterprise
Hello, I install Windows 7 RC and try to install Office 2007 Enterprise edition, but I got one error message, that canīt be found Enterprise.WW folder. I got the right folder in the patch, but got the same error next. Anyone has the same problem????? Can ayone help me??? Thanks a lot. ...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 23:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App