Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Office 2010 Professional Plus Installation Error


04 Jun 2010   #1
LS2010

Windows 7 Pro
 
 
Office 2010 Professional Plus Installation Error

I've recently downloaded Office 2010 Professional Plus from the Microsoft Home Use Program. When I try to install it, the process encounters an error (actually crashes explorer.exe most times through the installation process) - the problem is, it doesn't specify an error code! I'm not overly computer savvy, so maybe I'm looking in the wrong spot, but the extractor doesn't seem to be extracting the setup files into my Temp folder and there is no log file located there for me to reference for an error code. I have lots of space on my drive (~30 GB), so setup should not be aborting due to space limitations. I'm running Windows 7 Professional and it is kept current according to Windows Update.

I've gone through the forums here and other Google sources and tried everything I could find from deleting old Office installations, to changing permissions, etc. Mind you, there isn't much troubleshooting information given that Office 2010 is still only early in its release - I can't even find the official Microsoft support site for the suite. My old installation of Office 2007 is deleted (folders and registry entries) and I've restarted many times, without effect.

I am not encountering any error when I try to install Project Professional 2010 or Vision Premium 2010 (they install and work fine).

Needless to say, I'm at a dead end in terms of knowing what to do next. Very much appreciate any assistance the more knowledgeable users can provide.

I've attached a screenshot of the (very unspecific) error message that setup displays.

Thanks,
Liam




Attached Images
 
My System SpecsSystem Spec
04 Jun 2010   #2
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

Hello !! Welcome to SF !!

Yes the Error is no specfic at all. Lets try to find what's the issue.
Goto Start | Event Veiwer | Windows Logs | Application and look for MSIINSTALLER Errors post us the descrption it might give us a clue where to get you started.

Hope this helps,
Captain
My System SpecsSystem Spec
04 Jun 2010   #3
davinp

Windows 7
 
 

I too have the same problem and I'm at my wits end.

The setup log in the application data/temp folder shows error code 1603

Error attaching to OSE, error 0x00000000
Stopping running ose
LIS: start uncaching for download "{90140000-0016-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0016-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-0018-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0018-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-0019-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0019-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-001A-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-001A-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-001B-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-001B-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-002C-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-002C-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-0044-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0044-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-00A1-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-00A1-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-00BA-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-00BA-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-0115-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0115-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{90140000-0117-0409-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{90140000-0117-0409-0000-0000000FF1CE}-C"
LIS: start uncaching for download "{91140000-0011-0000-0000-0000000FF1CE}-C"
LIS: finished uncaching for download "{91140000-0011-0000-0000-0000000FF1CE}-C"
Error attaching to OSE, error 0x00000000
Stopping running ose
SystemRestore : Attempting to cancelling System-Restore-Point for Product [Microsoft Office Professional Plus 2010 Trial] (with RestorePointType [0, Installed]).
SystemRestore : Successfully cancelled System-Restore-Point for Product [Microsoft Office Professional Plus 2010 Trial] (with RestorePointType [0, Installed]).
Showing completion dialog.
Reboot requested if needed.
No reboot is needed.
Catalyst execution finished: 06/01/2010 22:23:22. Return code: 1603.
PERF: TickCount=12147907 Name=RunSetup Description=End function
My System SpecsSystem Spec
05 Jun 2010   #4
LS2010

Windows 7 Pro
 
 

davinp has the same error that I do ... when I look up the log (thanks for the heads up on where to find it), it's an error 1603.
My System SpecsSystem Spec
05 Jun 2010   #5
kucing13

 

my friend having this issue too. And im looking forward to the answers.
My System SpecsSystem Spec
05 Jun 2010   #6
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

Hello !!

  1. Click Start and then type cmd in the Start Search box.
  2. Type cd "%allusersprofile%\Application Data\Microsoft Help", and then press ENTER,
  3. Type attrib -h rgstrtn.lck, and then press ENTER.
  4. Type del rgstrtn.lck, and then press ENTER.
  5. Type exit, and then press ENTER.
Once you delete Rgstrtn.lck file, you can try to install it again and see what happens.
1. In the "Start" menu, locate "Command Prompt". Right-click and choose "Run as Administrator". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

2. Type the following commands, then press "Enter" to execute them one by one. Please
note the space before the command and its parameter.

takeown /f C:\Windows
cacls C:\Windows /G administrators:F

Note: I assumed that your operating system installed on C:\.

3. Restart the computer to check the issue.
After this, please try to install the Office program again.

If the problem persists, we can also try to check the permissions of the registry keys:
=============
First, I suggest we check the related Registry permissions by performing the steps below:
1. Click "Start", in the Search box, type regedit" (without quotation marks) and click OK.

2. Right-click HKEY_LOCAL_MACHINE and choose Permission.

3. Please check if "Administrators" is listed in the "Group and User" name list. If not, please click the "Add" button and type "Administrators" in the open window and click "OK" to add this group.

4. Highlight "Administrators" and check on "Full Control" under "Accept".
5. Click the "Advanced" button and choose the "Owner" tab.

6. Highlight the current user account in the list and mark the check box before "Replace owner on subcontainers and objects".
7. Click OK to save changes

Note: if there is the warning information "Error: The Registry Editor could not set security in the key currently selected, or some of its subkeys", it is normal. Please click "OK".

8. Click OK again to save the changes and exit the Properties window.
Then, please repeat the steps above to check permissions for this key:
HKEY_CLASSES_ROOT

Then, try to install the Office program again.

Source: Microsoft Office Professional Plus 2010 encountered an error during setup

Hope this helps,
Captain
My System SpecsSystem Spec
05 Jun 2010   #7
davinp

Windows 7
 
 

I've tried that and everthing else at the Microsoft site. I don't see the rstrtn.lck file on my computer

Quote   Quote: Originally Posted by Capt.Jack Sparrow View Post
Hello !!

  1. Click Start and then type cmd in the Start Search box.
  2. Type cd "%allusersprofile%\Application Data\Microsoft Help", and then press ENTER,
  3. Type attrib -h rgstrtn.lck, and then press ENTER.
  4. Type del rgstrtn.lck, and then press ENTER.
  5. Type exit, and then press ENTER.
Once you delete Rgstrtn.lck file, you can try to install it again and see what happens.
1. In the "Start" menu, locate "Command Prompt". Right-click and choose "Run as Administrator". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

2. Type the following commands, then press "Enter" to execute them one by one. Please
note the space before the command and its parameter.

takeown /f C:\Windows
cacls C:\Windows /G administrators:F

Note: I assumed that your operating system installed on C:\.

3. Restart the computer to check the issue.
After this, please try to install the Office program again.

If the problem persists, we can also try to check the permissions of the registry keys:
=============
First, I suggest we check the related Registry permissions by performing the steps below:
1. Click "Start", in the Search box, type regedit" (without quotation marks) and click OK.

2. Right-click HKEY_LOCAL_MACHINE and choose Permission.

3. Please check if "Administrators" is listed in the "Group and User" name list. If not, please click the "Add" button and type "Administrators" in the open window and click "OK" to add this group.

4. Highlight "Administrators" and check on "Full Control" under "Accept".
5. Click the "Advanced" button and choose the "Owner" tab.

6. Highlight the current user account in the list and mark the check box before "Replace owner on subcontainers and objects".
7. Click OK to save changes

Note: if there is the warning information "Error: The Registry Editor could not set security in the key currently selected, or some of its subkeys", it is normal. Please click "OK".

8. Click OK again to save the changes and exit the Properties window.
Then, please repeat the steps above to check permissions for this key:
HKEY_CLASSES_ROOT

Then, try to install the Office program again.

Source: Microsoft Office Professional Plus 2010 encountered an error during setup

Hope this helps,
Captain
My System SpecsSystem Spec
05 Jun 2010   #8
LS2010

Windows 7 Pro
 
 

I also don't have that file on my computer and that procedure (thanks for providing the help) didn't work unfortunately.
My System SpecsSystem Spec
05 Jun 2010   #9
LS2010

Windows 7 Pro
 
 

Everyone,

I just came across this source that offers some good insight. Apparently the default install is the issue - the error is associated with one of the packages. I just tried installing the main programs (word, excel, etc) alone without the shared components and it worked like a charm. I'm going to run installer again to try to install the other parts of the suite.

Office Plus 2010 Volume License Download Install Fails with error 1603
My System SpecsSystem Spec
18 Sep 2014   #10
vinita

Windows 7 Ultimate 64 bit
 
 

@ravi5kumar: Office 2010 uninstalled successfully by your method.
but now i could not reinstall office 2007/office 2010 again...
My System SpecsSystem Spec
Reply

 Office 2010 Professional Plus Installation Error




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:34 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App