Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Video lag on ALL MEDIA PLAYERS, please help!

27 Jan 2011   #1

win 7
 
 
Video lag on ALL MEDIA PLAYERS, please help!

so I've been having this issue on my laptop for about a month now. It just started one day and even after reinstalling windows 2 days ago, the problem is still there.

Whenever I watch a movie any video format including high quality, mkv files my video lags, the picture just freezes, gets choppy, the sound continues to work, but video is freezing and eventually I have no other solution than click pause/play a few times, so the picture and sound gets correct again. I don't know what the problem could be, but every player does it, VLC, KMplayer, RealPlayer, WMP,MPHC, so please help me as it's driving me crazy here.

Here's what codecs I have installed if that is of any help,

K-Lite Codec Pack Full
Combined Community Pack
CoreAVC Professional Edition 1.9.5
SRS Audio Sandbox (to amplify sound on my laptop when I watch movies without headphones)

I don't think any of the codecs is causing it, cause I had only K-Lite codec pack installed 2 days ago and I still had video lag, so any idea what it could be?

here's also my laptop specs:

Technical Specifications of MSI CX605 :
Screen 15.6WXGA HD (1366 768) Processor Intel Core 2 Duo RAM Installed (Max) max 4 GB DDR2 667/800 MHz, 2 slots storage space 160/250/320/500 GB Graphics Card ATI Mobility Radeon HD5470 1GB DDR3 dedicated Optical Drive DVD Audio System 2 speakers Webcam 1.3 Megapixels with microphone Network Wi-Fi 802.11 b / g / n + Ethernet Bluetooth Optional Bluetooth 2.1 + EDR Card Reader 4 in 1 Output (s) video HDMI, VGA Fingerprint Reader Non Input (s) / Output (s) Headset, Microphone ExpressCard Non Firewire Non USB 3 USB 2.0 Operating System 7 Windows Home Premium Battery Li-Ion 6-cell Autonomy announced Non Dimensions (mm) 374 x 247.5 x 18-35 Weight 2.48 Kg (with battery)

My System SpecsSystem Spec
.

27 Jan 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

It's not a codec problem VLC doesn't use codecs unless you specifically tell it too.

a quick note on that though, you want either cccp or klite, not both, they WILL conflict with each other. I suggest scrubbing them both and picking one.
CoreAVC is most useful with nvidia cards because of CUDA and probably isn't going to be a lot of help with the ati card.

Seeing as this is a laptop my first suggestion is to turn full power mode on. Running with normal laptop power mode settings is going to degrade video performance noticeably.
My System SpecsSystem Spec
27 Jan 2011   #3

win 7
 
 

Quote   Quote: Originally Posted by Maguscreed View Post
It's not a codec problem VLC doesn't use codecs unless you specifically tell it too.

a quick note on that though, you want either cccp or klite, not both, they WILL conflict with each other. I suggest scrubbing them both and picking one.
CoreAVC is most useful with nvidia cards because of CUDA and probably isn't going to be a lot of help with the ati card.

Seeing as this is a laptop my first suggestion is to turn full power mode on. Running with normal laptop power mode settings is going to degrade video performance noticeably.
ok then if I remove CCCP the thing I'm concerned about is whether SRS Audio sandbox will still give me an option to use it wih my normal speaker configuration...otherwise I'll just have to get rid of K-lite. Which one's better tho?

well if I don't have coreavc my .mkv files get laggy...I don't know if k-lite only can handle .mkv wih its codecs?

oh and about full power you probably mean power plans 'high performance/power saver/balanced' no?

I currently have power saver choosen on both options - on battery and adapter plugged in...should I choose high performance then for when I have it plugged in?
tho it still means when on battery probably video will still lag again since there I have power saver on, cause batery exhauses too fast?
My System SpecsSystem Spec
.


27 Jan 2011   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

klite has more in it, but I have never had need for anything beyond the standard cccp set personally.
Klite mega becomes a little more useful if you are attempting to make a lot of stuff yourself. For playback cccp is much lighter and easier to deal with.
If your only concern is mkv's specifically, you can get just the matroska pack
Free-Codecs.com : Download Matroska Pack Full 1.1.2, Matroska Pack Lite 1.1.2 and Matroska Pack MPEG4 1.0.3

and yes, high performance when it's plugged in. Your choice on whether to do it when the batteries are on, it will drastically reduce battery life though.
My System SpecsSystem Spec
27 Jan 2011   #5

win 7
 
 

Quote   Quote: Originally Posted by Maguscreed View Post
klite has more in it, but I have never had need for anything beyond the standard cccp set personally.
Klite mega becomes a little more useful if you are attempting to make a lot of stuff yourself. For playback cccp is much lighter and easier to deal with.
If your only concern is mkv's specifically, you can get just the matroska pack
Free-Codecs.com : Download Matroska Pack Full 1.1.2, Matroska Pack Lite 1.1.2 and Matroska Pack MPEG4 1.0.3

and yes, high performance when it's plugged in. Your choice on whether to do it when the batteries are on, it will drastically reduce battery life though.

thank you. I've unninstalled CoreAVC and kept K-lite and CCCP only because of the audio codecs for SRS Audio Sandbox, so I really hope those two won't interact.
I've installed the Matroska pack, so hopefully now all will work okay with high performance as power option on.
My System SpecsSystem Spec
08 Feb 2011   #6

Windows 7 32 Bit Ultimate
 
 

I'm actually having the same issue and still cant get it figured out. I only use vlc, Zune, And Windows media player for videos. In zune the movie just freezes for a bit and the sounds keeps up then it unfreezes, in vlc and windows it actually comes up boxish and pixlemalated. Ive tried to download new codecs but that didn't work, i tried re-installing windows on a new formated drive and that didn't help. I'm running out of ideas.

I have a dell 1735 studio laptop.
2.1 g dual possessor
3 gigs of ram.
My System SpecsSystem Spec
08 Feb 2011   #7

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

I don't know if this is part of your issue or not, but many sources recommend a 2.4ghz dual core or better for HD playback, and you are just under that threshold. Does this occur regardless of the video quality.?
My System SpecsSystem Spec
09 Feb 2011   #8

Windows 7 32 Bit Ultimate
 
 

To be honest idk if there HD quality to begin with, There mostly avi and some mpeg-4. I have tried converting to HD but nothing woks, ive tried to convert to compressed and it still dont work. Funny thing is that i didnt have a problem when i was running windows vista before on the same system.

I have a Intel Core 2 Duo CPU T5850 @ 2.16 Ghz
3 Gb or ram.
My System SpecsSystem Spec
09 Feb 2011   #9

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Quote   Quote: Originally Posted by DanksFoSho View Post
To be honest idk if there HD quality to begin with, There mostly avi and some mpeg-4. I have tried converting to HD but nothing woks, ive tried to convert to compressed and it still dont work. Funny thing is that i didnt have a problem when i was running windows vista before on the same system.

I have a Intel Core 2 Duo CPU T5850 @ 2.16 Ghz
3 Gb or ram.
I'm guessing you have a outdated system driver or something. The honest truth is win 7 is faster and more stable than vista. So if it worked with vista and doesn't with Windows 7 the only thing I can think of is you are dealing with some outdated drivers, video/audio/chipset.
My System SpecsSystem Spec
09 Feb 2011   #10

Windows 7 32 Bit Ultimate
 
 

I ran driver genius 10.0 and it updated everything and gave me the what i should have.
My System SpecsSystem Spec
Reply

 Video lag on ALL MEDIA PLAYERS, please help!





Thread Tools



Similar help and support threads for2: Video lag on ALL MEDIA PLAYERS, please help!
Thread Forum
Best Media Players Music, Pictures & Video
Suddenly no video but only audio on almost all video players Music, Pictures & Video
What are the best media players for weak video cards? Media Center
Media Players?? Music, Pictures & Video
No sound in media players Sound & Audio
Which Media Players Is The Best ? Music, Pictures & Video
Windows 7 and mtp usb media players.. Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33