Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP12: Album Art GONE!

13 Jun 2011   #1

Windows 7 Professional sp1 32bit
 
 
WMP12: Album Art GONE!

So, I've spent hours, nay, even days, trying to get the album art for my gigs of music that I've acquired over the last 10 years. I was pleased with my finalized collection, now complete with album art and metadata. Today, in WMP 12, i clicked the menu option under Tools -> Advanced -> Restore Media Library, and... POOF... just like that, all the album art is gone. If I show hidden and protected system files in windows explorer, I can see that the actual album art files are NOT gone, yet there is now no association between the mp3 file and the album art file.
So my questions are:
1) What the heck just happened?
2) How do I fix it without spending another few days getting the album art back on?

Oh, please, oh please, help me!

My System SpecsSystem Spec
.

13 Jun 2011   #2

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

If you come up with no better solutions.

You can do a System Restore.
Before they disappeared but well after you had things where you had things perfected.
Maybe yesterday or day before or the latest point available.
System Restore

If you do this put a check mark in the "Show more restore point" box. Gives you more selections if needed


On the other hand someone may have an easier way to directly fix things. So wait and see what other responses you may get.

Consider this if no other options avail themselves because if it happens again knowing how to fix the problem directly would be better.

Hopefully someone will have a more direct cure to your ailment.

I'll also post for more help might get you a solution sooner.
Mike
My System SpecsSystem Spec
13 Jun 2011   #3

Windows 7 Professional sp1 32bit
 
 

I went ahead with the system restore anyway. It didn't work .

Perhaps somebody can explain to me how WMP 12 handles album art. Some mp3 software puts the album art into the ID3 tag. I know wmp doesn't do that. I guess it puts jpg files in the same directory as the music files, but then where does the file association come from? Why does the file association disappear when the mp3s are moved to a different folder (EVEN if the album art files are moved along with it)? Why does the thumbnail of the music file change from a music note to the album cover on some mp3s but not others? Why do some mp3s have an INCORRECT album cover as the thumbnail? WMP 12 has really torqued me off this time.
My System SpecsSystem Spec
.


13 Jun 2011   #4

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

I posted for more help.
If no answers today check back tomorow.
Sometimes the person with the knowledge is living on the opposite side of the world and asleep now.

I thought the Restore would put things back in order. Sorry.

I don't use WMP so I am no help otherwise.

Good luck.
Mike
My System SpecsSystem Spec
13 Jun 2011   #5
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Hi Mervil, yes the album art should be in the same folder the media files are stored in. In WMP12, delete the music from the WMP library, playlists, etc., but NOT your system. Add the files back and see if that will fix things for you.
My System SpecsSystem Spec
14 Jun 2011   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

You could also try rebuilding the library using this tutorial

Windows Media Player - Rebuild Corrupted Libraries
My System SpecsSystem Spec
14 Jun 2011   #7

Windows 7 Home Premium x64
 
 

+1
Most problems in WMP can be fixed with that tutorial, it is, I fear say it, a common "maintenance" thing when using WMP xD
My System SpecsSystem Spec
14 Jun 2011   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

That's true. I have recently been rearranging my videos folder structure and I needed to use it for every change. It works flawlessly.
My System SpecsSystem Spec
14 Jun 2011   #9

Windows 7 Home Premium x64
 
 

You don't actually have to use it all the time.
If you're rearranging files and folders that are included in WMP's libraries, all you need to do is delete them in WMP, close it before it indexes these folders again. Do your stuff and when you finish, open WMP again and let it index the folders.

It does happen sometimes that WMP doubles entries, in which case, yeah, the tutorial steps again xD
My System SpecsSystem Spec
14 Jun 2011   #10

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

True but the WMP12 library seems to get its knickers in a twist very easily and it doesn't take long to rebuild the library.
My System SpecsSystem Spec
Reply

 WMP12: Album Art GONE!




Thread Tools



Similar help and support threads for2: WMP12: Album Art GONE!
Thread Forum
WMP12 backup album art Music, Pictures & Video
Help, I am going INSANE! WMP12 Album Art. Media Center
changing album art in wmp12 Music, Pictures & Video
ALBUM ART on WMP12 Media Center
WMP12 Album Art driving me insane Media Center
Unknown Album/Corruption in WMP12 Media Center
No album art WMP12 Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:04 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33