Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Clean Install of Win7 - Codec Installation Advice Needed

17 Jun 2011   #1

Windows 7
 
 
Clean Install of Win7 - Codec Installation Advice Needed

Good morning,

I’m doing a fresh install of Windows 7 Home Premium 64-bit tonight and I am looking for some advice on codecs to install to get optimum playback in Windows Media Player 12. Should I install a codec pack? should I install just the codecs I need? and what order should I install any codecs to avoid conflicts?

The main thing im trying to achieve is .mkv & .flv library & thumbnail support for WMP12. In the past I have used the k-lite codec pack & the divx .mkv codec from the divx site but I tend to get mixed results i.e sometimes thumbnails will be black etc

I had an issue on my previous installation of windows 7 where thumbnails would show for .flv and .mkv and appear in my library but sometimes the thumbnails would change before my eyes to the wrong ones. I have had it working fine on Windows 7 32-bit but I think that was more down to trial and error.

I would just like a clean, tried and tested way to get the above to work, help or tips from people who have would be appreciated.

Thankyou.


My System SpecsSystem Spec
.

17 Jun 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Go with Shark's codec pack.

Shark007.net - Windows 7 Codecs - WMP12 Codecs

Shark007.net - Windows 7 x64 Codecs - WMP12 Codecs

Shark007 is a member here so you can just ask him if there are issues. There are also forum links on the above 2 links where thumbnails problems have been discussed.
My System SpecsSystem Spec
17 Jun 2011   #3

Windows 7
 
 

Quote   Quote: Originally Posted by Bill2 View Post
Go with Shark's codec pack.

Shark007.net - Windows 7 Codecs - WMP12 Codecs

Shark007.net - Windows 7 x64 Codecs - WMP12 Codecs

Shark007 is a member here so you can just ask him if there are issues. There are also forum links on the above 2 links where thumbnails problems have been discussed.
Thanks for the quick response.

I have used the Shark007 codec pack when trying to resolve my problem in the past, however i have only ever used it after an install and uninstall of the k-lite codec pack so that may have caused problems.

I will check out the above links and install both codec packs tonight as the first thing i do on the new installation, after drivers, updates & anti-virus of course
My System SpecsSystem Spec
.


19 Jun 2011   #4

Windows 7
 
 

Ok i am still having problems with thumbnails, i have posted my problem on the Shark007 forum but to no reply and if anybody can help me on here i would appriecate it, below is what i have tried...


Ok Shark, wondering if you could help me, im tearing my hair out..

I know you have answered the question on .flv and .mkv thumbnails so many times so forgive me but i have looked in every thread on this forum to try and solve my problem, most of the time your response is to 'Use FFDshow's codec in the H264 TAB' which seems to have worked for everyone but me...here is what i have done

- Formatted HDD
- Installed fresh Windows 7 64-bit Home Premium
- Installed ATI Catalyst drivers
- Installed all windows updates

- Installed X86 codec pack
- Installed X64 codec pack
- Rebooted

Opened music video folder in explorer and watched thumbnails generate (every thumbnail generates apart from all .flv files and only a couple of .mkv files)

I've tried many different combinations of settings
- Going in the H264 tab and enabled FFDShow with multithreading (didn't work)
- Enabling 'Use FFDShow codec' under H264 codec in directshow players (generated black thumbnail)
- Going into the 'Swap' tab and enabling FFDShow for MPEG2 (didn't work)
-Tried enabling the suggested settings
-Tried resetting all settings

When amending the settings above i go into the x64 application as administrator - make the change - exit, then go back in as normal user.

The problem is not playback, every file plays fine but to me the thumbnails are important, it seems like every person who has followed your guidlines to make them work has been successful but me, even on a fresh windows install, what am i doing wrong and can you help me?

Many thanks
My System SpecsSystem Spec
19 Jun 2011   #5

Windows 7 Ultimate 64bit
 
 

Try installing this DIRECTX update from Microsoft.
My System SpecsSystem Spec
20 Jun 2011   #6

Windows 7
 
 

Quote   Quote: Originally Posted by Shark007 View Post
Try installing this DIRECTX update from Microsoft.
Hi Shark,

Thanks for the reply, I did think about whether installing DirectX would make a difference and I did install it at one point just as a routine update but this was after I had been messing with codecs and trying to get things to work so I didnít install it before installing your codec packs.

However, I have since restored a system image from about 3 days ago back to when thumbnails generally worked for all file types, however the reason I decided to start a fresh in the first place was because..

- Video thumbnails where changing at random times to the wrong thumbnail (i.e from a different video) then would change back, it only did this in WMP12 and not in explorer.

I even noticed it on a few occasions on a fresh OS install both with the shark codec and k-lite codec pack.

So if you have any thoughts on why that may be happeneing I would appreciate it but I shall run the DirectX update just to make sure.
My System SpecsSystem Spec
20 Jun 2011   #7

Windows 7 Ultimate 64bit
 
 

It is quite obvious to me that your issue is NOT codec related.
Hopefully the DirectX update solves it for you.
My System SpecsSystem Spec
20 Jun 2011   #8

Win7 x64 X2, Win 8.0 x64, Win8.1 x64, Quad Boot
 
 

This sharks codec pack is a system hijacker. 2 toobars and windows live sign in assistant. No opt out.
Only opt out option is for weather bug.
My System SpecsSystem Spec
30 Jun 2011   #9

Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Dixon Butz View Post
This sharks codec pack is a system hijacker. 2 toobars and windows live sign in assistant. No opt out.
Only opt out option is for weather bug.

I have nothing against offering toolbars to help defray costs on free stuff. Even Sun does it with Java.

But not allowing opt out is unforgivable, in my opinion, and I'll never run any windows live stuff (Windows Mail can be made to work on 7 without too much hassle if you don't like Thunderbird, et al).
My System SpecsSystem Spec
Reply

 Clean Install of Win7 - Codec Installation Advice Needed





Thread Tools



Similar help and support threads for2: Clean Install of Win7 - Codec Installation Advice Needed
Thread Forum
Going for a new Windows 8 installation, advice needed on hard drive Installation & Setup
Solved Doing Clean Install and need advice General Discussion
Any advice on Windows 7 clean install? Installation & Setup
Solved Advice on new SSD setup with clean install Installation & Setup
Codec Problem w/ Clean install Installation & Setup
Clean Install Driver Advice Installation & Setup
Win7 clean install - is Chipset driver package needed? Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33