Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dolby AC3 Audio (code 8192)?!


17 Jul 2011   #1
EvilOzzmess

7 Ultimate x64 SP1
 
 
Dolby AC3 Audio (code 8192)?!

Well, this most strange thing started happening to my movie files recently (an apparently selective problem). When these affected video files are opened in DivX Player, I see an alert informing me that:

"You may need an additional audio decoder to play the soundtrack of this file.

This file contains a track in the Dolby AC3 Audio (code "8192") format. You may need to install a DirectShow decoder for this audio format in order to hear the soundtrack of this file."

And, of course, there's ZILCH for sound - whether that's with DivX, Media Player etc. etc. etc. What is perplexing me about this the most is the fact that these files USED TO play flawlessly and WITH sound not so long ago (absolutely NOTHING has been changed on this system since when they last worked, either). So what's happening here and how can I fix it (preferably without having to spend a truckload of money - free being most preferable).

Thanks.

EDIT: Apparently this has something to do with DivX Plus... which I have, which SHOULD be solving this, I suppose, but which ISN'T... so now I have NO idea what I need to do now? Never had a problem like this before. >_<


My System SpecsSystem Spec
17 Jul 2011   #2
Gornot

Windows 7 Home Premium x64
 
 

Is it possible that the DivX suite updated automatically and "silently", i.e. without prompting you first?
I haven't used that suite in quite a while, so I don't really remember...
My System SpecsSystem Spec
20 Jul 2011   #3
EvilOzzmess

7 Ultimate x64 SP1
 
 

I have it set to 'automatically check for updates', but they never install themselves (at least not that I am aware of ever happening before). It usually has to wait for me to give the all clear before it does anything like that. Consequently, I have tried to do just that, thinking that perhaps it's out of date and that's the problem... but the status bar just keeps going endlessly, never completing the search for that update. Must be their servers? I'll try again... worst to worse, I'll reinstall (maybe even a previous version if I can find one). Just highly annoying... can't understand WHY some work and some don't. They must have different codecs?

Oh, but then I have also come across a few hits on Google about this saying it could ALSO be that there are some corrupt files, whether in the .AVI themselves or else with the media player's program files themselves, resulting in this. But then, I have both of all of these affected files on separate External HDD's and they're BOTH acting this way so... I find it unlikely to be those file's faults.


Thank you once again for your help!


EDIT: Well, the update seems to be working again... however, it states that there is no new version so there's my theory of that being the problem out of the window.

EDIT 2: Tried playing one of the affected .AVI's and the problem still persists.

Does anyone perhaps know if this is an intended change with DivX Pro (NOT the 'trial' version)? I notice they have a "codec pack" on their site now... are they removing these codecs from Pro, so we have to buy them too (again)? I can't find much of anything about this "AC3 decoder 8192" on their website or elsewhere. Just a bunch of incoherent snippets about "oh just download this [shoddy looking file]".
My System SpecsSystem Spec
20 Jul 2011   #4
EvilOzzmess

7 Ultimate x64 SP1
 
 

Apologies for the successive post in a row, however...

I came across this while perusing the DivX support site. So I am going to give it a try... see if it's "audio codecs missing" option will restore function of these affected AVI files... and pray that nothing blows up, because I am QUITE sick and tired of having to resort to "Factory Restore" for these kinds of tedious hiccups in shoddy programing. Just saying... *Sigh*

EDIT again: this had no affect whatsoever.




EDIT yet again: I think I am closing in on the culprit... apparently this is ALL to do with something called "DirectShow SDK" and... it is something that is IN the OS itself (a sort of multimedia platform, that Windows uses) and not with DivX at-all (or so I have just finished reading). Does anyone know what I have to do to locate and uninstall and then resinstall whatever this thing is (if that is even possible without having to - ONCE AGAIN - wipe my system)? I surely can't be the ONLY one with this problem ever... this issue dates back ALL the way into 2006 all over the internet (but with no solutions, of course), across various OS platforms of Windows. Somebody please advise the best next move here, I'm out of ideas with this one... and I WON'T be reinstalling the blarmy OS... won't... tired of that!

Also, now that I know it's something to do with the OS itself, or so I am being led to that conclusion by what I've been reading up, this HAS to have been brought on by a shoddy Windows Update because that is the ONLY thing I have been doing on this system for the last two months. Ugh.

Sorry for my bad temper... I now it's out of line but... this is just INFURIATING, I am sure you can sympathize!
My System SpecsSystem Spec
20 Jul 2011   #5
EvilOzzmess

7 Ultimate x64 SP1
 
 

Once again, apologies for the triple post...

Well, this sums it up rather well: DivX FAQ - DivX Movies

Going to try installing these other codecs, that apparently no longer work in the 'new' DivX (no idea how this is possible, but worth a try)... will report back....
My System SpecsSystem Spec
20 Jul 2011   #6
Gornot

Windows 7 Home Premium x64
 
 

Now I feel embarrassed that nobody else posted here xD
But from what I've seen here on the SF, most people don't use the DivX suite at all, but freeware/open source alternatives instead.
In any case, glad to see you're working your own way out of the problem. It's much more healthy than to scream out "i can has halp!" and wait.
My System SpecsSystem Spec
20 Jul 2011   #7
EvilOzzmess

7 Ultimate x64 SP1
 
 

Nah, helps to have someone to bounce ideas off of - thank you, rep heading your way soon.


Aaaaaaaannnnnnnnd... I have worked it out. Anyone else having this most grievous problem needs to click on the "AC3 Codec tag 2000 tag 8192 AC3 Codec" hyperlink mentioned in "DivX Faq 4.4" in the hyperlink above in my previous post... after you install it (yes, it is safe - nothing detected) your AC3-encoded audio in your .AVI and I expect, other video container file types, will miraculously work again!

Might I say now though... SHAME ON DIVX! They'd better offer an OFFICIAL solution to this (paying customers should NEVER have to resort to third-party codecs, which USED TO be included in the "Pro" package)! This said, please disregard my previous rantings... it obviously IS DivX to blame, as that 4.4 faq clearly has proven. Thanks again and I sincerely hope that anyone else coming across this HIGHLY annoying problem with endless run-around all over BUT on DivX's website, in this supposed 'new' DivX codec (which I have absolutely no recollection of installing, so must have been forced) has been helped with this!

Problem officially solved... here's to hoping no more codec curves are thrown by DivX!
My System SpecsSystem Spec
20 Jul 2011   #8
Gornot

Windows 7 Home Premium x64
 
 

Glad you worked it out, there's some really useful info in this thread
My System SpecsSystem Spec
30 Jul 2011   #9
anra

windows 7
 
 
thank you evil ozzmess!

i had exactly the same problem and after installing useless fixes your post saved me! happy viewing!
anra
My System SpecsSystem Spec
03 Nov 2011   #10
Tactics

64 bit
 
 

Wow glad I found this thread! been searching for 2 hours!

Thanks again!
My System SpecsSystem Spec
Reply

 Dolby AC3 Audio (code 8192)?!




Thread Tools



Similar help and support threads for2: Dolby AC3 Audio (code 8192)?!
Thread Forum
Solved Dolby Audio Driver Error Msg Drivers
Realtek HD Audio Manager and Dolby Home Theater V4 Sound & Audio
Realtek AC'97 Audio (Code 10) Sound & Audio
win7 = no dolby digital audio - Roxio = yes! Sound & Audio
Realtek AC'97 Audio (Code 39) Sound & Audio
Dolby Control Center 'No audio endpoints found' Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:32 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App