Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Most video thumbnails do not load

04 Sep 2011   #1
Webberjo

Windows 7 Ultimate x64
 
 
Most video thumbnails do not load

I've been having a problem getting my video thumbnails to show ever since I installed Windows Media Player 12. I already have VLC Media Player installed and they were showing up fine before. Now it's only showing video thumbnails for .avi and .wmv files (that I've noticed), but not for .mp4. I've done a lot of searching and tried many things to get it back the way it used to be.
  • "Always show icons, never thumbnails" is unchecked and folders have been reset.
  • I've deleted my IconCache and rebooted.
  • VLC has all of its default file extension privileges, including .mp4.
  • I tried uninstalling VLC, restoring all of WMP's file type associations and rebooting.
  • Disabled WMP in "Turn Windows features on or off" and rebooted.
  • Downgraded WMP from 12 to 11.
  • Added "DisableThumbnailCache" to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced with value set to 0 and rebooted.
  • Running "regsvr32 shmedia.dll"/"regsvr32 /u shmedia.dll" gives an error saying the module failed to load. I checked and it wasn't even in my system32 folder, so I tried downloading shmedia.dll, putting in my system32 folder and trying again. This time I got an error saying the module may not be compatible with the version of Windows I'm running.
None of these helped bring my video thumbnails back. If anyone's got any more suggestions, I'm all ears.


My System SpecsSystem Spec
.
04 Sep 2011   #2
Hellriser

Windows 7 Ultimate x64 SP1
 
 

Welcome to Seven forums!

I don't know what codecs you are using, but I strongly suggest you use these:
Shark007 Windows 7 Codecs.
It should also fix your thumbnailing problems. More info about the codecs is on the site.
My System SpecsSystem Spec
04 Sep 2011   #3
Webberjo

Windows 7 Ultimate x64
 
 

The thumbnails were showing up just fine before I installed WMP12 though. Doesn't VLC already come with all the codecs required to play videos?
My System SpecsSystem Spec
.

04 Sep 2011   #4
Hellriser

Windows 7 Ultimate x64 SP1
 
 

VLC does support all kind of formats and plays almost everything, but the codec pack I offered you is custom tailored for Windows 7 and WMP (and all the other video players out there), frequently updated and maintained and its developer offers great support here and on his forums. Give it a try, see if it fixes your problem (which it will).
My System SpecsSystem Spec
04 Sep 2011   #5
Webberjo

Windows 7 Ultimate x64
 
 

I may just be being fussy, but I don't like WMP very much at all. I prefer something much simpler like VLC. Do you think my problem would be fixed if got a 64-bit shmedia.dll, or am I going to have to reinstall my OS?
My System SpecsSystem Spec
04 Sep 2011   #6
Hellriser

Windows 7 Ultimate x64 SP1
 
 

It doesn't matter what player you use, the codecs work with any player. I don't think that getting a new shmedia.dll will fix your problem, but I'm no expert in the field.

I also found this fix on the VLC forums. It doesn't have any confirmation it's working except from the poster. Try it out. But in the end, I still strongly recommend the codecs I posted. The pack will save you from any headache with playing video files.


Attached Files
File Type: reg Windows 7 x64 thumbnail fix.reg (1.4 KB, 2116 views)
My System SpecsSystem Spec
04 Sep 2011   #7
Webberjo

Windows 7 Ultimate x64
 
 

Wow, you are just amazing, that actually worked! You indeed are skilled my friend! Thank you so much for saving me $8 in Advil for the next couple days. =D
My System SpecsSystem Spec
04 Sep 2011   #8
Hellriser

Windows 7 Ultimate x64 SP1
 
 

I'm glad I could fix your problem. But which was it? The codecs or the .reg file?
My System SpecsSystem Spec
04 Sep 2011   #9
Webberjo

Windows 7 Ultimate x64
 
 

The .reg file. =)
My System SpecsSystem Spec
09 Jun 2013   #10
sonsuperman

Windows 7 Ultimate x64
 
 

Thank so muck! I've been looking for a solution for this problem for a longtime. You make my day
My System SpecsSystem Spec
Reply

 Most video thumbnails do not load




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Video Thumbnails
Hello Forum, My system is currently not showing video files as thumbnail images in any folder(s), just the default AVI, WMV, MPEG icons. Picture files such as JPEG, GIF, display the thumbnail image of the given picture just fine. Has anyone expierienced this quirk, does anyone know how to...
Music, Pictures & Video
Windows Explorer: Some image thumbnails do not load.
I have Win 7 64-bit machine and all of a sudden some image file thumbnails show, and some do not. I have logged in as a different user on the machine and problem still occurs. Other machines on my network do not have this problem. I have tried the following below, but still no fix. Any suggestions...
General Discussion
Disbale video thumbnails but keep images thumbnails
Hello guys Im new here. windows 7 64 bit 1.There is an option in folder options : ALWAYS SHOW ICONS, NEVER THUMBNAILS. Is it possible to set this option only to a specific folder not all folders? 2.If the answer to question above is no, so how can i disable thumbnails for a specific file...
Music, Pictures & Video
Most video thumbnails do not load
I had to try this because most of my video files would not load thumbnails. Windows 7 Forum http://www.sevenforums.com/music-pictures-video/184838-most-video-thumbnails-do-not-load.html Shark007 Win7Codecs Shark007.net - Windows 7 Codecs - WMP12 Codecs Shark 007 Setup and usage
Music, Pictures & Video
thumbnails take too long to load
hi everyone, I have this issue with thumbnails of photos taking a very long time to load when I open a folder in windows explorer. I mean a really long time, like 5+ minutes, for a folder that contains say 200 pictures. And this happens all the time, regardless of what else may be running, and...
General Discussion
Video Thumbnails cut off
I've been having this problem since I upgraded from Vista to 7: The video border for the thumbnails is showing up strangely, as you can see in the picture. I can still tell what the files are but it's starting to get annoying. I looked all over google and found no answers. can anyone help? ...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App