Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP12 will only play demo video, audio is fine

05 Mar 2012   #1
meat7433

Windows 7 Ultimate x86
 
 
WMP12 will only play demo video, audio is fine

I recently installed Win7 Ultimate x86 on my Dad's HP Compaq Presario. PC has a 2.2 Gig AMD processor (processor is a 64bit but had glitches when I tried the Win7 64bit OS) w/2GB DDR2 Mem. All drivers are the originals from when the PC had Win XP Home on it, except for what ever Win7 swapped out on install. WMP12 will only play the supplied demo video and that appears as a duo image in a split screen with playback in black and white. Plays ALL audio fine, even CD's. Will Not play any Video DVD's. Installed Power DVD 11 and same problem. Win7 say's something about not enough memory installed and close running programs to free up memory. All programs are closed except WMP12. Have increased page file size to 1024low/8192high and every thing seems to work fine except WMP12 & PowerDVD video. Monitor res is something like 1080x840. Plays YouTube vid and flash just fine on internet w/Adobe Flash11 installed. So, anyone have a clue as to what might be going on? Thank you in advance. This has me stumped, even tried the WMP Fix utility listed in this site. Oh yeah, HP has NO Updated drivers listed for this PC.


My System SpecsSystem Spec
.
08 Mar 2012   #2
Gornot

Windows 7 Home Premium x64
 
 

This definitely sounds to me like an issue with the graphics card not having proper drivers. Make sure you set up Windows Update, it should offer the drivers for your GPU. They might be just generic drivers, but at least it should give you proper video playback. If HP doesn't offer drivers specifically for Windows 7, perhaps Vista drivers could do the trick, too.
My System SpecsSystem Spec
08 Mar 2012   #3
meat7433

Windows 7 Ultimate x86
 
 

Hi Gornot, I did the win7 update. No sucess. Looked at HP for vista drivers or win7 drivers, only updates for lightscribe. I too believe it is a driver issue. Went to device manager and had it look for updates for monitor and display, no look said I had the latest. Here's some more info that might help: the chipset is Sis AGP. Northbridge Sis 760/ Southbridge Sis 964. The mobo is an Asus K8S-LA made expressly for HP. Hope this info helps lead to a resolution.
My System SpecsSystem Spec
.

08 Mar 2012   #4
Gornot

Windows 7 Home Premium x64
 
 

Perhaps knowing exactly which graphics card you have might help. According to that, maybe you can find the drivers from the GPU manufacturer's website instead of looking up at HP.
My System SpecsSystem Spec
08 Mar 2012   #5
meat7433

Windows 7 Ultimate x86
 
 

A formal graphics card is part of the issue, that is why I gave the mobo info. This PC has no graphics card. Graphics are built into the mobo chipset.
My System SpecsSystem Spec
08 Mar 2012   #6
Gornot

Windows 7 Home Premium x64
 
 

Ah, so that's what it is. Alright then, lemme Bing that (yes, I bing and banged whenever I need to xD)

EDIT - I am not having luck in finding any Win7 specific drivers, not even for Vista. Did you have Win7 installed previously or is this your first attempt at it? I've read some comment saying that the PC is old; not having proper Win7 drivers would probably mean you'd have to stick to XP.
My System SpecsSystem Spec
08 Mar 2012   #7
meat7433

Windows 7 Ultimate x86
 
 

OK. My apologies for not being a little more specific. I have researched the heck out of this and no, I am not a noob or uninformed when it comes to PC's. It is a 2005 PC that originally had XP home on it. Did not upgrade to vista first cause we all KNOW WHAT THAT HORROR IS AND WAS (even MS abandoned it)LOL. So I decided he needed an upgrade to Win & Ultimate. Same version I have on My 2005 HP compaq Laptop. His is an HP desktop same year(has a 64 bit processor). Win 7 installed and worked fine on my PC so I installed it on his. First I had a copy of Win7 Ultimate x64 on it. The PC didn't take kindly to 64 o iI put X86(32 bit) on it. Everything work fine,in Media player except for Video(wether its dvd movie, sample video, format, etc..). Put K-lite codec pack in and that didn't help. I understand with win7 I really didn't need to but ya never know. I can tell you this, the sample video will play but is in black and white instead of color and appears as a plit screen with the same video in both windows. Funky huh. Well I'd hate to revert him back to XP when all is good except video. Any how He's 79 and say' he doesn't really need the vid, I would jut like to solve this for him. By the way, online the adobe flash works just fine.
My System SpecsSystem Spec
08 Mar 2012   #8
meat7433

Windows 7 Ultimate x86
 
 

Note. I have been online at SIS website(chip manufacturer) Asus makes the mobo and I have been to there site too. No help from either.
My System SpecsSystem Spec
08 Mar 2012   #9
Gornot

Windows 7 Home Premium x64
 
 

Vista wasn't all that bad, its reputation was earned by hyped hate rather than actual problems. I'm not saying it didn't have any, it did... A lot. But it didn't make it an entirely useless OS.

Anyway, the thing is, being such an old desktop, I'm not truly surprised there are no Win7 specific drivers for it. You said you installed the K-Lite pack, and used PowerDVD. One last thing I can think of instead of chasing drivers that don't exist is to download and try VLC to play video. VLC is different from both WMP and PowerDVD because VLC uses its own set of codecs internally, despite the codecs you may or may not have installed on your system. So try it out and post back if that works.

If not, maybe I could get someone else to pick up this thread to help you out, or you could just revert back to the "good old" XP.
My System SpecsSystem Spec
09 Mar 2012   #10
meat7433

Windows 7 Ultimate x86
 
 

I will Give That a try sometime on Fri. the 16th, probably in the P.M. Thank you again.
My System SpecsSystem Spec
Reply

 WMP12 will only play demo video, audio is fine




Thread Tools





Similar help and support threads
Thread Forum
Windows Media Player Video Freezes Audio Fine
I have a problem with playing a high definition video that I rendered using Sony Vegas 12. This problem only recently arose. I can play videos that I have rendered from After Effects CS6 perfectly fine. Here are the two video details: -- After Effects Rendered -- Length: 04:56 Frame Size:...
Music, Pictures & Video
Are there any way to play Audio, Video while Downloading?
Hello!:D Are there any way to play Audio and Video while they are Downloading? I can play Audio and Video in my NOKIA 5130 Xpress Music phone. So are there any special software for PC to do that process? :p:p
Music, Pictures & Video
WMP12 BSOD on Video Play Back
Greetings all... I recently installed Windows 7 Ultimate on a new system that I put together. I've had no problems with it, other then my old DVD playback software was no longer compatible. No problem, as I was able to play and watch my DVD's on the included version of Windows Media...
Media Center
Audio Plays Fine, No Video
Hey, I just bought this TV tuner (I know, went for the cheap one... I should've expected as much) and here's my problem. I had cable hooked via a TV that worked fine, but the TV was cluttering my desk space, hence the need for a TV tuner. I installed the TV tuner, got the latest software...
Media Center
WMP12 Wont play video files!
Installed AC3Filter, all the codecs.. WMP player plays my AVIS fine before, now i updated my video card and all AVIS will not work! When i switch my sound to "Speakers" - it will not load the avi... but when i use Digital Audio High definition bus the avi VIDEO works fine, but there is no audio.....
Music, Pictures & Video
WMP12 box at video play huge!
Okay so when I first started using WMP12 to play vids a little box would appear as it cached the vid for playback later. This was fine. But I let a friend use the computer and somehow he resized this little box before the video launched and now it it huge! This bothers me to no end causeing many...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App