Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP won't play AVI files correctly


29 Apr 2012   #1

Windows 7 Ultimate x64
 
 
WMP won't play AVI files correctly

WMP used to work perfectly with AVI files. I could watch movies, cartoons, whatever with no problems. Then a couple days ago, it happened. I double clicked on an AVI and WMP started up but horrible screeching sounds came from the speakers and when the video was visible it was playing very slowly.

I tried reloading the DIVX and XVid codecs. Then I tried removing WMP, rebooting and then reloading WMP but that didn't help.

DIVX player works fine.

Any thoughts?

Any changes to my system? I re-installed DVD Styler and Sothing Movie DVD Maker. I had them installed before with no issues but have reinstalled Win 7 so had to reinstall those programs when I wanted to create DVD.

My System SpecsSystem Spec
.

30 Apr 2012   #2

Win7 H.Prem. 32bit+SP1
 
 

My System SpecsSystem Spec
30 Apr 2012   #3

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

remove the divx codecs and install sharksoo7 codec pack, shark is a member here and gives good support here.
i have been using these codecs for a number of years with no problems
if you do use them then run the codec pack as admin and then select the sharks reccomended settings checkbox

Shark007.net - Windows 7 Codecs - WMP12 Codecs
My System SpecsSystem Spec
.


02 May 2012   #4

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by boohbah View Post
remove the divx codecs and install sharksoo7 codec pack, shark is a member here and gives good support here.
i have been using these codecs for a number of years with no problems
if you do use them then run the codec pack as admin and then select the sharks reccomended settings checkbox
Did as you suggested and everything is now working fine.

Thanks.
My System SpecsSystem Spec
02 May 2012   #5

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

good news .
My System SpecsSystem Spec
Reply

 WMP won't play AVI files correctly




Thread Tools



Similar help and support threads for2: WMP won't play AVI files correctly
Thread Forum
IE 10 doesn't download files correctly Browsers & Mail
AVI files will not play in WMP Music, Pictures & Video
Solved How can I play .mkv files in WMP 12? Music, Pictures & Video
Solved 3D SBS Movie - Stereoscopic Player - unable to play correctly General Discussion
Solved IE9 won't play FLV files Browsers & Mail
can't play .mov files from WMC Media Center
how to play *.ram files on WMP 12 ??? Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:44 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33