Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Pc wont let me watch Itunes movie properly

24 Sep 2012   #1
batrico

Windows 7 Home Premium 64bit Service Pack 1
 
 
Pc wont let me watch Itunes movie properly

On further exploration if i play a movie my cpu on itunes in task manager keeps going up to 98 percent.


Im not sure if im posting this in the right place but hopefully someone can help or reply so i can explain my situation.


At this moment ive restarted my pc about 10mins ago and my cpu is under 29percent yet when i try to watch a movie in itunes its stuttering and stalling.The red light on my cpu is working hard but i have no programmes open except firefox.ive closed itunes.ive task manager on to see what processes are on.phys mem is at 35percent so i should be able to run itunes fine.i watched a movie yesterday and the second half ran fine once my pc settled down whatever it was doing.
under processes for other users itssys host is 90000k was higher earlier.this sys host includes superfetch,windows driver foundation and a few others al at Pid 424.


My System SpecsSystem Spec
.
24 Sep 2012   #2
Wrend

Windows 7 Professional SP1 64bit, Debian GNU/Linux 64bit (virtual machine on a RAM drive)
 
 

Please fill out your system specs information so we know what you're working with. Also, what background programs are running? Are you streaming the movie? Maybe your computer was busy defragging, doing a virus scan, or something. There's no way of knowing for sure from the provided information.
My System SpecsSystem Spec
25 Sep 2012   #3
batrico

Windows 7 Home Premium 64bit Service Pack 1
 
 

Hi ive changed the focus of my problem. i have a theory that itunes is part of the problem.

I was trying to watch a movie that I had rented from the itunes store.It was downloaded to my pc and i was using itunes to watch it.I didnt have any programmes on apart from normal Avast Av , Comodo Firewall doing there work in the backround.No virus scan was on at the time.

I have 4gb of Ram.Intel Celeron 2.ooghz processor.windows 7 64bit home premium.my internet speed is 20mb.

For example i am downloading a couple of things at the moment but my cpu usage is at less than 50percent with a couple of spikes and no lag. When checking task manager I noticed while playing itunes was using over 90 percent of my cpu which it had not done before as i have only had this problem recently.I read up on this as well and tried a winsock reset as suggested but it still remained the same.


A post on Apple support suggested for me to use autoruns to see if there was a LP conflict.Autoruns said i was missing a file called rdclip.exe.

Ive looked into this further and found out its for remote desktp use which is disabled by win7 on installation.Do i need to enable it or does it affect the small home network i have at all.If it doesnt then can i just untick the box in autoruns and move on.



I know ive written alot of stuff its just i want to give all info.
My System SpecsSystem Spec
.

25 Sep 2012   #4
Wrend

Windows 7 Professional SP1 64bit, Debian GNU/Linux 64bit (virtual machine on a RAM drive)
 
 

Sorry, don't know much about iTunes and rdclip.exe.

That processor is a bit dated and slow, though still above minimum requirements. I'd probably go into the advanced system settings and optimize Windows for performance (if you haven't already done so). That should help with overall snappiness a bit, but probably not solve your issue with iTunes. I'll let someone more knowledgeable help you out with that.

Good luck.
My System SpecsSystem Spec
26 Sep 2012   #5
batrico

Windows 7 Home Premium 64bit Service Pack 1
 
 

Found a temporary fix on site:

https://discussions.apple.com/message/19641702#19641702


The music is now playing even when browser is open.Havent tried it with video until im ready to watch one of my rentals.

didnt work with video.itunes still talking up 90percent cpu.
My System SpecsSystem Spec
10 Oct 2012   #6
batrico

Windows 7 Home Premium 64bit Service Pack 1
 
 

Today i actually watched a film in itunes.Reason I downgraded itunes to version 10.63 and it worked fine.So until apple fix the mess they made with version10.7 i am staying with 10.63.
My System SpecsSystem Spec
Reply

 Pc wont let me watch Itunes movie properly




Thread Tools




Similar help and support threads
Thread Forum
Entire Movie Wont Play and more....
Hello all, I'm trying to play a dvd that I ripped and when I play it through Windows Media Center 7 I'm having the following issues. When I play these short episodes there is a part of the episode that is entirely skipped for some unknown reason and will not play in it's entirety when using Media...
Media Center
Problems while trying to watch a movie
I have a Windows 7 HP Laptop BTW Ok every time I go and put a DVD in my computer it makes a weird noise and it doesnt work. Also when I opened the dvd drive there was a black and yellow paper that was crumbled, i think its the optical drive? what should i do
Music, Pictures & Video
iTunes 10+ installed but suddenly wont run
I did some registry cleaning recently using CCleaner and Advance System Cleaner. I also did a system restore where I had to uninstall Zone Alarm bcuz System Restore wouldn't restore one of my points. Now, when i select the iTunes icon, my mouse icon/cursor flickers for a moment but that's it. ...
Software
iTunes 9 just wont install
Hi all, First post and I have been searching through this awesome forum for an answer but have found no solutions. Im a new Win 7 user so hopefully its just a case of missing something simple. My main issue is I just cant get windows to install itunes! I have been trying all of the...
Software
Win 7 pro 64 can't watch movie using media center.
I can't play home video or ripped movies using windows 7 Pro 64 media center. When I click play, nothing happens. But when I move the mouse, I see the video time bar running and then stop. I installed NVIDIA PURE DECODER to see if that is that I need it, but no luck. Still doing the same thing. I...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App