Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MP3 album art not showing


23 Oct 2012   #1

Windows 7 Home Basic x64
 
 
MP3 album art not showing

I can't see any thumbnails in MP3 files (the folder art is visibile,though) anymore, only the file icons.The MP3 songs are already tagged, because when I open them with an editor like MP3 tag editor or a media player such as Winamp or Windows Media Player 12, the album art for all the MP3 songs is visible,but it's not in Windows Explorer.

I have already cleaned and reset the thumbnail cache in "Disk Cleanup" option according to a tutorial available in the forums, but the cache images and files are still there.I even deleted them manually and put a JPG image named "folder" in the album folder, but no success.Is there any way to re-enable thumbnail visualization for MP3 files?Thanks

P.S.: The "Show icons, never thumbnails" option in Folder Options is already unchecked.



Info:

OS: Windows 7 x64 Home Premium
MP3 tags: ID3 v1 and v2.3

My System SpecsSystem Spec
.

23 Oct 2012   #2
Arc

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64 Bit SP 1
 
 

Hello ksioamaral89,

First make it sure that the thumbnail preview is enabled.
Thumbnail Previews - Enable or Disable

Then, associate mp3 files with windows media player.
Default File Type Associations - Restore
Just download the registry file for mp3 and merge it.

Does it work?
My System SpecsSystem Spec
24 Oct 2012   #3

Windows 7 Home Basic x64
 
 

Hey Ark, thanks for the help, I managed to solve the issue.I checked the tags and all the MP3 files had ID3 v1, v2.4 UTF-8 and APE v2.So I changed the ID3 v2.4 to v2.3 UTF-16 and deleted the APE tag.After that I chose a JPG image to be the MP3 files thumbnails and wrote the tags, and now my MP3 files are displaying the art thumbnail correctly.I even put a JPG image named "folder", and the folder thumbnail is also being shown.I deleted the cache files too(JPG images and .db files).

I even found out a solution for a similar issue.Sometimes the album folder thumbnail (not the MP3 files) isn't updated, even if you manually added a thumbnail image to the MP3 files.So, I associated the MP3 files with WMP 12, and after some seconds, WMP 12 managed to recreate the cache files (small, large images) and even the "folder" one, so now the folder thumbnail is being correctly displayed and updated.I'll mark it as solved, and will tell the solution to other users.Thanks!
My System SpecsSystem Spec
.


16 Mar 2013   #4

Windows 7 Ultimate
 
 

Thanks , i have same problem like this for a couple month and after i read it , now my mp3 files embedded with artwork can show again in windows explorer , thanks a lot , it works !! just download mp3 default reg & restart

sorry for my bad english
My System SpecsSystem Spec
10 Aug 2013   #5

Windows 7 Ultimate 32bit
 
 

I have just solved my very old problem related to mp3 album art with the help of mp3 .reg. Thank u very much for such a post.
My System SpecsSystem Spec
11 Jun 2014   #6

64 bit
 
 

i have the same problem and it's been 2 days that i was trying to solve it, i couldn't even if i used the MP3tags it wouldn't appear, i see that you've found the solution but i really couldn't understand it, mind to help and explain?
My System SpecsSystem Spec
11 Jun 2014   #7

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Quote   Quote: Originally Posted by SeoSone029 View Post
i have the same problem and it's been 2 days that i was trying to solve it, i couldn't even if i used the MP3tags it wouldn't appear, i see that you've found the solution but i really couldn't understand it, mind to help and explain?
First check that the settings are enabled as described in Option One and Option Two of this tutorial: Thumbnail Previews - Enable or Disable

If that doesn't solve the issue, try restoring the defaults values for .mp3 files

In this tutorial, scroll down to
mp3 - MP3 sound format file. The default program is Windows Media Player

Download, save, the Default_MP3.reg file
(this is the file you get when you click on the mp3 link referenced above)
When the download completes, click Open folder
double click to merge.
answer any prompts with a YES
My System SpecsSystem Spec
11 Jun 2014   #8

64 bit
 
 

i could figure it out ^^ thanks for the help D
My System SpecsSystem Spec
11 Jun 2014   #9

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Glad you got it figured out and that it worked for you.
My System SpecsSystem Spec
2 Weeks Ago   #10

Windows 7 Ultimate x64
 
 

Hi
I don't know you still bother of this problem or not, but I recently found the solution and I prefered to share it.
first thanks to RoystarGamer for help and here's the solution:
Download this file, enjoy!
I hope your problem be solved.
My System SpecsSystem Spec
Reply

 MP3 album art not showing




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33