Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 ''Play All'' function not working properly

30 May 2015   #1
Hoblito

Windows 7 Ultimate x64
 
 
Windows 7 ''Play All'' function not working properly

Hello everybody!

I set MusicBee as my default music player and have associated files with it. Everything is working fine, except when i click ''Play All'' option for some folders it normally opens MusicBee and in others it opens Windows Media Player. It has absolutely nothing to do with different file types cause they are all mp3 files and also if I click on them individually they normally open in MusicBee as they should. So I figured everything should be ok if I just disabled Windows Media Player with ''Turn Windows Features On or Off'' option, but it didn't help because the ''Play All'' option that opened WMP before now simply does nothing.

Please help! How can i make ''Play All'' option always to open MusicBee?


My System SpecsSystem Spec
.
30 May 2015   #2
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Not sure what you mean. Here's how I use MusicBee.

Installation - not set as default player (don't associate any file types)

Setup - Scan files
Windows 7 ''Play All'' function not working properly-rescan_-add-files-playlists.jpg
If you want to play all tracks just open MusicBee and hit the play button. Or you can just create a playlist.


My System SpecsSystem Spec
30 May 2015   #3
Hoblito

Windows 7 Ultimate x64
 
 

Thank you, but it's not what i want. I just want to open the songs in any folder using windows 7 integrated ''Play All'' option.
My System SpecsSystem Spec
.

30 May 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
I don't know of any music player that plays via folders
Usually it's by albums...

I would also suggest creating playlist of the folders you have and use it like that which I'm sure is why you've been using Play all instead of opening wmp .... to play your music

It's really easy to create play lists,
Turn on wmp,
Select all of the files in your folder and right click one of them,
Click on Add to wmp play list,
Sort the files as you wish,
Save the play list.
Cheers.
My System SpecsSystem Spec
30 May 2015   #5
Hoblito

Windows 7 Ultimate x64
 
 

I guess I wasn't clear enough ... maybe it's because my English isn't quite perfect. Let me try to explain one more time.

1. I don't want to use Windows Media Player, I want to use MusicBee
2. I'm aware I can create playlists, add to Libraries etc., but my question wasn't about that ... it was about simple ''Play All'' function that is already there in any Windows 7 and why does it work normally for some music and not for the other.
My System SpecsSystem Spec
30 May 2015   #6
Hoblito

Windows 7 Ultimate x64
 
 

To be more precise ...


Attached Thumbnails
Windows 7 ''Play All'' function not working properly-play-all.jpg  
My System SpecsSystem Spec
30 May 2015   #7
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Okay I can see what you want to do now. It wasn't clear before. Personally I've never used the "Play All" button in Explorer.

Just tried it - and for me it opens the tracks in te folder in my default media player which is PotPlayer.

MusicBee - I prefer to install it as a non-default player and use playlists.

WMP - I don't use it and it's been removed via Control Panel.

So as far as I can work out you'd need to install MusicBee as your default player in order for PlayAll to work. Can't say for sure though as that button may still default to WMP if WMP is left installed.

Play All - plays tracks in default media player
Windows 7 ''Play All'' function not working properly-playall.jpg
Right click a track and "Play All" button changes to "Open" still using default media player.
Windows 7 ''Play All'' function not working properly-playall-2.jpg


My System SpecsSystem Spec
30 May 2015   #8
Hoblito

Windows 7 Ultimate x64
 
 

Yep, you got me now and I thank you for your time and advice. I'm aware of everything you said. The problem is that ''Play All'' normally plays tracks in my default media player (which is MusicBee), but for some reason (and I'd like to know that reason) in some cases it plays them in Windows Media Player or doesn't play them at all (if I remove Windows Media Player).

It's not such a big deal if you don't have the solution ... I can always make a playlist or just drag and drop songs in the player ... I was just curious if anybody knew why is it happening and if it's possible to fix it.
My System SpecsSystem Spec
30 May 2015   #9
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

As far as I can work out - the problem you are having is that some types of music file are still associated with WMP.

Check Control Panel

Use Small Icons View

Then Default Programs > Associate a file type or protocol with a program.

Wait while the list is built.

Sort the "Current default column" by A-Z

Scroll down and find any music file types that are still associated with WMP and change the association to MusicBee.

The other option is to right click on the problem track in your music folder and choose "Open With" > "Choose Default Program"

Select MusicBee and also the checkbox for "Always use the selected proram for this type of file"

If you don't see MusicBee listed - expand the plus [+] sign next to "Other Programs" and browse to the MusicBee executable and select it.

Edit:

Another option is right click on MusicBee shortcut icon and select "run as administrator"

Then in the top left select the drop down arrow next to MusicBee

Then Edit > Preferences

Under File Types - associate any problem file types and integrate with explorer.
My System SpecsSystem Spec
30 May 2015   #10
Hoblito

Windows 7 Ultimate x64
 
 

I've already done that all, but it seems that it's not the problem in file association cause when i click single files they open in MusicBee, but "Play All" opes Windows Media Player.
My System SpecsSystem Spec
Reply

 Windows 7 ''Play All'' function not working properly




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Hibernate Button Does Function Properly
When I clicked Hibernate, the screen turns off then after a few seconds, the screen will now show the account log in. I'm running Windows 7 64-bit Ultimate. I suspected this happened after I installed (dual boot) openSuse in the same partition where my Windows 7 is. Any solution?
General Discussion
Windows Internet Explorer AND sleep function not working properly!
I've never seen anything like this. Okay, here's the system rundown --- Running win 7 pro sp1 64 bit on a Dell xps 8000. Replaced hard drive one month ago, and I've used Seagate's diagnostic tool to check out hard drive, which didn't find any errors with the hard drive. So, here's problem 1:...
General Discussion
Programs Won't function/close down properly
Heya, I know that people have come across similar issues and I have looked through hundred of threads regarding each bit of software, but I now am thinking it is something for my case, stuffing everything up. My PC is fairly new, I know it's not my hardware. My problems I have are for...
Software
Modem/router function properly, but no internet
My modem (Siemens SpeedStream 4100) and router (Linksys WRT120) both function properly, but my desktop computer (HP-Pavillion Elite m9077c) won't connect to the internet. I never had a problem connecting up until a month ago, but since then, nothing. I know the modem and router function properly...
Network & Sharing
Windows SP1 - now explorer doesnt function properly
I installed SP1 last evening with no issues what so ever, but now today when I am using my computer I am not able to double click on anything in windows explorer. When I try and open a drive or a folder I get the message there is no default program associated with this type of file, please go...
Windows Updates & Activation
Can't Get AppLocker to Function Properly
Hello, I am trying to set up a user account that can be used to run Windows Media Center. I would like to restrict access to just about everything else on the operating system (files, programs, etc). It seems like AppLocker would be perfect for this. However, I cannot get AppLocker to...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App