Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MP3 album art embedded but not showing in W.Explorer

29 Mar 2011   #11


Wow, I didn't think people were posting in this thread.

I'm not sure if this will work for you but I managed to "solve" this in a really weird, roundabout way.

So say you have an entire album of MP3's where none of the album art is showing. I Ctrl+A to select all of them and then right click>Properties. Then I switched to the "Details" tab. There, make ANY chance to the details. I think I just erase the year and retype it again - it's not important what you type, you just need to change the file so that the "Apply" button becomes available.
After that, I hit Apply and for some miraculous reason, all the thumbnails start to show.

Let me know if this works! It's been working for me so far.

My System SpecsSystem Spec
29 Mar 2011   #12

Windows 7 Home Premium x64

Glad you sorted it out
My System SpecsSystem Spec
01 Apr 2011   #13

windows 7 professional

Quote   Quote: Originally Posted by Nishiio View Post
This is kinda irking me, haha.

I've been on vacation for the past couple weeks and took some time to organizing my music. I used MP3Tag to add album art to all the MP3 files.

Just yesterday, I was editing a certain album. Like usual, I highlighted all the files and drag+dropped a JPG file into the slot for album art. It saved and MP3 Tag shows all of the files with an image file.

However, NONE of these images show up in the music folder in Windows Explorer ie. it still shows the default MP3 file icon.

Here's an image to illustrate:

Thanks in advance for any advice. =)

Having the same problem, wondering if any solutions have come about. I know the tags are correct. WMP12 sees them. Media Monkey sees them. I tag editor sees them.

Also noticed if you highlite several files and drag them, the icon is a default icon instead of the album art like it was in the past. Been doing this for a while, just now having time to work on it.

Thanks in advance for any and all help.

My System SpecsSystem Spec

02 Apr 2011   #14

Windows 7 Home Premium x64 OEM --> RTM clean install

Hi twosteper, and welcome to the forums.

If I were you I'd ditch your current id3 editor and install the excellent, and free, Tagscanner. Then I check in Tagscanner that you have the album artwork embedded, if so then I'd rebuild your search index database.

Post back with updates...

Attached Thumbnails
MP3 album art embedded but not showing in W.Explorer-untitled.jpg  
My System SpecsSystem Spec
02 Apr 2011   #15

Win 7 Ultimate 64-bit SP1 (desktop)

Quote   Quote: Originally Posted by Gornot View Post
What'0s wrong with MP3tag all of a sudden, been using it for years.
MP3Tag is awesome, agreed!
My System SpecsSystem Spec
24 Apr 2011   #16

windows 7 professional

More information.

loaded a tagged album on a usb drive and took it to a friends house. His system shows the tags correctly when a single mp3 files is highlighted. The problem is not in the tagged files it is somewhere in the system that reads them.
I have also rebuild search database. I have also removed the files from wmp directory and re-installed the files to the library. Still no luck
Thanks again for any help.
My System SpecsSystem Spec
01 Jul 2011   #17

Windows 7 32 bit

I'm having this problem too on certain files. I embed the album art using MediaMonkey. The art shows correctly in mediamonkey and on my computer. But when I copy/move it to a network drive, it doesn't display or only show the art that was previously embedded. However when I change the filename the updated art appears and when I revert to the previous filename the problem appears again. Am I explaining this clearly? Even cleaning the tags doesn't help.

Update: NEVERMIND! I tried Nishiio's suggestion. Had to manually edit the file in the properties>details field through explorer rather than the player. The art shows correctly now.

Attached Images
MP3 album art embedded but not showing in W.Explorer-untitled.jpg 
My System SpecsSystem Spec
05 Sep 2011   #18

Windows 7 Ultimate Signature Edition // Windows 7 Home Premium

I am still having this problem and have not found a solution either.. Im about to just wipe and reinstall.
My System SpecsSystem Spec
05 Sep 2011   #19

Windows 7 Home Premium x64

Sometimes that's the only thing one can do at all. Next time you install the OS, make sure you DON'T use multiple programs of the same kind i.e. Winamp and iTunes. Some media players have a habit of fighting each other over file allocations; as a result, the aforementioned problem arises that can sometimes be fixed, sometimes not. It depends on a lot of things...
My System SpecsSystem Spec
13 Jan 2012   #20

Windows 7 Ultimate x64

The problem arises when your registry becomes corrupt or maybe some registry cleaner program deletes it thinking it's useless.
I copied this registry file from a friend's PC and imported it on mine. Magically, all MP3 files having album art (whether embedded or not) started showing thumbnails...
Issue Solved!!

Attached Files
File Type: reg MP3.reg (1.1 KB, 646 views)
My System SpecsSystem Spec

 MP3 album art embedded but not showing in W.Explorer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Windows Explorer Music libary not showing album artwork...
When opening Windows Explorer and then opening Music, I'm not seeing album artwork as I do when I open Windows Media player. Album artwork works fine in WMP 12 but not in the Explorer music library. All I see are the generic music notes. This has to be an easy fix, correct?
Music, Pictures & Video
ie11 Not Showing Embedded Videos
Windows 7 Home Premium SP1 with latest MS updates 64 bit Dell XPS 410 desktop. Embedded videos in IE11 do not how up. In Firefox not a problem. Uninstalled and re- installed Adobe Flash Player. Still not working. Shut down Windows Firewall no change. suggestions?
Browsers & Mail
MP3 album art not showing
I can't see any thumbnails in MP3 files (the folder art is visibile,though) anymore, only the file icons.The MP3 songs are already tagged, because when I open them with an editor like MP3 tag editor or a media player such as Winamp or Windows Media Player 12, the album art for all the MP3 songs is...
Music, Pictures & Video
How to Remove Album Art Images Embedded in MP3 Files?
Source - How to Remove Album Art Images Embedded In MP3 Files? - The Winhelponline Blog
Media Center
Album art of music are not showing in windows explorer
In windows explorer album art not showing. Even if i set icon to large. Any music player can show art when i play. But not showing in explorer. Videos and pictures are ok. sorry for my bad english writting. I'm not good at this.
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:58.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App