Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network issue with playing videos off a shared folder in my Home LAN


04 Jul 2012   #1
caffemisto

Windows 7 Professional 64bit
 
 
Network issue with playing videos off a shared folder in my Home LAN

Hi,

I've ran into a very strange issue at home when playing a video off a shared folder.

Both computers are running Windows 7 Professional and are connecting to the LAN at 100Mbit/Full.

On my main desktop, I've shared a drive with videos on it and on my HTPC, I've mapped a drive to that share.

Now I can access the videos through Windows Media Center. However, that's how far everything works just fine, because when I play a video off the shared drive, it stutters like crazy.

Even my buddy could not believe that's happening and he even said that he's using wireless to do the same thing I'm trying to accomplish. That the wired connection should be faster and smoother. LOL

So I went crazy on both computers disabling services and what not to see if it made a difference, but still get the stuttering video on my HTPC.

Currently disabled on both: Firewall, AntiVirus, Remote Differential and Windows Updates. I have also changed the hub connecting everything to a switch.

This is not a codecs issue. I can see the video content during the stuttering and when copied locally, the videos play just fine in Windows Media Center.

Please help. I'm very open to suggestions, even the ones where you poke fun at me.

Thank you.


My System SpecsSystem Spec
.

05 Jul 2012   #2
solarmystic

Windows 7 x64 Professional SP1
 
 

Hello caffemisto,

Just to exclude a few more possibilities, have you tried running the video content using an alternative video player like VLC for example?

VideoLAN - Official page for VLC media player, the Open Source video framework!

Have you also tried testing the general network connectivity between the machine serving the media and the HTPC playing it by copying files back and forth between machines to get an idea of the real bandwidth available to them?

I'm assuming that since both are on a wired, full duplex 100Mbits connection, realistic transfer speeds would top 8.5 - 9 MBps (Megabytes per second) if the network is idling.
My System SpecsSystem Spec
05 Jul 2012   #3
caffemisto

Windows 7 Professional 64bit
 
 

I will give VLC a try when I get home from work.

Also, while at work, I had another idea: I'm going to connect the computer in the garage directly to the main switch where the HTPC is already on. So it'll bypass the switch and see if that makes any difference.

I added a switch because I have a network printer and a workbench in the garage next to my main desktop.

I will try your idea first before fiddling with the cabling again.

Thanks.
My System SpecsSystem Spec
.


06 Jul 2012   #4
caffemisto

Windows 7 Professional 64bit
 
 

Well, I installed VLC on my HTPC, started a video off my other computer, everything started playing nice, then the colors started washing off and stuttering began shortly after.

So I connected my main desktop directly to the router where the HTPC is on and the stuttering plus washed off colors kept happening.

I also did a file copy from main desktop to HTPC and the speed was horrible, as if I was transferring files over a 28k modem line.

Thank you for your help, though. I'm just going to copy/move the videos off my main desktop to the HTPC's hard drive.

My System SpecsSystem Spec
08 Jul 2012   #5
Salohcin

64
 
 

Just out of curiosity , try doing a clean uninstall of firewall on both machines assuming that it is not windows firewall. Often disabling firewall isn't enough if its third party as there could be driver incompatabilities present etc or services still running even though you disabled the firewall.
My System SpecsSystem Spec
25 Jul 2012   #6
caffemisto

Windows 7 Professional 64bit
 
 

I found the culprit, here it goes:

Even though all computers were on the same router/switch, file transfer speeds were below 1Mbps with all the NICs set to 100/Full. It was so ridiculously slow I wanted to cry. LOL

There was still one more thing I hadn't tried: putting the computers on its own switch and uplink that switch to the main router.

As soon as I did that, the file transfer speeds went up to 20Mbps and more, and video playback over the wire stopped stuttering.

The culprit: AT&T Uverse's home gateway router. This device handles HomePNA for TV feed, a built-in 10/100 switch, DSL modem, Wireless access point and Internet routing. My feeling is that this device is tuned to give the TV feed top priority. I'm fine with that now, though.

Also, even my connection to the internet is faster on the wired computers. Before it felt like I was not getting what I paid for.
My System SpecsSystem Spec
Reply

 Network issue with playing videos off a shared folder in my Home LAN




Thread Tools



Similar help and support threads for2: Network issue with playing videos off a shared folder in my Home LAN
Thread Forum
How do I change shared network folder icons Network & Sharing
Solved Shared folder access/permissions issue Network & Sharing
Creating a home network for shared folders Network & Sharing
Streaming videos from WHS to laptop outside of home network Network & Sharing
Shared Folder over network problem... Network & Sharing
Browsing Win7 shared folders in home network - how??? Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:39 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App