Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help, Internet keeps dropping intermittently!

27 Jul 2010   #1

Windows 7
 
 
Help, Internet keeps dropping intermittently!

Right, this is going to seem like along post but I'm going to give you the full story so that maybe you can shed some light on it.

About a month ago my internet randomly stopped working on my Windows 7 machine showing the little red cross icon on the network icon, it had been working fine up until then and my laptop with WinXP continued to be fine using the same connection. When using the troubleshooter it told me it may be a problem with the LAN driver, so I uninstalled and reinstalled, tried a newer driver, tried an older driver, nothing worked.

Suspecting that it may be a problem with my onboard LAN (Realtek Gigabit Ethernet on an ASUS P5B) I bought a new network card and installed that but to no avail.

I then moved flat which had a different internet connection but still the internet would not connect on my machine despite working on other computers in the house.

So I decided a reformat was the only option. Reformatted and hey presto internet was working again, problem solved !

Except another problem has occured quite quickly after my reformat. The internet won't work every time a shut down and reboot the computer. I can sometimes solve the issue by running ipconfig /renew and sometimes by swapping the ethernet cable from the network card to the motherboards LAN port

This latter point made me suspect it might be athe conflict between the 2 ethernet ports causing the problem, so I removed the PCI-E network card but then was completely unable to get the internet connected, no matter how many times I rebooted or ran the ipconfig /renew

I've since reinstalled the Network card, rebooted the machine, internet not working but as soon as I switched the ethernet cable between the 2 ports a couple of times it starts working again as if by magic!

Any one got any thoughts on how to solve this issue, any input would be HUGELY HUGELY appreciated!

Cheers in advance

My System SpecsSystem Spec
.

27 Jul 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Nobull View Post
Right, this is going to seem like along post but I'm going to give you the full story so that maybe you can shed some light on it.

About a month ago my internet randomly stopped working on my Windows 7 machine showing the little red cross icon on the network icon, it had been working fine up until then and my laptop with WinXP continued to be fine using the same connection. When using the troubleshooter it told me it may be a problem with the LAN driver, so I uninstalled and reinstalled, tried a newer driver, tried an older driver, nothing worked.

Suspecting that it may be a problem with my onboard LAN (Realtek Gigabit Ethernet on an ASUS P5B) I bought a new network card and installed that but to no avail.

I then moved flat which had a different internet connection but still the internet would not connect on my machine despite working on other computers in the house.

So I decided a reformat was the only option. Reformatted and hey presto internet was working again, problem solved !

Except another problem has occured quite quickly after my reformat. The internet won't work every time a shut down and reboot the computer. I can sometimes solve the issue by running ipconfig /renew and sometimes by swapping the ethernet cable from the network card to the motherboards LAN port

This latter point made me suspect it might be athe conflict between the 2 ethernet ports causing the problem, so I removed the PCI-E network card but then was completely unable to get the internet connected, no matter how many times I rebooted or ran the ipconfig /renew

I've since reinstalled the Network card, rebooted the machine, internet not working but as soon as I switched the ethernet cable between the 2 ports a couple of times it starts working again as if by magic!

Any one got any thoughts on how to solve this issue, any input would be HUGELY HUGELY appreciated!

Cheers in advance

Are you by chance using "homegroup" for networking? On some mixed OS systems it has connectivity problems, because it uses IPv6. You can easily test it by creating a new network connection using workgroup. If it works you can disable IPv6 and kill homegroup.

Let us know if you need help

Ken
My System SpecsSystem Spec
27 Jul 2010   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

I would think about updating the firmware on the router before I did anything else.
My System SpecsSystem Spec
.


29 Jul 2010   #4

Windows 7
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post

Are you by chance using "homegroup" for networking? On some mixed OS systems it has connectivity problems, because it uses IPv6. You can easily test it by creating a new network connection using workgroup. If it works you can disable IPv6 and kill homegroup.

Let us know if you need help

Ken
That seems to have fixed it Ken, you're a lifesaver! Thanks very much
My System SpecsSystem Spec
31 Jul 2010   #5

Windows 7
 
 

Well the wokgroup fix had me running the internet problem free for at least three days and through several reboots but this morning, the same problem returned! Once again I was able to fix it by switching the ethernet cable from one LAN port to another...

Any other suggestions?
My System SpecsSystem Spec
31 Jul 2010   #6

Windows 7 Ultimate x64 SP1
 
 

Do you have jumbo frames enabled?
My System SpecsSystem Spec
01 Aug 2010   #7

Windows 7
 
 

Don't know what jumbo frames are or how I'd check if they were enabled Kegobeer. Pardon my ignorance!
My System SpecsSystem Spec
01 Aug 2010   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Nobull View Post
Well the wokgroup fix had me running the internet problem free for at least three days and through several reboots but this morning, the same problem returned! Once again I was able to fix it by switching the ethernet cable from one LAN port to another...

Any other suggestions?
I think I made a suggestion already but you didn't seem to notice it. My suggestion assumes that you want this problem fixed for good.
My System SpecsSystem Spec
Reply

 Help, Internet keeps dropping intermittently!




Thread Tools



Similar help and support threads for2: Help, Internet keeps dropping intermittently!
Thread Forum
Wireless internet sometimes dropping out Network & Sharing
Internet dropping.... Network & Sharing
Please Help. Internet dropping out Network & Sharing
Internet stops working intermittently on wireless Network & Sharing
Wireless Connection dropping intermittently Network & Sharing
Internet on/off intermittently Network & Sharing
Wireless Connection dropping intermittently Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:21 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33