Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No internet connection over LAN

15 Aug 2010   #1

Windows 7 Enterprise 64 bit
No internet connection over LAN

Ok, I have read every thread and tried everything I can think of, now I turn over my nightmare to people hopefully more attuned to 7 than I.
First the facts.
Internet over campus connection (I live in staff accommodation in a school in China) our building has shared wired internet. Our network is fine as people who are on xp and my desktop (win 7) are still receiving internet.
My laptop is running Windows 7 ultimate 64 bit, and until yesterday was fine. All of a sudden a yellow exclamation mark appeared over the LAN icon, and that was that, no internet over LAN.
I have disabled/enabled. Uninstalled/reinstalled. Updated drivers. Even reinstalled windows.
Wifi is fine, but this LAN thing is driving me crazy.
I've probably missed a ton of info, but I can't think straight as this has me really pissed!
Please Seven Forums members, your my only hope!

My System SpecsSystem Spec
15 Aug 2010   #2

XP, 7

if it's not working on a fresh install of windows, then sounds like a hardware problem.
try a different network cable
try a new NIC (you can get a USB NIC for super cheap from china on ebay)
My System SpecsSystem Spec
15 Aug 2010   #3

Windows 7 Enterprise 64 bit

I thought hardware too initially, I'm using an Acer 6920g laptop.
However the same problem has also arisen on my friends Asus laptop as well, and that is too much of a coincidence for it to be a hardware issue and is leading me to believe it is Windows 7 related.
If I have to go down to Vista or XP so be it, but I'd rather exhaust all other options first.
My System SpecsSystem Spec

15 Aug 2010   #4

Windows 7 Enterprise 64 bit

A small update.
I now have internet working on my Ethernet, HOWEVER it has placed me on Network 3!
Thus not letting view the other machines on my network!
Any advice on how I can get my laptop back onto the same network, while retaining my connection?!
My System SpecsSystem Spec

 No internet connection over LAN

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Try to update internet explorer 8, and lose internet connection
When i try to update internet explorer 8 i lose the internet connection. Windows 7, int exp 8 64 bit.
Browsers & Mail
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
LAN connection without internet stops wireless internet connection
Well I've fiddled around and searched to no avail ... I have some form of conflict between my main wireless network and a LAN I use for file transfer and streaming. The attached PDF file illustrates the setup. Basically, the wireless network is fine by itself. Music streams from the...
Network & Sharing
Fallback to second internet connection after internet access loss?
My computer has two network adapters connected to two different internet gateways. One is Ethernet and the other is WIFI. The Ethernet connection is first on the access order list (if you don't know what I'm talking about, see the image attached) and the WIFI is second. Today, the internet...
Network & Sharing
Internet connection error or internet Download Manager problem
I'm using IDM 5.19 build 3 in may DELL Studio 14 using Windows 7. Recently I cannot finish my downloads. When I start the queue the speed will be around 200kbps but after a few seconds the speed fluctuates and becomes slower. The speed becomes 5kbps or slower. Is this my internet connection or...
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:26.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App