Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DHCP not working after Windows 7 Upgrade

29 Aug 2010   #1
diyu01

Windows 7 Ultimate x64
 
 
DHCP not working after Windows 7 Upgrade

Hi, I have a machine that used to run Windows Vista Home Premium, and it is connected to a LinkSys router using DHCP. It worked fine. Also, I have a Windows 7 Ultimate laptop that connects to the same router using DHCP, it works fine too.

Today I upgraded the Vista machine to Windows 7. After the upgrade, the DHCP no longer works. The network status keeps showing "identifying..." and never can connect to the router. "ipconfig" shows a private local IP address. If I manually set the IP address to one that is normally assigned by router (192.168.1.100) and set the router (192.168.1.1) as default gateway, then everything works, but as soon as I set the IP address back to automatic, then it fails.

What could the problem be? Thanks!


My System SpecsSystem Spec
.
29 Aug 2010   #2
TooCrooked

Win 7 Pro x64
 
 

i've seen this behavior on XP, but i can't remember what the culprit was.

since i can't remember, i'd suggest (as a very long shot) repairing the adapter. it really isn't a repair as much as it is a windows reboot...
My System SpecsSystem Spec
30 Aug 2010   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by diyu01 View Post
Hi, I have a machine that used to run Windows Vista Home Premium, and it is connected to a LinkSys router using DHCP. It worked fine. Also, I have a Windows 7 Ultimate laptop that connects to the same router using DHCP, it works fine too.

Today I upgraded the Vista machine to Windows 7. After the upgrade, the DHCP no longer works. The network status keeps showing "identifying..." and never can connect to the router. "ipconfig" shows a private local IP address. If I manually set the IP address to one that is normally assigned by router (192.168.1.100) and set the router (192.168.1.1) as default gateway, then everything works, but as soon as I set the IP address back to automatic, then it fails.

What could the problem be? Thanks!
For this problem it can help to reset winsock.

1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue.


2. Type netsh winsock reset at the command prompt, and then press ENTER.

Note If the command is typed incorrectly, you will receive an error message. Type the command again. When the command is completed successfully, a confirmation appears, followed by a new command prompt. Then, go to step 3.


3. Type exit, and then press ENTER. You should be prompted to reboot, if not you should reboot and test.
My System SpecsSystem Spec
.

Reply

 DHCP not working after Windows 7 Upgrade




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 upgrade,Now sound card not working
Hi to all I have just got my tower back after my son upgraded me to windows 7-32 and just linked my speakers into the system and my sound card is not working,It is a Hercules muse XL MPN LWHA521-t9,A bit old but it also allows my disabled son to use the microsoft sidewinder wheel for his games,I...
Sound & Audio
Wireless not working after upgrade to Windows 7 Ultimate
Hi, I have a new laptop running Windows 7 Home Premium 64-bit. I installed Ultimate and now there is no way to make an Internet connection. The button that had the symbol where you click and connect to a network with Wi-Fi has disappeared. I tried turning the router on and off as well as...
Network & Sharing
DHCP - WIN7 64Bit - Not Working
Hello, I just installed a new version of windows 7 64bit Ultimate. I am currently having an issue with obtaining a IP address using DHCP. I can connect using a Fixed IP address. Windows defaults to 169.X.X.X address and subnet mask of 255.255.0.0. Any Ideas Of what could be the issue. ...
Network & Sharing
dns & dhcp not working in windows
after i upgraded vista to windows 7, i now have a problem that my internet is not working,i can ping external ips but no address resolution and if i made the connection to auto ip ...doesn't work.so that's dhcp & dns are not working.when i check in the services.msc the dhcp and dns services are...
Network & Sharing
Blu-Ray not working after Windows 7 Upgrade
I upgraded to Windows 7 Ultimate and now my Blu-Ray drive in my Sony VGN-FZ180E notebook pc will not work with Blu-Ray disks. Seems the device driver for the Mat****a BD-MLT-UJ-220 Blu-Ray drive has now become a standard Microsoft 6.1.7600.16385 driver from June 21, 2006. When I click to update the...
Drivers
Wireless not working after Windows 7 upgrade
I have an HP Pavilion dv7-1135nr laptop which I just upgraded to Windows 7 from Vista. Everything worked very smoothly until I noticed that my wireless adaptor doesn't work. Nothing I have tried allows me to get it working. the Adaptor is a Atheros AR5007 802.11b/g WiFi Adapter. If I go to the...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App