Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet sharing wifi and USb


19 Sep 2010   #1

Windows 7 Ultimate x32bit
 
 
Internet sharing wifi and USb solved

How should I bridge or share the internet between these two networks ?


Uploaded with ImageShack.us


My System SpecsSystem Spec
.

19 Sep 2010   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Bridging usually works best for ICS.

Here's a checklist of things for ICS and file sharing for 2 croslinked computers (in my case a Windows 7 and XP one):

- both computers set to the same workgroup
- restarts
- advanced sharing settings - all things turned on (network discovery etc.) except for password protected sharing
- bridged the connection with the internet
- turned on Internet Connection Sharing for the internet connection - this forced an ip to the other connection (192.168.137.1) and gave an option to select which connection should have access to the ICS (the second connection or the bridge - you choose the second / crosslinked cable connection)
- shared some folders on both computers
- worked instantly (the other pc aquired a correct ip and internet)

Using ICS (Internet Connection Sharing)

Notice how in the link above they use a switch to connect more than one computer to the ICS machine.

The way you are doing it may not work correctly because you are daisy chaining the ICS machines end to end.
My System SpecsSystem Spec
19 Sep 2010   #3

Windows 7 Ultimate x32bit
 
 

It working pretty awesome
My System SpecsSystem Spec
.


20 Sep 2010   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Looks good yousaf, second one shows no lost packets.
My System SpecsSystem Spec
21 Sep 2010   #5

Windows 7 Ultimate x32bit
 
 

How this looks


ANd look at this one. It starts from just next to my server laptop, Signal is -19,. when connect it from a crowed store room the signal drops to -50. It's around 65 when I put it behind a thick steel cabinet. It again raises to -25 when put it at 5 fts to the server laptop.
My System SpecsSystem Spec
23 Oct 2010   #6

Windows 7 Ultimate x32bit
 
 

Now again I'm having problem with this network. As you can see it is obtaining wrong ip


By yousaf465 at 2010-10-23


I tried to renew the ip and this is what I got

Code:
C:\Documents and Settings\compname>ipconfig /renew

Windows IP Configuration

No operation can be performed on Local Area Connection 3 while it has its media
disconnected.
An error occurred while renewing interface Wireless Network Connection : unable
to contact your DHCP server. Request has timed out.

Tried it again with both ether and wifi on

Code:
C:\Documents and Settings\compname>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Wireless Network Connection : unable
to contact your DHCP server. Request has timed out.

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.1.4
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Autoconfiguration IP Address. . . : 169.254.49.92
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . :
My System SpecsSystem Spec
24 Oct 2010   #7

Windows 7 Ultimate x32bit
 
 

I connected in Fedora (linux), working fine with this result. 10.42.43.1 for the host and 10.42.43.10 for the client running windows xp.

ifconfig
Code:
[liveuser@localhost ~]$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:30:0A:AF:BA:D6  
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::230:aff:feaf:bad6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27665 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34322 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20412861 (19.4 MiB)  TX bytes:11815939 (11.2 MiB)

eth1      Link encap:Ethernet  HWaddr 00:12:F0:27:5A:37  
          inet addr:10.42.43.1  Bcast:10.42.43.255  Mask:255.255.255.0
          inet6 addr: fe80::212:f0ff:fe27:5a37/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11923 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7536 errors:0 dropped:5 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8949521 (8.5 MiB)  TX bytes:13174731 (12.5 MiB)
          Interrupt:17 Base address:0x6000 Memory:dfdfd000-dfdfdfff 

eth2      Link encap:Ethernet  HWaddr 00:11:43:72:AC:3A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:900 (900.0 b)  TX bytes:900 (900.0 b)
Code:
Iwconfig gave this

liveuser@localhost ~]$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b  ESSID:"modem"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:12:F0:15:10:62   
          Bit Rate:11 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=97/100  Signal level=-27 dBm  Noise level=-85 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:0   Missed beacon:0

eth2      no wireless extensions.

pan0      no wireless extensions.
My System SpecsSystem Spec
24 Oct 2010   #8

Windows 7 Ultimate x32bit
 
 

This time bridging solved the problem. Hopefully it carries on. One questions remain how can you enable ICS and bridging on the same connection at same time ? I bridged my Internet connection and wifi adapter. And it working now.
My System SpecsSystem Spec
Reply

 Internet sharing wifi and USb




Thread Tools



Similar help and support threads for2: Internet sharing wifi and USb
Thread Forum
Wifi Sharing question Network & Sharing
Solved how do i use my laptop for sharing wifi Network & Sharing
Internet sharing via Virtual Wifi miniport drops internet access Network & Sharing
internet sharing via wifi from fedora to windows 7 Network & Sharing
Sharing wifi internet via ethernet Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:25 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33